Jump to content






Photo

Emby Server 4.0.1 Released

Posted by Luke , 21 January 2019 · 7671 views

4.0.1 has gone out to address a few issues we've uncovered with the new 4.0 release. Here are the highlights:

  • Fix movie matching regression of failing to determine movie year from file name
  • Fix sporadic video crashes on Apple TV
  • Improve external subtitles with HLS
  • Various fixes for .ignore files
  • Fix movie sub-folder detection with mixed content libraries
  • Add EMC seasons workaround
  • Fix editing of user preference access option
  • Fix A-Z picker on folders tabs
  • Add music videos to search results
  • Ensure resume options are available for audio books content type
  • Add played filter to songs tab
  • Remove display of year on collections list
  • Remove erroneous Dlna setting
  • Add list view to music screens
  • Show year for collection items
  • Show artists in playlists



  • SikSlayer, e123enitan, ShoutingMan and 3 others like this



Thanks for the hard work!

    • rathmore and stevenb@gmail.com like this
Photo
Richard Branches
Jan 21 2019 08:22 PM

How can I check for new updates? I can't find a button or an option inside the server, any help?

How can I check for new updates? I can't find a button or an option inside the server, any help?

 

Hi, the server handles this automatically. Please be patient and it will tell you when an update is available. Thanks !

    • Richard Branches likes this

Hi

My Windows 10 Pro Emby has updated to 4.0.1.0, on the 22nd of January.

 

There are two main problems for me with this update (and with V4 in general).

 

1. The DLNA service is not always picked up by my new LG TV, I have to physically restart the service on the hosting PC. Also, after watching something, and then 'left clicking' to go back to the menu to watch something else, the server disappears, and I have to repeat the restart on the PC.

2. Your previous version had a 'Folders' option where your server did not try and get clever with the content, and just showed what was in the folders.

 

This seems to have disappeared, and now my entire music collection (in d:\Music\A_To_M\A, e:\Music\N_To_Z\N  etc. format) is no longer visible as is - it is just a mess of files and folders and unusable. 

Not everyone wants their files organised for them. Are these problems going to be addressed or do I go back to Serviio?

Neither of these occurred prior to V4.

Hi

 

I'm my server is on Nvidia Shield. I received the message that an update is available and it tell me to shutdown the server but i don't see a download for an APK where do igo to find that?

 

Bdub44

I'm in trouble with this latest version... Every time I've open Kodi, it asks me for login on Emby server and my Series Library is missing...

I have exactly the same problem as spectrox.  I noticed that on every kodi/emby device, I now have to logon to emby every time I open kodi. My TV library is also no longer visible from the devices, even though I see the TV section is intact through the emby web interface.

Hi,

looking good, with a nice perf. bump! thx

 

However, as has happened with an older version some Months ago,

the Filter Checkbox for "Missing", when searching for TV Episodes, is in fact absent.

 

Having this checkbox is one killer feature for completionists and made me switch from plex!

 

I hope there's plans to re-introduce this feature...

 

greetings

ben

Many thanks for the hard work!

 

Will be checking it out asap

Quick question regarding the update, my library scan since the 4.x upgrade is still running (for about a week now). Can/shall I run the update, or let the scan finish before the restart?

I have the same problem (2) as borisx here.  All the folders I had setup previously are now "missing" and everything is just one jumbled mess.  Is this feature coming back?

 

 

Hi

My Windows 10 Pro Emby has updated to 4.0.1.0, on the 22nd of January.

 

There are two main problems for me with this update (and with V4 in general).

 

1. The DLNA service is not always picked up by my new LG TV, I have to physically restart the service on the hosting PC. Also, after watching something, and then 'left clicking' to go back to the menu to watch something else, the server disappears, and I have to repeat the restart on the PC.

2. Your previous version had a 'Folders' option where your server did not try and get clever with the content, and just showed what was in the folders.

 

This seems to have disappeared, and now my entire music collection (in d:\Music\A_To_M\A, e:\Music\N_To_Z\N  etc. format) is no longer visible as is - it is just a mess of files and folders and unusable. 

Not everyone wants their files organised for them. Are these problems going to be addressed or do I go back to Serviio?

Neither of these occurred prior to V4.

 

One of these last two updates has broken my interface.

I have several “libraries” separated by my likings on the main display as folders that open into my own defined genres. I use Zeiners icons for the folders. This has worked fine until at least the last two update possibly just this very last update.

Now the movies within the libraries are getting reassigned somewhat randomly when I update one movie image manually several change and now even the folder icon (Zenier) is changing to a movie icon from a sub folder within.

Now I am going to have to look up how to get the debugging info to you to sort it out when just a few days ago it had been working fine.

This happens whether I am managing through the main web interface on the server machine, an authorized access from another machine on the network or the iPhone app. This tells me it is part of the server side update that has broken things for me.

If I sound perturbed it’s because I got home Tuesday from a surgery out of town and came home to this mess... and nothing I do to restore the folder images and/sub folder images is working it just gets worse... I’ll try to get the necessary files together for a proper report but as I’m in recovery it is both slow going and infuriating...

For what it’s worth the web interface has become quirky. When viewing the media to edit individual movie images the web page that opens randomly stops taking keyboard entries and I have to reclining on the title to search for the meta-data to replace the wrong data being displayed when it does this hiccup several movies are getting grabbed and updated st once. All with the same image which is of course the wrong one.
Ok so I’m not sure exactly what happened with the update but apparently every movie with a blu-Ray folder structure somehow had its nfo files recreated one level higher in the folder hierarchy than it should have and then images were just bleeding over one another left and right. I think most of it is fixed now but some individual folders still somehow lost their proper images but it’s mostly correct now.

I had to repeatedly delete the nfo files as they repopulated until EMBY stopped recreating them. I’m guessing because I have all my genre folders actively watched for changes...

I can’t imagine I’m the only one this happened to but I don’t see any other complaints about it so my apologies for the tirade. It’s been a long week...
Ok so now as I try to update the movies to their original correct images Emby is continuing to populate data and images one folder higher than it should... so problem is not fixed...

Hi Luke, Thanks for this great work, one thing that I noticed in the new build is that it is missing media count, in previous version it displayed the count in Tv shows in my case 200, Movies 1000, now this could are gone, appreciate if this count can be reinstate or if there a function somewhere that I have to enable to see the count please let me know.

 

Cheers!

Photo
diamondplay22
Jan 25 2019 04:03 PM

how to remove playlists folder from new emby update

I should add this is on my roku.

 

 

I have the same problem (2) as borisx here.  All the folders I had setup previously are now "missing" and everything is just one jumbled mess.  Is this feature coming back?

I loaded this onto my FreeNAS-11.2-Release-U1 box overwriting the existing iocage jail which was on first version 4. All runs fine and no problems.

One nag can we have the number of films in the database back again between the two arrows that disappeared since the last version 3 it a useful thing if the Emby database has not picked up all the films. You can then compare the home folder with whats being shown the Emby database much quicker than going through everything on the screen.

 

Other than that keep up the good work, thanks. 

I too would like to get the media counter back...it's very useful to tell at a glance if I have a drive unplugged or whatever. Excellent work by the Emby team, I really appreciate the effort that is put in which is why I gladly pay for Premier. I came to Emby from Plex after the Roku disaster and will never go back. 

    • windozesuk likes this

I too would like to get the media counter back...it's very useful to tell at a glance if I have a drive unplugged or whatever. Excellent work by the Emby team, I really appreciate the effort that is put in which is why I gladly pay for Premier. I came to Emby from Plex after the Roku disaster and will never go back. 

 

I would also love the feature back in the next update if you could put it on the todo list. Much appreciated! Still loving my emby!

July 2019

S M T W T F S
 123456
78910111213
141516171819 20
21222324252627
28293031   

Recent Comments