Jump to content

Enableinusermenu access model changed in 4.11.04 or recent?


Recommended Posts

ginjaninja
Posted
PageInfo = new PluginPageInfo
{
    Name = "ManageComingSoonUser",
    DisplayName = "Manage Coming Soon",
    EnableInMainMenu = false,
    EnableInUserMenu = true,

My plugin provides user functionality via "enableinusermenu" / PluginUI ecosystem, recently users are presented with an an 'access denied message' "user X does not have access to ManageServer feature" when initially accessing the page.  Has something changed recently do i need to accomodate an updated way of working? It still working for admins. Thanks

 

Posted

Can they pull up the trakt or listenbrainz config screen?

Posted
14 hours ago, ginjaninja said:

My plugin provides user functionality via "enableinusermenu" / PluginUI ecosystem, recently users are presented with an an 'access denied message' "user X does not have access to ManageServer feature" when initially accessing the page.  Has something changed recently do i need to accomodate an updated way of working? It still working for admins. Thanks

This is what I had explained in a recent conversation: As you had noticed yourself already, this is not properly implemented, and never been looked at it. It even turned out to be a potential security risk, that's why we have disabled it until we have safe and a fully working implementation for it.

Thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...