Jump to content


Photo

Beta Roku app


  • Please log in to reply
79 replies to this topic

#61 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 17 December 2018 - 02:34 AM

I am having similar issues as @borngborn. I just recently switched from Plex to Emby and I'm loving this software, but like @borngborn I get an rgb fuzz when playing a 4k HEVC file. I attached some photos showing the issue. I havent tried the beta app but will check it out tomorrow.

Attached Files



#62 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131197 posts
  • Local time: 10:21 PM

Posted 17 December 2018 - 02:35 AM

What model Roku?



#63 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 17 December 2018 - 02:45 AM

Oh sorry forgot to post the TV model. It's a TCL Roku 65S405

Edited by camp8615, 17 December 2018 - 03:08 AM.


#64 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131197 posts
  • Local time: 10:21 PM

Posted 17 December 2018 - 12:57 PM

Oh sorry forgot to post the TV model. It's a TCL Roku 65S405

 

Ok, can we please go over an example? Please attach the information requested in how to report a media playback issue. thanks !



#65 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4611 posts
  • Local time: 07:21 PM

Posted 17 December 2018 - 01:24 PM

As well as providing the information requested above. I have two more questions. What firmware version is on your TCL RokuTV? What version of the Emby Roku app are you using?



#66 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 17 December 2018 - 10:24 PM

I have attached a log.txt file. My TCL Roku TV is running the latest firmware Roku OS 8.2. I am using the latest Roku version of the app 3.0.128 and tried the latest version of the Roku beta app 3.0.129 and I'm running  emby server version 3.5.3.0



#67 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4611 posts
  • Local time: 07:21 PM

Posted 17 December 2018 - 10:36 PM

@camp8615 As a test, can you try with Roku Media Player app? It will see Emby as a DLNA server. Browse to the same video this way and attempt to play. If it plays it with the same exact issue, which I suspect it will, this is a Roku firmware issue with 8.2.x on certain RokuTV models regarding bitrate of HEVC files. Unfortunately the only way to fix it is lower the bitrate in app to cause a transcode. With HEVC this comes with a heavy cost. I wish there was something we could do to work around this but this requires help from Roku with correcting their firmware. As a side note, depending on what container the item is in, with Roku you can use higher bitrate with MKV than you can with MP4. If the item is an MP4 with HEVC try a remux to MKV and see if it works.



#68 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 17 December 2018 - 11:13 PM

I'll try the Roku media player and see what happens. I'm wondering what Plex does to allow this file to play through the Roku. This is the only 4K HEVC I have, so I can live with it. If I were to post a Plex log would that be of any help?

#69 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4611 posts
  • Local time: 07:21 PM

Posted 17 December 2018 - 11:23 PM

I'll try the Roku media player and see what happens. I'm wondering what Plex does to allow this file to play through the Roku. This is the only 4K HEVC I have, so I can live with it. If I were to post a Plex log would that be of any help?

 

Plex is likely fully transcoding it. You can provide a log from them though if you want. Sure. We can do the same thing and transcode, but we always play directly if supported.

 

Press down on your Roku remote to open the video player OSD when that video is playing. Use the playback menu (3 sliders like a graphic equalizer) and choose the playback correction option. This will cause the video player to exit and restart with the next playback method. If it still has problems, use the playback correction button again. There are multiple playback methods it will use as you use that button multiple times. It should eventually resolve the problem using this option.


Edited by speechles, 17 December 2018 - 11:25 PM.


#70 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 17 December 2018 - 11:40 PM

Thanks man I appreciate the help. I really like this software more than Plex and like a lot of ppl came over from Plex due the direction Plex is heading.

#71 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4611 posts
  • Local time: 07:21 PM

Posted 17 December 2018 - 11:53 PM

We don't discriminate. Everybody is welcome. Welcome aboard.

 

We also take support seriously. So if you have any issues, thoughts, concerns, wishes, complaints, improvements.. Please let us know what we are doing right or wrong. We also take user feedback seriously. Thanks and merry christmas. :)



#72 ucliker OFFLINE  

ucliker

    Newbie

  • Members
  • 7 posts
  • Local time: 09:21 PM

Posted 18 December 2018 - 10:08 PM

Is there a place to download the latest Roku beta app? I just see random links in various threads but no testing section (unless I missed it).



#73 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131197 posts
  • Local time: 10:21 PM

Posted 18 December 2018 - 10:10 PM

Hi, yes instructions are on the download page of our website. Thanks.

#74 ucliker OFFLINE  

ucliker

    Newbie

  • Members
  • 7 posts
  • Local time: 09:21 PM

Posted 18 December 2018 - 10:29 PM

I found the link and I added it. Is there a changelog anywhere? 


Edited by ucliker, 18 December 2018 - 10:36 PM.


#75 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131197 posts
  • Local time: 10:21 PM

Posted 19 December 2018 - 12:31 AM

There is a Roku sub-forum under the Testing Area at the bottom of the community. That's where new testing versions are announced. Thanks.



#76 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 19 December 2018 - 04:52 PM

Update: 

 

So i tried all that @speechles said to do and was not able to get the stream to work on Emby or Roku Media Player. I went back to Plex and using the official Plex Roku app was able to get a direct stream for the HEVC video with HDR to work and the only thing being transcoded is the AAC audio from 7.1 AAC to 5.1 AC3. I am now going to transcode the audio on my MKV file myself and take out the VOBSUB subtitle file then remux and try again on Emby see if it'll will work. I attached 2 photos showing how its working on Plex and the Plex trancoder log see if it helps the admin.

Attached Files



#77 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 4611 posts
  • Local time: 07:21 PM

Posted 19 December 2018 - 05:05 PM

Are the VobSub forced or default? If you turn off those flags should be all you need to do. Not remove the subtitle entirely.


Edited by speechles, 19 December 2018 - 05:06 PM.


#78 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 19 December 2018 - 05:09 PM

no they are not default or forced just checked



#79 camp8615 OFFLINE  

camp8615

    Newbie

  • Members
  • 8 posts
  • Local time: 08:21 PM

Posted 19 December 2018 - 06:30 PM

So here are my findings: I transcoded AAC 7.1 to AC3 5.1 and EAC3 5.1 due to my current system capabilities and everything worked perfect. I did another test where i remuxed the .mkv file to have only the HEVC 4k video file and the AAC 7.1 audio and the same thing happened as before "RGB Fuzz". So i determined the culprit to be the AAC audio. My guess is Roku really does not like that codec. Thanks again for the help. I'm glad i was able to find a solution because like i said before I'm really liking this software and this community.


Edited by camp8615, 20 December 2018 - 01:04 PM.


#80 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131197 posts
  • Local time: 10:21 PM

Posted 19 December 2018 - 10:55 PM

Interesting, thanks for the info.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users