Jump to content

MediaPortal 2 Emby Support


Go to solution Solved by pünktchen,

Recommended Posts

arrbee99

Are you using the beta server of Emby?

But one after the other. Can you choose a channel group now inside the plugin?

 

Beta (always).

 

And yes I can...

 

5b0340947ee1f_EmbyMediaPortalMPExtendedC

 

And, even better, I think its now playing a channel (exclamation mark). Pretty sure it is but I've got about 4 different ways of playing the same stuff though confident its MP thats playing it.

 

But even though its playing at the moment running that schedule thing still gives the above mentioned Void error. Also, even though I've numbered the channels as...

 

5b03424f1fd6a_EmbyMediaPortalMPExtendedC

 

in Emby they're showing up as 1,2,3 etc.

 

 

 

Not quite so sure about the playing bit now, have one channel thats only on MediaPortal and just get spinning circle for that Edit - (and no sign of anything playing in dashboard).

Edited by arrbee99
Link to post
Share on other sites
pünktchen

And, even better, I think its now playing a channel (exclamation mark). Pretty sure it is but I've got about 4 different ways of playing the same stuff though confident its MP thats playing it.

...

Not quite so sure about the playing bit now, have one channel thats only on MediaPortal and just get spinning circle for that Edit - (and no sign of anything playing in dashboard).

If you have more than one tv plugin in Emby i suggest you to rename the channels at the backend  to differentiate them.

 

But even though its playing at the moment running that schedule thing still gives the above mentioned Void error. Also, even though I've numbered the channels as...

See my previous post at Luke. The plugin is broken now in the beta server  :angry:

 

in Emby they're showing up as 1,2,3 etc.

 Sorry, no channel numbers from MPExtended.

  • Like 1
Link to post
Share on other sites
arrbee99

Renamed so I can tell which is which. Doesn't appear to be playing anything via MediaPortal.

 

Does plugin broken automatically mean it won't play anything, or its affecting some other aspect.

 

Tried the preview in TVServer and it says 'Preview failed: Tune Cancelled' now. worked fine yesterday.

Link to post
Share on other sites
pünktchen

Renamed so I can tell which is which. Doesn't appear to be playing anything via MediaPortal.

 

Does plugin broken automatically mean it won't play anything, or its affecting some other aspect.

 

Tried the preview in TVServer and it says 'Preview failed: Tune Cancelled' now. worked fine yesterday.

Only retrieving of schedules is brocken. Playback and all the other stuff is working here.

Of course if the preview in TVServer doesn't work, it will not work in the plugin. It's possible that some of your other tv software has locked the tuner...

Link to post
Share on other sites
arrbee99

Quite possibly. Cleared caches and restarted machine and some channels played in the preview, and in Chrome (transcoding) and ET (direct play). Not sure why some don't, something to do with the source maybe. Will have to have another go later today. Thanks very much for your help. Shall probably pester you some more soon enough....

Link to post
Share on other sites
arrbee99

So just to mention, seeing as the object of the exercise, so far, is comparing TV start-up times, just a few results so far -

 

ET, direct play -

 

NextPVR plugin 8 sec

Mediaportal plugin 4 sec

Emby Hauppauge 8 sec

 

Chrome, transcoding - 

 

NextPVR plugin 13 sec

MediaPortal plugin 10 sec

Emby Hauppauge 8 sec

 

All playing the same channel.

Link to post
Share on other sites
pünktchen

Good. If you create a RAM disc drive for the timeshift folder of MediaPortal you will get another one or two seconds, depending on where it is right now.

Link to post
Share on other sites
arrbee99

Possibly. Not sure if I'm that adventurous yet though...

 

Besides I need to see how things go on Fire TV which isn't actually going at all at the moment as the latest beta (.89a I think) for that is somewhat broke....

Edited by arrbee99
Link to post
Share on other sites
pünktchen

@@Luke was it intentional that you've changed

public List<string> Genres { get; set; }

to

public string[] Genres { get; set; }

in TimerInfo of Mediabrowser.Controller/LiveTv in the beta server? If so, why not also for RecordingInfo and ProgramInfo?

Link to post
Share on other sites
Luke

Because that property on timerinfo is very new and I didn't expect that any plugins would be using it. If I change the others then all the plugins will need updates.

Link to post
Share on other sites
pünktchen

Because that property on timerinfo is very new and I didn't expect that any plugins would be using it. If I change the others then all the plugins will need updates.

New? Ha, you must be joking here because i use it in my plugin since 12 months already!
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...