Jump to content

Error: Script failed!:Version check


CBers

Recommended Posts

im85288

It doesn't look emby related from what I can see in the logs. Seems to be failing on a version check in a different script. Maybe you need to update kodi? What version are you running

Link to post
Share on other sites

As per the log, 14.2 ;)

 

Nothing has changed in the setup apart from the Kodi addon and Arctic Zephyr updates.

 

What do these relate to:

 

File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/__init__.py", line 307, in loads
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/decoder.py", line 319, in decode
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/decoder.py", line 336, in raw_decode
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/scanner.py", line 55, in iterscan
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/decoder.py", line 183, in JSONObject
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/scanner.py", line 55, in iterscan
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/decoder.py", line 183, in JSONObject
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/scanner.py", line 55, in iterscan
                                              File "/home/jenkins/workspace/Android-X86/tools/depends/xbmc-depends/i686-linux-android-android-14/lib/python2.6/json/decoder.py", line 227, in JSONArray
                                            ValueError: Expecting , delimiter: line 233 column 16 (char 7190)
Who is jenkins?

 

It's not me!

 

How do I see which addons have been updated recently?

 

.

Edited by CBers
Link to post
Share on other sites
Angelblue05

lol, maybe it's just a placeholder and then gets substituted by the real root later?

 

What I think happened is weather metoffice tried to use the same function as us at the same time and it locked up Kodi with the first error and when Kodi tried to verify version, it was already locked up and this is a side effect error so I wouldn't worry too much about it because technically it's supposed to represent your root folder. I think. :) You can try googling "/home/jenkins kodi"....See if anything interesting comes up?

 

All I know is that it's not a problem related to Emby. This is why I suggest you try to disable weather metoffice and see if you still get an error.

Edited by Angelblue05
Link to post
Share on other sites

For information, the above relates to my Nexus Player running Kodi.

 

I also have the same setup on my Fire TV and don't have that issue, bu I see there is an update to the VERSION CHECK script:

 

screen_FTV_10.png

 

screen_FTV_11.png

 

Although for some reason it won't download/update on my FTV.

 

Would/could this have caused the error on my NP ??

Link to post
Share on other sites

OK, I disabled the weather addon and reset my Kodi database, allowing a full sync to run, but I still get the same error when I restart Kodi.

Link to post
Share on other sites

For information, the above relates to my Nexus Player running Kodi.

 

I also have the same setup on my Fire TV and don't have that issue, bu I see there is an update to the VERSION CHECK script:

 

screen_FTV_10.png

 

screen_FTV_11.png

 

Although for some reason it won't download/update on my FTV.

 

Would/could this have caused the error on my NP ??

 

Looks like the service.py script was updated on my Nexus Player this morning.

 

Seems to be the one that won't update on the FTV.

Link to post
Share on other sites

OK, I've uninstalled the update to the Services - Version Check addon and I no longer get the error.

 

Current version is v0.32 with an update available to v0.34 which causes the issue.

 

Is there a Kodi forum this should be reported on?

 

.

Edited by CBers
Link to post
Share on other sites
marcelveldt

This error is known with the Kodi devs and the fix is already done, will be available soon on the official Kodi repo. Just ignore the error for now.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...