Jump to content

Subtitles with selective audio?


Recommended Posts

I didn't think this was a bug or issue, but wanted to see if anyone else has encountered this issue.

Wanted to watch a show with multiple audio options and subtitles.  Pressed play and I've got English subtitles and English audio. I wanted Japanese audio so I switched tracks and my subtitles no longer appear even though they show they are toggled on .

I've never had any issues like this and use subtitles frequently. 

I've tried multiple times with multiple subtitles but always the same result. English audio and subtitles are on, foreign audio, no subtitles. 

This appears to be isolated to one show, at least I hope.

Link to post
Share on other sites


This is the show with Japanese audio (FLAC) with English subtitles enabled, but they do not appear. There IS dialogue in the scene.


Here is the same video, with English audio (AAC Stereo) with English subtitles enabled, and they do appear. There IS dialogue in the scene.



Hopefully this illustrates my situation. If a server log would provide the information needed, let me know and I can duplicate this process again and pull the log with a timestamp.

In the grand scheme, it was weird it would play them for my native language where I don't necessarily need them, but not for the language I need them for lol.

Worse case, I'll learn me some Japanese and better better off in the long run. 


If you look at the filenames of the images, I mislabeled them, so disregard their filenames.

Link to post
Share on other sites
12 hours ago, Luke said:

How does the web app compare if you perform the same activity?

Not sure if you/I would believe it but, my first attempt it reacted the same way when I began the show from the beginning in Japanese with srt subtitles enabled. No subtitles. I switched the audio to English and still no subtitles, but Emby has turned them off when I changed the audio language to English. I toggled them on and it worked with English audio and English subs.

I switched back to Japanese audio and this time the subtitles did display.


I use subtitles 90% of the time regardless of audio language, and this is the first time I've encountered anything like this. More peculiar than anything else.

Log attached, in hopes that maybe it can show something. 

I believe the event occurs around 00:56:44



Atomic (Subtitle oddity) 00-56-44 timestamp embyserver.txt

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...