Jump to content


Photo

un8y - a WMC theme with a Windows 8 twist (and a template to create your own WMC theme)

Media Center theme neo

  • Please log in to reply
154 replies to this topic

#141 scottydog OFFLINE  

scottydog

    Newbie

  • Members
  • 6 posts
  • Local time: 07:34 AM

Posted 04 June 2014 - 05:54 PM

hi @keef - I've noticed another issue, not sure if this will be fixable though...

 

When a programme is flagged as HD on the guide page, it shows OK on the listing grid, but you can't really see it on the detail section below:

 

538f4062d7a36_HDscreengrab.png

 

I don't see the HD logo in the images folder, so I'm not sure if it's even in the resource dlls... not an issue if it can't be fixed / is too time consuming to change it as it's not really needed anyway (personal opinion anyway!).

 

Cheers


  • keef likes this

#142 keef OFFLINE  

keef

    Advanced Member

  • Alpha Testers
  • 97 posts
  • Local time: 07:34 AM
  • LocationBonnie Scotland

Posted 07 June 2014 - 07:47 AM

@scottydog, apologies for the slow response, I've been abroad with work.

 

I see from your epg that you're in Scotland too?

 

Thanks again for picking this up.  My PC TV tuner is SD only, so the HD logo doesn't show in my system.  It is fixable though - but I'll be working "blind", so it may take a couple of iterations.


Edited by keef, 07 June 2014 - 07:48 AM.


#143 keef OFFLINE  

keef

    Advanced Member

  • Alpha Testers
  • 97 posts
  • Local time: 07:34 AM
  • LocationBonnie Scotland

Posted 07 June 2014 - 08:11 AM

@scottydog - try this.  I'm relying on your feedback, because I can't see what it looks like in the epg.



#144 scottydog OFFLINE  

scottydog

    Newbie

  • Members
  • 6 posts
  • Local time: 07:34 AM

Posted 09 June 2014 - 03:57 PM

thanks @keef - that's not a slow response at all, I've seen cosmetic changes take months to get fixed in software! :-)

 

yep, I'm in Bonnie Scotland too - central belt for me... and WMC drives my main tv in the lounge, hence HD reception is a must these days

 

looking good to me - a definite improvement and keeps the red highlighting too - nice touch, hadn't thought of that myself! only issue I would say is it doesn't look 'sharp' - is there a slight gradient in the middle of the png? in this case I think it may look better just solid...

5395bd27c5f1c_hd_newscreengrab.png

 

many thanks again though for the swift response!



#145 keef OFFLINE  

keef

    Advanced Member

  • Alpha Testers
  • 97 posts
  • Local time: 07:34 AM
  • LocationBonnie Scotland

Posted 09 June 2014 - 04:18 PM

Glad I found the right image, @scottydog (BTW, I'm in the Central Belt too!).

 

OK, I can have a play around with the image a bit more, but I can't really see the effects of the various masks WMC applies to non-selected epg items, etc.  Maybe you could edit it so that it looks best to your taste: the image is METADATA.HDTV.PNG in \Theme\Resources\ehres\Images\

 

Here's a gradient one

and a solid one

 

(right click and save image as - you know what to call it and where to put it :P )


Edited by keef, 09 June 2014 - 04:28 PM.

  • scottydog likes this

#146 scottydog OFFLINE  

scottydog

    Newbie

  • Members
  • 6 posts
  • Local time: 07:34 AM

Posted 13 June 2014 - 05:52 AM

great, thanks @keef - I've picked the solid one, looks best to my (degrading by the day) eyes! I did try editing the original icon myself, but mspaint only gave me bright red and big blocks :-(



#147 paulpaul OFFLINE  

paulpaul

    Newbie

  • Members
  • 2 posts
  • Local time: 06:34 AM

Posted 04 February 2015 - 07:30 AM

Does anyone know how to change the background for a specific page? For exaple, to change the background of the picture gallery, I think I have to modify the file PHOTOSBROWSEPAGE.XML of the ehres.dll (expecially where there is "<backgroundpage url="common.background.xml"/>") but I wasn't able to obtain nothing.  :(  Anyone can please help me? thank you very much!



#148 keef OFFLINE  

keef

    Advanced Member

  • Alpha Testers
  • 97 posts
  • Local time: 07:34 AM
  • LocationBonnie Scotland

Posted 04 February 2015 - 09:45 AM

Hi @paulpaul!  So, you are directly editing ehres.dll?  Are you using Restorator? 
 
Have a look here - based on work done by bill24 (the guru of ehres modding, he used to hang out on the old Media Browser Community Tracker but don't think he's active on the new forum).


Edited by keef, 04 February 2015 - 09:45 AM.


#149 paulpaul OFFLINE  

paulpaul

    Newbie

  • Members
  • 2 posts
  • Local time: 06:34 AM

Posted 04 February 2015 - 08:45 PM

Thank you very much! I didn't find when I searched in the previous days for something like this :unsure:

 

The solution is great but not perfect, meaning that the backgrounds didn't fade.

That's why I tried to modify the RECORDEDTV.BROWSEPAGE.XML (just an example) by putting a navigateToAnimation="PageBackground.In" but the problem, after all, is that WMC is seeing it as a new istance (deleting the background of the start page).

I searched for a different solution, but even calling directly the PAGEBACKGROUND.MCML file, for example like for "PageBackground.mcml#AudioPageBackground" WMC creates a new istance.

At the end, after the full day  :huh:  , I success (I hope) calling something like <video:RecordedTVBrowsePage class="Page.Browse" IsWidescreenAware="true"
UIName="res://Microsoft.MediaCenter.Shell!BrowsePage.mcml#BrowseRECORDEDTV" />
inserting different copies of the same structure (having different background images) in BROWSEPAGE.MCML

I'm using Media Center Themer (great program!).

Do you have idea if it's possible to call 'something' like a program, a routine or an something like a system event from a MCML file? I would like to use a minimalistic remote control and, in order to do so, I need to use the same button for different functions (for example using the LEFT button to go left when in the user interface or SKIP when watching a video) but in order to do so, I have to notify Eventghost about the context: for example I tried watching, inside eventghost, if the FFDSHOW codec was running in order to understand if a video was playing ..everything was perfect, but WTV files doesn't use FFDSHOW :angry:  , so this is not a solution, that's why I was thinking calling something directly from a MCML file, but I have absolutelly no idea how to do this <_<

I'm using WMC from more than 10 years and I really love it.



#150 Nick's MCE OFFLINE  

Nick's MCE

    Advanced Member

  • Members
  • 253 posts
  • Local time: 04:34 PM
  • LocationAustralia

Posted 20 January 2016 - 03:03 PM

Hi

Just wondering if anyone has successfully used media centre themer on the MCE Hack for windows 10. Tried installing as I did in win 8 but cant get it to stick.

 

Thanks

Nick



#151 keef OFFLINE  

keef

    Advanced Member

  • Alpha Testers
  • 97 posts
  • Local time: 07:34 AM
  • LocationBonnie Scotland

Posted 22 January 2016 - 01:21 PM

Hi

Just wondering if anyone has successfully used media centre themer on the MCE Hack for windows 10. Tried installing as I did in win 8 but cant get it to stick.

 

Thanks

Nick

 

What version of Themer are you using?  Make sure you use v1.51.

 

I've not done much with W10, but I've just installed the MCE hack on W10 build 11102, then MCT v1.51 and finally un8y.  It all seems to work, but I guess time will tell whether it "sticks"...



#152 Lee OFFLINE  

Lee

    Advanced Member

  • Alpha Testers
  • 1157 posts
  • Local time: 06:34 AM
  • LocationBarnsley, Yorkshire. England

Posted 22 January 2016 - 06:17 PM

Hi

Just wondering if anyone has successfully used media centre themer on the MCE Hack for windows 10. Tried installing as I did in win 8 but cant get it to stick.

 

Thanks

Nick

have you tried using patchou? that works for definite... although w10 update wiped WMC entirely for me when the new build came thru. been ok since.



#153 a3gill OFFLINE  

a3gill

    Member

  • Members
  • 17 posts
  • Local time: 02:34 AM
  • LocationDeerfield Beach, FL, USA

Posted 23 September 2017 - 01:33 PM

Hello,

 

I know I'm pretty late to this, but curious if there is an active link to the un8y theme files still around? The original link is no longer active.

 

Thanks!



#154 keef OFFLINE  

keef

    Advanced Member

  • Alpha Testers
  • 97 posts
  • Local time: 07:34 AM
  • LocationBonnie Scotland

Posted 23 September 2017 - 01:58 PM

Hello,

 

I know I'm pretty late to this, but curious if there is an active link to the un8y theme files still around? The original link is no longer active.

 

Thanks!

 

Thanks for your interest in this.

 

Try the download link in the top post again - it should work now.



#155 a3gill OFFLINE  

a3gill

    Member

  • Members
  • 17 posts
  • Local time: 02:34 AM
  • LocationDeerfield Beach, FL, USA

Posted 23 September 2017 - 02:24 PM

Thanks for your interest in this.

 

Try the download link in the top post again - it should work now.

Awesome!

 

Thanks so much. It's there now.

 

Thanks again!







Also tagged with one or more of these keywords: Media Center, theme, neo

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users