Jump to content

Server keeps stopping


smawdsley
 Share

Recommended Posts

smawdsley

I've installed the Emby server through the Terramaster dashboard as well as direct download from the Terramaster site. When I install the Emby server it stays as Stopped, when I press start it says that it's successful but stays Stopped. I can't find any way of changing any settings. Any advice? I've got Emby Premiere for what difference that makes. All was fine a few months ago, I haven't used it for a while.

after start.png

press start.png

stopped.png

Link to comment
Share on other sites

smawdsley

4.5.2 is the file I got direct from the Emby/Terramaster website, I can't find any further updated file...

Link to comment
Share on other sites

smawdsley

I tried that before and got the same message as this time. Doesn't recognise it...

update.png

Link to comment
Share on other sites

smawdsley

The 64-bit one, but it happened with the ARMv8 one as well, which is why I didn't use the beta when I was trying to update it.

Link to comment
Share on other sites

Just now, smawdsley said:

The 64-bit one, but it happened with the ARMv8 one as well, which is why I didn't use the beta when I was trying to update it.

Well of course it's normal that it would happen with at least one of them. You can't just pick any one that you want and install it. You have to use the correct one based on your TerraMaster model.

What model do you have?

Link to comment
Share on other sites

smawdsley

Sorry, I meant that I used the stable 64bit one, tried updating to the beta and tried both files. I have the F4-220.

Link to comment
Share on other sites

alucryd

Works fine on my F2-220. I see you have an older firmware version, could you update your firmware first? Latest version is 4.2.09.

Also please make sure you do not modify the name of the package file you download from us in any way, terramaster is very picky about it. And preferably install it over wired network to ensure the file doesn't get corrupted.

Link to comment
Share on other sites

smawdsley

Thanks I'll try the firmware - I had it to update automatically and it hadn't done it. I haven't changed any filename, I've been installing it as soon as I download the files. The NAS is wired directly to the router.

Link to comment
Share on other sites

smawdsley

So the server now starts but it says it's a bad gateway when I link to it. The server downloads the ver 4.5 when I install it from the desktop app, when I try to use that it says bad gateway. It still says the ver 4.7 has an error when I try to install that. The ver 4.6 installs, says it's started but then says 'refuses to connect. The Emby server has the same IP address as my server (which I assume is correct?), so I know the IP address works.

Link to comment
Share on other sites

smawdsley

I install the 4.6.0 ver from the website but it says the ver is 4.5.2.0 after I install it.

Link to comment
Share on other sites

smawdsley

So I finally managed to get the 4.7.1 installed but as soon as I check the version of the app, it says it's 4.5.2 - I'm installing it through the Settings tab, install application manually.

Link to comment
Share on other sites

alucryd
23 hours ago, smawdsley said:

So I finally managed to get the 4.7.1 installed but as soon as I check the version of the app, it says it's 4.5.2 - I'm installing it through the Settings tab, install application manually.

The terramaster web ui doesn't properly reflect new versions when updating manually, did you check that one or the one inside emby? Emby itself should report the correct version.

Link to comment
Share on other sites

smawdsley
20 minutes ago, alucryd said:

The terramaster web ui doesn't properly reflect new versions when updating manually, did you check that one or the one inside emby? Emby itself should report the correct version.

I can't get into Emby without it telling me bad gateway. I've restarted the server after doing the updates, no difference. It works fine on my laptop but not on the NAS.

Link to comment
Share on other sites

alucryd

Ok. If you managed to install it it means it failed to start afterwards. There are only a few ways it can fail on x64 devices, I'd guess there may have been a leftover process from the 4.5 installation package. Could you try uninstalling emby, reboot, then install the latest package again?

Link to comment
Share on other sites

smawdsley
Posted (edited)

Uninstalled, restarted, reinstalled, restarted - still no luck. It currently says the server is started but I'll check how long that stays like that, but when I click the icon to open it I get he screen attached. I'm also getting regular messages about the CPU being above 90%. Is it worth mentioning that when I install it, I never get an Install Wizard? It just installs and I don't get any options.

Untitled.png

Edited by smawdsley
Link to comment
Share on other sites

smawdsley
On 06/06/2021 at 05:08, Luke said:

Are any log gives generated under /home/emby/logs?

I can't get into Emby to get any logs

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...