Jump to content

WAN connection to E4k Next Gen & Kodi 19


jachin99
 Share

Recommended Posts

I'm trying to test a remote connection from E4K to my emby server by attempting to use my domain name in the E4k Setup routine on my local network.   When I use my address of HTTPS://DOMAINNAME.us, E4k gives me an on screen error message telling me the address is not valid.  I use SSL for remote connections, and when I configure E4k, I use port 8920.  Is this a known limitation, or is there something else I should be doing?  Thanks

Link to comment
Share on other sites

If it works from outside your LAN it's most likely a router limitation.
I fixed that by setting up a reverse proxy in my LAN, but that requires some network knowledge.
An easy fix would be modifying the host file on your device to point the domain name to the correct local IP address.

Link to comment
Share on other sites

I might be able to throw up a quick reverse proxy.  Where is the host file on the Emby client in kodi?  Do i just modify the normal host file used by the browser instead, or how would I do that?  

Link to comment
Share on other sites

You need to modify the host file on every client. Thats the problem with going that route. With a reverse proxy there os no need to touch the clients. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...