Jump to content

Network Stream subtitles (not downloaded) are on by default suddenly for recorded TV


Recommended Posts

I have no idea when this started.

In our recorded TV, that is being streamed from TVHeadend and recorded by Emby, it seems the subtitles are on - this is the horrid black ones that never really match the spoken words.

If I press the subtitle on the shield TV, it gives the screen to download them - but this is recorded TV to the Recorded TV area, not somewhere I would want to download - to recap, these are the transmitted subtitles (closed captioning) that are sent from the TV network.

I have done googling, and many hits are from kodi users that can turn them on and off in the kodi client.

How does this work with emby clients - specifically Nvidia Shield.

I have taken the stream as used in emby ( and pasted it into VLC and each channel does NOT show them, and they can be turned on for each.

Somehow, I have got them on by default for emby / shield ?

Any ideas ?

Link to post
Share on other sites

Yep, just checked, set to none.

I have logged in as my kids too, recorded tv is doing the same for them.

We don’t watch a load of live TV, but this is a pain.


Link to post
Share on other sites

I have never had anything to do with these closed captioning things before.  I just had a play in the live TV, and the android TV SUB/Audio defaults seem to have no relevance.  I can’t make them come up no matter what I set them too.  This issue that started a few days back seems to force them on for recorded TV, but not for liveTV.

Link to post
Share on other sites

OK - I tried to be a bit scientific about this today.

Watched ABC news live from browser - no closed captions, Recorded a bit of it using emby (as I said, it is streamed from TVH if that matters).  Played back on browser - no closed captions, Played back on ShieldTV - no closed captions, so all good with that - unless for some reason there were none transmitted with that show at that time.

Moving on - 

I did the same tests with sesame street - no closed captions there either, looking good....

Moving on - 

I then did the same with 'The morning show' - no closed captions anywhere.

At this stage I started to doubt myself and went back to a recorded TV show I was trying last night -  Territory Cops - closed captions showing on that show on the shield TV.  Tried it on the browser, closed captioning also showing there.  So I opened the same file with VLC - and that also shows the closed captions and cannot be turned off.

In summary, I think that something somehow is forcing embedding of closed captions if they exist ?  Could a tvheadend update have caused that ?  There was one a few days back, but there has been two emby updates in that time also.  I dont believe this is an emby issue.

Any ideas ?



Link to post
Share on other sites

yep - sounds like - but not all shows seem to do it.

Any idea where to look ?

HDHR feed to TVH, then streamed to Emby......


Link to post
Share on other sites

So I checked around in TVH for anything that may cause this.

I changed the streaming profile to another one, rather than 'pass' and restarted.

I watched liveTV on emby (in chrome), and clicked the CC at the bottom right and it shows 'English (DVB_TELETEXT)' as an option that I can enable, they then show.  disabled, they are removed.

I then recorded the same show and watched it back and was also able to enable and disable these  'English (DVB_TELETEXT)' (much faster on recorded tv that live).

so..... I assumed the tvh stream profile was the cause, so I set it all back as it was (to 'pass') and restarted.

Re-did the same tests above with the same results.  

Seems the issue is not burning these in.  I repeated on two other channels with the same results.

Will see what happens on the usual scheduled recordings - maybe there is a scenario that I have not tested for.


I looked back in my recorded TV shows - as I have many going back days and weeks I can see roughly when the issue occurred.  The problem was not there on recordings 31 March and older, but is introduced on recordings from 3rd April on.  I just have to figure out what changed then.



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...