Jump to content

DSD dsf File Support for Emby Direct Play on Sony Blu-Ray UBP-X700 using DLNA and Remote App


thashisho
 Share

Recommended Posts

thashisho

Hello everyone,

I'm having trouble playing/streaming dsf music/audio files from Emby DLNA to my Sony Blu-Ray UBP-X700 using remote apps on my iPhone (mainly three: mConnect, 8Player Pro, and nPlayer Plus). Using the Twonky server, I have no issues what so ever direct streaming DSD dsf files to my UBP-X700 and from there playing it on my YAMAHA receiver which indicates its a DSD stream and plays it perfectly, even Multichannel DSD dsf files play perfectly with full surround. I don't even touch anything in terms of configurations in Twonky.

With Emby, this does not work. On my remote apps, it sees the Emby DLNA server perfectly with no issues. If I choose to play mp3 AC3 or even dts files, everything plays with no issues, however if I choose to play a DSD dsf file, I get an error message "device sent an error response" and "Open command failed" depending on the Remote app I use.

So, is there support to play DSD dsf files this way from Emby??!! I'm sure that it can be done, but how??

I would like to use Emby and I'm already on Premium and have come across some people on the Internet who successfully done that and be able to stream DSD dsf files over Emby's DNLA. I even seen a review about that somewhere on the net.

I would appreciate it if I can get an answer please.

 

Link to comment
Share on other sites

Hi there, let's look at an example:

Thanks.

Link to comment
Share on other sites

thashisho

Thanks Luke for your message and sorry for not sending the required information.

I hope that I had described the issue thoroughly enough, so what's missing is the information about what Emby software I'm running and the logs from the server. In terms of searching the Knowledge Base, I did that already and could not find any topics about "DSD" or "dsf" files playback.

I'm running the Emby Server on Windows 10 version 10.0.18363 machine. The Emby server version is 4.5.4.0

The server was put on DEBUG logging mode and the attached file contains the logs starting from the time I accessed the server using the two clients/remote applications on my iPhone namely "mConnect" and "8Player Pro" to play the "dsf" media files until getting the errors on both apps.

 

Emby Log APR0520201120PM.txt

Link to comment
Share on other sites

thashisho

Hello,

Anyone please would help with this issue. If more information is required please let me know.

Thank you...

 

Link to comment
Share on other sites

Hi, I'm really not sure what the issue is, but this might be improved for the next release if you'd like to try the 4.6 beta server. Just be advised you can't roll back to 4.5 if you decide to try it, and there could be issues as it's still a work in progress release (see the testing area of the community).

If you decide to try it, then please let me know how it turns out, and attach a new log file if there is still an issue. Thanks.

Link to comment
Share on other sites

thashisho

Thank you Luke for your reply. And yes please, I would definitely like to get 4.6 beta server to see if it solves my issue of not being able to play DSD dsf files from Emby Server using dlna through my Sony BD player.

Thank you for your help and support...

 

Link to comment
Share on other sites

Let us know how you get on. Thanks.

Link to comment
Share on other sites

thashisho

Hello,

So I downloaded and installed Emby server version 4.6 BETA and installed it. However, that did not fix my issue of not being able to DLNA direct stream .dsf (DSD) files to my Sony UBP-X700 bluray player from Emby server.

I had a look at the DLNA standard profiles for Sony Blu-ray Players and had noticed that there is no definition of dsd or dsf mime-types in all the files. Actually there is no reference at all to dsd or dsf in all the files as well. I tried to create a custom profile and defined dsf and dsd as direct play audio codecs/containers but all that did not work as well. Also I've noticed that in the <ProtocolInfo> definition in the profile files there is no http-get for dsf or dsd as well.

I've included the logs from Emby for reference. Please let me know if you want me to conduct more testing around this and/or if there is a profile that you want me to test going forward.

Thank you...

Log from Emby APR0720211017.txt

Link to comment
Share on other sites

The beta server has a new feature for Dlna, which is auto-detection of supported formats by querying the device's GetProtocolInfo method. This is what your device returned as the list of supported formats:

http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM
http-get:*:audio/mpeg:DLNA.ORG_PN=MP3
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
http-wavetunes:*:audio/x-ms-wma:*
http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO
http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO
http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_320
http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320

No dsf in there.

Link to comment
Share on other sites

That was for the Yamaha:

	DeviceDescription:
	FriendlyName:RX-V577 B4C0D7
	Manufacturer:Yamaha Corporation
	ManufacturerUrl:http://www.yamaha.com/
	ModelDescription:AV Receiver
	ModelName:RX-V577
	ModelNumber:V577
	ModelUrl:http://www.yamaha.com/
	SerialNumber:0E529CD3
2021-04-07 22:15:26.848 Debug Dlna: Dlna Device.GetConnectionManagerProtocolAsync
2021-04-07 22:15:26.848 Debug HttpClient: GET http://123.456.789.119:8080/ConnectionManager/desc.xml
2021-04-07 22:15:26.861 Debug HttpClient: POST http://123.456.789.119:8080/ConnectionManager/ctrl
2021-04-07 22:15:26.911 Info Dlna: Device GetProtocolInfoResponse Source: 
2021-04-07 22:15:26.911 Info Dlna: Device GetProtocolInfoResponse Sink: 
http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM
http-get:*:audio/mpeg:DLNA.ORG_PN=MP3
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
http-wavetunes:*:audio/x-ms-wma:*
http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO
http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO
http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_320
http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320

 

Link to comment
Share on other sites

thashisho

This is not the device I'm playing to Luke, this is strange!!

Anyways, this time I tried to play the file from the Emby web interface and chosen "Play On" to be the UBP-X700 device. The file did play, however it is transcoded to PCM (on my Amplifier it is saying PCM (should say DSD if it is Direct Play) also I can see ffmpeg running as well). It is not playing the file as a DSD file directly.

I have attached the new logs here and I have also noticed that for the capabilities inquiry for the device UBP-X700 it does include dsd.

2021-04-07 22:53:09.371 Debug Dlna: UBP-X700 - Received PlayRequest: PlayNow
2021-04-07 22:53:09.372 Info Dlna: Using default profile for:
    DeviceDescription:
    FriendlyName:UBP-X700
    Manufacturer:Sony Corporation
    ManufacturerUrl:http://www.sony.net/
    ModelDescription:
    ModelName:UBP-X700
    ModelNumber:BDP-2018
    ModelUrl:
    SerialNumber:
2021-04-07 22:53:09.372 Debug Dlna: Dlna Device.GetConnectionManagerProtocolAsync
2021-04-07 22:53:09.372 Debug HttpClient: GET http://123.456.789.23:52323/ConnectionManagerSCPD.xml
2021-04-07 22:53:09.377 Debug HttpClient: POST http://123.456.789.23:52323/upnp/control/ConnectionManager
2021-04-07 22:53:09.718 Info Dlna: Device GetProtocolInfoResponse Source: 
2021-04-07 22:53:09.718 Info Dlna: Device GetProtocolInfoResponse Sink: 

...................
http-get:*:audio/dsd:DLNA.ORG_FLAGS=9d700000000000000000000000000000
http-get:*:audio/x-dsd:DLNA.ORG_FLAGS=9d700000000000000000000000000000
..................

 

Log from Emby APR0720211051.txt

Link to comment
Share on other sites

thashisho

I really tried everything I could do right now. Even creating a new custom profile and adding the mime-types and the direct play entries for dsd and dsf with no luck what so ever. There is also an issue that editing the profile outside of Emby using a text editor and restarting the server, the custom profile just disappears from the DLNA Profiles although it is still available in the "user" directory.

I'm done exploring on my own. There is definitely something not right about Emby doing a Direct Play of DSD files. I'm sure that it can be done, but it needs to be revisited by the developers. The only two pieces of software so far that can do this is Twonky Server and JRiver Media Center with the first straight out of the box and the latter needed a small change in regards to the mime-type for dsf and that's it, it works perfectly.

Emby is amazing but I only wish it could stream DSD directly through its DLNA.

Thank you...

Link to comment
Share on other sites

  • 2 weeks later...
santakrooz

FWIW I'm having same/similar issue with Emby DNLA to Sony UBP-X700 with DSD content. This x700 network player plays DSD (.DSF) 2 channel and 5 channel content via DNLA from Twonky (yuk) and my NAS media servers but, for some reason (I assume due to x700 DNLA profile or description), Emby won't send any DSD content to the x700. It will send FLAC content to the X700. I am able to play the same DSFs from Emby to a Denon x4300h receiver on the same network but in a different location.  I will try to capture a log and post it. 

Link to comment
Share on other sites

thashisho

I totally agree @santakrooz with your analysis, it is definitely the DLNA profile for the X700 or for the Sony BD players profiles (I tried them all with no success). You say you can play DSFs from Emby to your Denon receiver which means it is a profile issue. I can play DSFs using Twonky and JRiver Media Center with the latter requiring a very minor change in the Mime types. Let's wait and see and I really hope this can be fixed in Emby as it is an amazing piece of software...

  • Like 1
Link to comment
Share on other sites

santakrooz

@Luke  all these Sony Blu Ray UHD network players are definitely DSD capable devices (x700, x800, x1000, and x1100 all are DSD UPnP/DLNA network players) and we are able to play DSD (both 2 channel and 5.1 DSFs) to these players fine from both Twonky and NAS media players via DLNA.  But for whatever reason Emby won't send any DSD to them at all, but will send FLAC ok. If the problem is the Sony profile response that the player reports back to Emby, is it possible for us to create a custom profile that will "override" it and let Emby and send DSD anyway?  Or is it something that we could look into getting a workaround/fix in Emby?  Happy to supply whatever you need logs, etc. I believe these are pretty popular Blu Ray players, and they are current models. Thx. 

Link to comment
Share on other sites

  • 1 month later...

Hi, have you tried this with the stable 4.6 release?

Link to comment
Share on other sites

thashisho

@santakrooz I got DSD playback using Twonky, Minimserver and JRiver but not Emby. Both JRiver and Minimserver required a modification of mime types of dsf and dff from audio/x-dsf to audio/x-dsd and from audio/x-dff to audio/x-dsd so the issue is not only the profiles but a change in mime types as well which I have no idea where to change in Emby that is if Emby is assumed to be able to stream dsd to dlna renderers such as the Sony X700…

 

Link to comment
Share on other sites

  • 1 month later...
cchsieh

I tried on the stable 4.6.4.0 ... 

I try to play dsf audio files from Emby web client to Sony SRS-HG1 speaker, but it seems transcode to mp3. I check the log and the server seems autodetect dsd for Sony speaker correctly. (Log file: embyserver.dsf.txt & ffmpeg-transcode*)

Then I try to create a custom profile for Sony SRS-HG1 and disable transcoding in the profile, but it still can't play dsf files directly. (Log file: embyserver.dsf.customprofile.txt & SONY SRS-HG1 TEST.xml)

It seems mime-type problem of dsd stream header.

Thanks in advance.

embyserver.dsf.txt ffmpeg-transcode-44e50ce6-80fd-46d5-8d26-436358a1414d_1.txt embyserver.dsf.customprofile.txt SONY SRS-HG1 TEST.xml

Link to comment
Share on other sites

  • 1 month later...
On 7/21/2021 at 9:30 PM, cchsieh said:

I tried on the stable 4.6.4.0 ... 

I try to play dsf audio files from Emby web client to Sony SRS-HG1 speaker, but it seems transcode to mp3. I check the log and the server seems autodetect dsd for Sony speaker correctly. (Log file: embyserver.dsf.txt & ffmpeg-transcode*)

Then I try to create a custom profile for Sony SRS-HG1 and disable transcoding in the profile, but it still can't play dsf files directly. (Log file: embyserver.dsf.customprofile.txt & SONY SRS-HG1 TEST.xml)

It seems mime-type problem of dsd stream header.

Thanks in advance.

embyserver.dsf.txt 150.7 kB · 1 download ffmpeg-transcode-44e50ce6-80fd-46d5-8d26-436358a1414d_1.txt 8.84 kB · 0 downloads embyserver.dsf.customprofile.txt 151.3 kB · 2 downloads SONY SRS-HG1 TEST.xml 3.21 kB · 1 download

@cchsieh in your case, your device reports support for the dsd container, but your media file has a container of dsf. I guess we'll just treat them as interchangeable. This will be in the next release of the server. Thanks.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...