Jump to content

Non-stop Intense disk activity.


brucesnelgrove
 Share

Recommended Posts

brucesnelgrove

Dashboard says Emby server is up to date. I am aware of 4.5.4. Server still scanning since last post.

So, where is this permission coming from?

 

Link to comment
Share on other sites

brucesnelgrove

Server indicates it is finished scanning, but there is still a lot of disk activity, so I'm sending you the log as an fyi. Update, apparently there is a network error going in Emby that is preventing it from saving lot. The hits just keep on coming.

Link to comment
Share on other sites

2 hours ago, brucesnelgrove said:

Dashboard says Emby server is up to date. I am aware of 4.5.4. Server still scanning since last post.

So, where is this permission coming from?

 

What he's saying is, it looks like you enabled saving metadata to nfo files, but did not grant the server write access to your media folders to do that.

Link to comment
Share on other sites

2 hours ago, brucesnelgrove said:

The server is going thru it's second scan. I didn't do anything. don't know where it's coming from. Seems to take forever between 95-100%. It still doesn't see a large percentage of my mp3s.

embyserver3.txt 9.89 MB · 1 download

The server runs a scheduled library scan every 12 hours by default. Have you explored the server scheduled tasks? You have the ability to control the schedule for each task to something that makes more sense for you.

Also...

Quote

2021-03-12 15:31:53.545 Debug App: Refreshing Audio /mnt/MediaSource/iTunes/Music/Neil Young/Decade/12 - Cowgirl In The Sand.mp3 due to configured automatic refresh interval
 

Why didn't you disable the automatic metadata refresh after I just pointed that out on the previous page? And this log still has debug logging turned on. 

Again - both features are very up front when you turn them on that they will cause additional disk access. Did you read the help text before you enabled them?

Link to comment
Share on other sites

brucesnelgrove

I turned on debug because I thought it might provide you with additional info, and it is off currently.. I have real time monitoring turned off on all libraries, and scheduled for once every 12 hours. If there are any other ways to turn off any automatic metadata refresh, I'll need to be guided to that setting. Also, any thoughts on why so many mp3's are not being "seen"?

 

Link to comment
Share on other sites

Quote

If there are any other ways to turn off any automatic metadata refresh

Hi, the same place where you turned it on. Go into the settings for each library one by one, click the advanced toggle in the upper right to show all settings, then locate this one and set it to never:
Untitled.png

Link to comment
Share on other sites

While you're in there, you probably want to turn off saving nfo metadata if you're not going to be granting emby server write access to your media folders.

Link to comment
Share on other sites

brucesnelgrove

I granted Emby all folders and file read/write access. I drilled down on TOS any permission related settings I could find. This seems to have cured the missing music issue. Thanks for your help. I am still running into the symptom where I can only play 2 consecutive songs before the Emby/Roku player stalls and has to be forwarded/reversed to another song before play will resume. Any thoughts?

 

Link to comment
Share on other sites

1 minute ago, brucesnelgrove said:

I granted Emby all folders and file read/write access. I drilled down on TOS any permission related settings I could find. This seems to have cured the missing music issue. Thanks for your help. I am still running into the symptom where I can only play 2 consecutive songs before the Emby/Roku player stalls and has to be forwarded/reversed to another song before play will resume. Any thoughts?

 

Can you please attach the emby server log from when this happened? Thanks.

Link to comment
Share on other sites

20 hours ago, brucesnelgrove said:

I am still running into the symptom where I can only play 2 consecutive songs before the Emby/Roku player stalls and has to be forwarded/reversed to another song before play will resume. Any thoughts?

Is the Roku screensaver popping up while the music plays? Roku has made our ability to dismiss that screensaver and keep playing music more difficult. But we will be looking at ways to improve this situation. If there is not any screensaver interrupt your music it is entirely different. Please attach Emby server logs and any relevant ffmpeg logs if this issue isn't caused by the screensaver. Thanks. :)

Link to comment
Share on other sites

brucesnelgrove

Ok. Seems the disk activity and missing mp3s were related to permission issues on TOS. But the  3 song stall is still going on with Emby player on Roku. I have included the log from the latest incident. This is just so odd, I'm interested what's causing it.

embyserver.txt

Link to comment
Share on other sites

brucesnelgrove

I diabled the Roku screensaver and it looks like that's IT! I can't believe I overlooked that. Thank you all for your patience and help.

Link to comment
Share on other sites

2 hours ago, brucesnelgrove said:

I diabled the Roku screensaver and it looks like that's IT! I can't believe I overlooked that. Thank you all for your patience and help.

Do you mean the Roku system screensaver? or in Emby?

Link to comment
Share on other sites

brucesnelgrove

I had already disabled it in Emby. Disabling the Roku screensaver solved my 3 song stall problem. However, I'm still getting disk activity when there is no scans going.( I have disabled all scheduled tasks), and it is still unable to recognize a significant chunk of music. Also, a new issue, Emby seems to replace the names of certain artists and albums with what appears to be random letters and numbers. Any thoughts? I have included some logs at the time. Look forward to your input.

embyserver (1).txt embyserver-63751920819.txt hardware_detection-63751920958.txt

Link to comment
Share on other sites

9 hours ago, brucesnelgrove said:

I had already disabled it in Emby. Disabling the Roku screensaver solved my 3 song stall problem. However, I'm still getting disk activity when there is no scans going.( I have disabled all scheduled tasks), and it is still unable to recognize a significant chunk of music. Also, a new issue, Emby seems to replace the names of certain artists and albums with what appears to be random letters and numbers. Any thoughts? I have included some logs at the time. Look forward to your input.

embyserver (1).txt 703.63 kB · 0 downloads embyserver-63751920819.txt 59.6 MB · 0 downloads hardware_detection-63751920958.txt 165.5 kB · 0 downloads

Hi, please try removing these plugins:

	CoverArt 4.1.10.0
	Diagnostics PlugIn 4.6.0.6
	Douban 1.0.3.0

Then restart the server and let us know if it performs better. Also can you update to Emby Server 4.5.4? Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...