Jump to content

Non-stop Intense disk activity.


brucesnelgrove
 Share

Recommended Posts

brucesnelgrove

This is has been going on for a while and it finally needs to be addressed. I have a TM F2-221 running 10TB RAID 0. With Emby being the sole software running, I am running into constant, relentless disk activity. Latest versions of NAS and Emby. Deleted Portmapper and two other plugins that I read might help. No go. Constant, Intense, Hard drive activity. Thanks in Advance.

Link to comment
Share on other sites

rbjtech

Unrelated to the issue but ..

RAID 0¬†ūüė¨

I hope you have a backup of all your media .. as if one disk fails, you will lose all the data on both drives.

If you don't want redundancy, fine, just use 2 x JBOD disks with emby, that way, if a single disk fails, then at least you only lose 50% of your overall data.

 

  • Like 1
Link to comment
Share on other sites

brucesnelgrove

Sorry, typo. Actually a RAID 1. Thanks for the heads-up, though.

 

  • Like 1
Link to comment
Share on other sites

brucesnelgrove

 

I have included 2 logs. The Emby server log should a prolonged period of intense disk activity. It is still going on while I write this(30 min). The second is the first of a process that repeated for hours.

 

In both instances,I felt I had to shut down the server because of intense activity.

Most importantly, the server is so busy I can't use it for movies music or anything else. It just keeps cycling.

 

FYI- I am the only user and Emby is the only software that is installed on the server. There is minimal activity at any given time.

 

 

 

embyserver.txt

ffmpeg-transcode-4c51a349-131d-493d-849d-8687497d944c_1.txt

Link to comment
Share on other sites

You had a library scan going on during the time of this log. Disk activity will be normal during this time. Can we look at a log from a different occasion when a library scan was not running?

Link to comment
Share on other sites

brucesnelgrove

Then it is always scanning. Of coarse, for some reason, disk activity has dropped to minimal. Sorry, I'll have to wait for the symptoms to reappear. Thanks for your patience. I'll be back.

Link to comment
Share on other sites

rbjtech

So a couple of things to look at -

1) debug logging is on - this increases disk i/o to the log file - turn off if not required. 

2) ensure your scanning 'schedule' is set to what you need.  It may be set to scan when first powered up, and/or every X minutes/hours.    A periodic scan is a good idea, but maybe set this to once a week, very early morning etc so it doesn't conflict with your viewing times.  Click the clock icon in 'Schedule' to change it.

3) check your settings for BIF file creation - this can be intensive if run on a fresh install but is only done once.  A lot of new media will again create a lot of activity depending on how you have scheduled the task to run - a) when adding the media or b) on a scan (ie '2' above)

I hope that helps.

Capture.PNG

Edited by rbjtech
Link to comment
Share on other sites

Quote

1) debug logging is on - this increases disk i/o to the log file - turn off if not required. 

Oh yes good catch, I missed this. It even states on the configuration screen when enabling debug logging that it will result in increased file system access.

Did you make note of that when you turned it on? Or did we ask you to turn it on to troubleshoot another issue?

Link to comment
Share on other sites

roaku
16 minutes ago, Luke said:

Oh yes good catch, I missed this. It even states on the configuration screen when enabling debug logging that it will result in increased file system access.

Did you make note of that when you turned it on? Or did we ask you to turn it on to troubleshoot another issue?

The original poster has not confirmed he has/had debug logging on.

Link to comment
Share on other sites

Just now, roaku said:

The original poster has not confirmed he has/had debug logging on.

It is in the log he attached. 

Link to comment
Share on other sites

Happy2Play

To me at least from that log RTM is seeing Music updates and refreshing all albums.

@LukeCould all of .DS_Store items be a issue?  Would need to see additional server logs to see if Music is in a refresh loop.

	Line 281: 2021-03-10 07:25:16.931 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/.DS_Store
	Line 284: 2021-03-10 07:25:24.214 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/VA - A Very Special Acoustic Christmas/.DS_Store
	Line 288: 2021-03-10 07:25:30.101 Debug LibraryMonitor: Resetting file refresher from /mnt/MediaSource/iTunes/Music/VA - A Very Special Acoustic Christmas/.DS_Store to /mnt/MediaSource/iTunes/Music/VA - A Very Special Acoustic Christmas
	Line 289: 2021-03-10 07:25:30.118 Debug LibraryMonitor: Resetting file refresher from /mnt/MediaSource/iTunes/Music/.DS_Store to /mnt/MediaSource/iTunes/Music
	Line 774: 2021-03-10 07:27:11.162 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/.DS_Store
	Line 2740: 2021-03-10 07:29:24.952 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/VA - Ultimate Christmas/.DS_Store
	Line 3116: 2021-03-10 07:29:45.363 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/VA - The Greatest Eighties Album/.DS_Store

 

Link to comment
Share on other sites

27 minutes ago, Happy2Play said:

To me at least from that log RTM is seeing Music updates and refreshing all albums.

@LukeCould all of .DS_Store items be a issue?  Would need to see additional server logs to see if Music is in a refresh loop.


	Line 281: 2021-03-10 07:25:16.931 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/.DS_Store
	Line 284: 2021-03-10 07:25:24.214 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/VA - A Very Special Acoustic Christmas/.DS_Store
	Line 288: 2021-03-10 07:25:30.101 Debug LibraryMonitor: Resetting file refresher from /mnt/MediaSource/iTunes/Music/VA - A Very Special Acoustic Christmas/.DS_Store to /mnt/MediaSource/iTunes/Music/VA - A Very Special Acoustic Christmas
	Line 289: 2021-03-10 07:25:30.118 Debug LibraryMonitor: Resetting file refresher from /mnt/MediaSource/iTunes/Music/.DS_Store to /mnt/MediaSource/iTunes/Music
	Line 774: 2021-03-10 07:27:11.162 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/.DS_Store
	Line 2740: 2021-03-10 07:29:24.952 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/VA - Ultimate Christmas/.DS_Store
	Line 3116: 2021-03-10 07:29:45.363 Debug LibraryMonitor: New file refresher created for /mnt/MediaSource/iTunes/Music/VA - The Greatest Eighties Album/.DS_Store

 

Yes for the next release I'll update the realtime monitor to ignore changes to .ds_store files.

Link to comment
Share on other sites

@brucesnelgrove you have also configured your library to do a full metadata refresh every X number of days:

Quote

2021-03-10 07:38:56.728 Debug App: Refreshing Audio /mnt/MediaSource/iTunes/Music/Various Artists/One Hit Wonders/95 Have I the Right.mp3 due to configured automatic refresh interval
 

This will cause your library scans to take longer. Again, it's also noted in the help text underneath the option:

Enabling this option may result in significantly longer library scans.

Do you think it's possible that you've turned a number of things on, all of which come with a cost, and now you're penalizing us for that ?

Link to comment
Share on other sites

brucesnelgrove

Thanks for the suggestions. Debugging was turned on-now off. Now going through the rest of the suggestions. Additional symptom presented itself and is still present, Emby wn't play more than 2 1/2 songs(mp3) and then quits. the screen says it is still playing. when I pause and then play again, no effect. It is not untill I go forward or backward a song does it start playing, and then it is only 2 songs and a bit of the third until it stalls again. Any thoughts?

Link to comment
Share on other sites

4 minutes ago, brucesnelgrove said:

Where would I find the setting for the BIF file creation?

It's the video preview thumbnail option for each library.

Link to comment
Share on other sites

15 minutes ago, brucesnelgrove said:

Thanks for the suggestions. Debugging was turned on-now off. Now going through the rest of the suggestions. Additional symptom presented itself and is still present, Emby wn't play more than 2 1/2 songs(mp3) and then quits. the screen says it is still playing. when I pause and then play again, no effect. It is not untill I go forward or backward a song does it start playing, and then it is only 2 songs and a bit of the third until it stalls again. Any thoughts?

Can we please look at an example? Thanks.

Link to comment
Share on other sites

brucesnelgrove

I select an album.  Play or shuffle doesn't matter. I listen and notice the music has stopped. I look at the screen and emby shows it has stopped(no progression), always around halfway through the third song. I press pause-no response. I press play-no response. It only resumes if I get out of the song altogether. The pattern repeats itself. Any other detail I can provide, please let me know.

Link to comment
Share on other sites

33 minutes ago, brucesnelgrove said:

I select an album.  Play or shuffle doesn't matter. I listen and notice the music has stopped. I look at the screen and emby shows it has stopped(no progression), always around halfway through the third song. I press pause-no response. I press play-no response. It only resumes if I get out of the song altogether. The pattern repeats itself. Any other detail I can provide, please let me know.

Hi, yes please attach the emby server log from when this happened. Thanks.

Link to comment
Share on other sites

brucesnelgrove

Just a bit of context. Emby wasn't recognizing a large percentage of my music files. I have artist and albums not being recognized. Example: Nazereth. I have 13 albums. Emby recognizes 1 and I can't see a pattern why the other 12 won't show up. I just want emby to see the other music files.

Link to comment
Share on other sites

brucesnelgrove

The server is going thru it's second scan. I didn't do anything. don't know where it's coming from. Seems to take forever between 95-100%. It still doesn't see a large percentage of my mp3s.

embyserver3.txt

Link to comment
Share on other sites

Happy2Play

Why are you on 4.5.2.0?

You have some permissions issue in your Music library.

2021-03-12 15:15:08.829 Error ProviderManager: Error in metadata saver
	*** Error Report ***
	Version: 4.5.2.0
	Command line: /mnt/md0/application/emby-server/system/EmbyServer.dll -programdata /home/emby -ffdetect /usr/local/emby-server/bin/ffdetect -ffmpeg /usr/local/emby-server/bin/ffmpeg -ffprobe /usr/local/emby-server/bin/ffprobe -defaultdirectory /mnt -updatepackage emby-server-terramaster_{version}_x86_64.tar.xz
	Operating system: Linux version 4.13.16 (root@developer) (gcc version 7.1.0 (Buildroot 2017.08-rc1)) #446 SMP Thu Nov 19 16:35:43 CST 2020
	Framework: .NET Core 3.1.7
	OS/Process: x64/x64
	Runtime: mnt/md0/application/emby-server/system/System.Private.CoreLib.dll
	Processor count: 2
	Data path: /home/emby
	Application path: /mnt/md0/application/emby-server/system
	System.UnauthorizedAccessException: System.UnauthorizedAccessException: Access to the path '/mnt/MediaSource/iTunes/Music/Susan Tedeschi/Better Days/album.nfo' is denied.
	 ---> System.IO.IOException: Permission denied
	   --- End of inner exception stack trace ---
	   at Interop.ThrowExceptionForIoErrno(ErrorInfo errorInfo, String path, Boolean isDirectory, Func`2 errorRewriter)
	   at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String path, OpenFlags flags, Int32 mode)
	   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
	   at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, Int32 bufferSize, FileOpenOptions fileOpenOptions)
	   at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, Boolean isAsync)
	   at NfoMetadata.Savers.BaseNfoSaver.SaveToFile(Stream stream, String path)
	   at NfoMetadata.Savers.BaseNfoSaver.Save(BaseItem item, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Manager.ProviderManager.SaveMetadata(BaseItem item, LibraryOptions libraryOptions, ItemUpdateType updateType, IMetadataSaver[] savers, CancellationToken cancellationToken)
	Source: System.Private.CoreLib
	TargetSite: Void ThrowExceptionForIoErrno(ErrorInfo, System.String, Boolean, System.Func`2[Interop+ErrorInfo,Interop+ErrorInfo])
	InnerException: System.IO.IOException: Permission denied
	Source: 
	TargetSite: 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...