Jump to content

Unable to start emby service with latest beta


xd003
 Share

Go to solution Solved by Luke,

Recommended Posts

xd003

Its been a while since i used emby . So i thought to give the latest beta a try . I downloaded the latest beta from here - https://github.com/MediaBrowser/Emby.Releases/releases/download/4.6.0.28/emby-server-deb_4.6.0.28_amd64.deb and installed it . Then i enabled and started the service through systemctl

sudo systemctl enable emby-server && sudo systemctl start emby-server

But for some reason , the service is not running / crashing . sudo systemctl status emby-server returns the following

● emby-server.service - Emby Server is a personal media server with apps on just about every device.  
Loaded: loaded (/lib/systemd/system/emby-server.service; enabled; vendor preset: enabled)

Active: inactive (dead) since Wed 2021-02-24 05:17:27 UTC; 28s ago     

Process: 49019 ExecStart=/opt/emby-server/bin/emby-server (code=exited, status=0/SUCCESS)

Main PID: 49019 (code=exited, status=0/SUCCESS) 

Feb 24 05:17:27 xd003 emby-server[49019]:         InnerException: System.Net.Sockets.SocketException: Address already in use
Feb 24 05:17:27 xd003 emby-server[49019]:         Source: System.Net.Sockets
Feb 24 05:17:27 xd003 emby-server[49019]:         TargetSite: Void UpdateStatusAfterSocketErrorAndThrowException(System.Net.Sockets.SocketError, System.String)
Feb 24 05:17:27 xd003 emby-server[49019]:            at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)
Feb 24 05:17:27 xd003 emby-server[49019]:            at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
Feb 24 05:17:27 xd003 emby-server[49019]:            at System.Net.Sockets.Socket.Bind(EndPoint localEP)
Feb 24 05:17:27 xd003 emby-server[49019]:            at Microsoft.AspNetCore.Server.Kestrel.Transport.Sockets.SocketConnectionListener.Bind()
Feb 24 05:17:27 xd003 emby-server[49019]:         
Feb 24 05:17:27 xd003 emby-server[49019]: Info Main: Shutdown complete
Feb 24 05:17:27 xd003 systemd[1]: emby-server.service: Succeeded. 

 

Edited by xd003
Link to comment
Share on other sites

  • Solution

Hi, I would try rebooting your machine. This error suggests the server is unable to bind to the http ports that it uses.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...