Jump to content

[solved] In-app purchase for FireTV app not working on FireTV Stick 4K with 2FA enabled


Go to solution Solved by bigcookie,

Recommended Posts


I wanted to purchase the in-app activation of Emby app on my FireTV Stick 4K as well. I installed it and went through the purchase process, but I cannot hit the "ok" button after entering the OTP. The FireTV highlights the "Continue" (not sure about the wording) when navigating to it, but hitting the "select button" on the remote doesnt activate/push it. As such I cannot move forward.

Is there a way to fix this or is there another way to buy the in-app purchase?

Thanks, regards


Edited by bigcookie
Link to comment
Share on other sites

  • Solution

Fixed it!

I had to temporarily turn-off 2-factor authentication in my amazon account via PC. Not ideal, but works. Afterwards re-enable it and done.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...