Jump to content

error port mapper

Recommended Posts


Buenas tardes.

Recientemente me Emby me da fallos y me bloquea la raspi (me deja sin accesto tanto por ssh, como VNC).

MIrando los log que hace Emby (una maravilla, por cierto), encontre este error: https://pastebin.com/bu3m0DN9

Entonces no se exactamente como solucionarlo.

He hecho un sudo apt-get autoremove mono-devel, sudo apt-get purge mono-devel*, dado que hace dos días quise instalar sonarr, y al parecer eran paquetes necesarios. Pero me salio un poco mal, no me dejaba actualizar indexers, y al final lo desinstalé.

Hay alguien que pueda arrojarme algo de luz en este asunto, por que pasa, y como puedo solventarlo?

Gracias de antemano.

Link to post
Share on other sites

Hi there, can you please attach the complete emby server log? thanks.

Link to post
Share on other sites

Hi there.

Thanks for answering.

Here we go: log from 19/10/2020: https://pastebin.com/2E66kGjj

Today's log: https://pastebin.com/Atsidwmi

True though today it hasn't stopped. So, honestly I don't know what was happening the last two days. If you could shed a light on the issue I would be more than thankful.

Hope it serves the data.

Best regards,
Dan P.

embyserver-63738687814.txt embyserver-63738778177.txt embyserver.txt

Edited by danpacu
attached files forgotten
Link to post
Share on other sites
  • 3 weeks later...
On 10/20/2020 at 5:40 PM, Luke said:

Hi there, can you please attach the complete emby server log? thanks.

hello again.

Sorry to disturb again, but I still have the same problem. Eventually, it blocks my raspi due to large number of errors (my guess, only - I insist in letting you know that I am only an enthusiastic learner in the field of raspberry, not a programmer at all - therefore I can only guess).

Hope that the last log may shed some light upon the issue.

Please, help me out understad what is it all about, and, if possible, how can I fix it!

Thanks in advance.


Link to post
Share on other sites

Hi, If you want to get rid of the port mapper errors then you can turn this off.

Go to the Network menu in Emby dashboard and uncheck "Enable automatic port mapping".
You can then remove the Port Mapper plugin from the Plugin Menu.

With this you do need to manually setup port forwarding in your router as Emby won't be able to do it for you.

Link to post
Share on other sites

Hi. Thanks a lot for the tip. I'll try it right now.

Hope it fixes the issue on my raspberry pi. Much appreciated your advice.


  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...