Jump to content

Docker HWA


postboy99

Recommended Posts

postboy99

Hi guys,

I run Emby on a Synolgy NAS and it's working fine.

For quite some time I want to move to Docker but I cannot get hardware transcoding to work.

It's just not detecting VAAPi like Emby directly installed on NAS and of course I've put in the Emby premiere key.

I've also tried :latest and :beta and even linuxserver/emby docker all with no success.

Here is my docker configuration:

#!/bin/bash
docker run -d\
  --name=emby1 \
  --net=bridge \
  -e UID=1042 \
  -e GID=100 \
  -e GIDLIST=100,65537 \
  -e TZ=Europe/Berlin \
  -p 9999:8096 \
  -p 9998:8920 \
  -v /volume1/docker/Emby:/config \
  -v /volume1/Filme/:/Filme \
  -v /volume2/Serien/:/Serien \
  -v /volume1/music/:/music \
  --device /dev/dri:/dev/dri \
emby/embyserver:beta

User video:

id video
uid=1042(video) gid=100(users) groups=100(users),65537(video)

/dev/dri permissions:

ls -l /dev/dri
total 0
crw-rw-rw- 1 root video 226,   0 Oct  5 07:09 card0
crw-rw-rw- 1 root video 226,  64 Oct  5 07:09 controlD64
crw-rw-rw- 1 root video 226, 128 Oct  5 07:09 renderD128

So I just don't get the VAAPI Transcoder seen on the transcode section in Emby/Docker

So Can you please help.

@Happy2Play please move my posting to a new topic. Thanks.

embyserver-63737496636.txt

hardware_detection-63737496322.txt

Link to post
Share on other sites
postboy99
Posted (edited)

Thanks for creating new topic. Can anyone help?

 

EDIT: I was able to fix it by myself.

I had to change UID/GID/GIDLIST to root id's.

Even though I tried my admin user id's with no success. Only root id's (0,0,0) are working.

Edited by postboy99
Link to post
Share on other sites
postboy99
40 minutes ago, Luke said:

Hi, so you're using our Docker package on Synology?

Yes. It's working now. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...