Jump to content

Question about hardware


gutterpunk13
 Share

Recommended Posts

gutterpunk13

Hey guys, I am experiencing an odd issue on my Windows 7 Home Premium server

 

I was streaming some movies and things to my chromecast VIA the android app the other day, everything was fine. All of a sudden the media would pause on its own and sit for like a minute then it would play for a minute then pause again. I thought this was odd so I remote into my machine to see what was what, and found that ffmpeg has my cpu maxed out.

 

I restarted my machine and it cleared up the issue, for a while. Now this happens at least once a day. Its quite an annoyance.

 

Any clue on what I can do to clear this up?

 

Thanks!!

 

John

Link to comment
Share on other sites

gutterpunk13

Ok. Just changed it to "Higher Quality." I'll try it out.

Do you recommend this or "auto"?

 

Strange that it ran for months on max without this issue until now.

 

Thanks for your help!

Link to comment
Share on other sites

I was curious about this recently and now I'm wondering when is it appropriate to use the max setting?

 

 

Sent from my iPad using Tapatalk

Link to comment
Share on other sites

for most, probably never. it is for people who know their way around media encoding and care to deviate from the default

  • Like 1
Link to comment
Share on other sites

Thanks @@Luke. I'm not really interested in using it I'm just wondering why anyone would want to.

 

 

Sent from my iPad using Tapatalk

Link to comment
Share on other sites

Thanks @@Luke. I'm not really interested in using it I'm just wondering why anyone would want to.

 

Someone who really knew what they were doing and had a server with tons of power that did nothing but MB and sufficient bandwidth to always provide the max quality.

 

In reality, that is probably 1% of users but we aim to please ;).

  • Like 1
Link to comment
Share on other sites

Thanks @@ebr and @@Luke. Right now I'm trying to figure out how to get high quality video and audio to my XB1 via dlna. Currently I'm getting crap video and audio.

 

 

Sent from my iPad using Tapatalk

 

 

Edit: er, not meant to bash the system....just figure it's a settings issue I need to figure out.

Edited by Jvtm
Link to comment
Share on other sites

i would just try increasing the bitrate in the dlna profile, or specifying one if it's empty. try 10000000

  • Like 1
Link to comment
Share on other sites

i would just try increasing the bitrate in the dlna profile, or specifying one if it's empty. try 10000000

Right on. I'll give that a go tomorrow. Thanks!

 

 

Sent from my iPad using Tapatalk

Link to comment
Share on other sites

  • 2 weeks later...
gutterpunk13

Just an update. Changed to auto and haven't had an issue since!

 

Thanks again!

Edited by gutterpunk13
Link to comment
Share on other sites

  • 1 year later...
cnjnorton

I was having these issues with it set to max  and when I lowered it to auto it still has multiple instances of  ffmpeg.exe running. What I did to completely fix it is installed WinFF which converts movies using ffmpeg.exe .  I then took the ffmpeg.exe from WinFF app here Winff.org which is 34mb compared to the ffmpeg.exe in the C:\Users\pcman\AppData\Roaming\Emby-Server\ffmpeg\20160410 directory which is 40mb  now all movies play and zero ffmpeg.exe runing at all. and movies are perfect when even set to max 

 

i'm on Windows 7 Enterprise x64 4 cores and just replacing the file has solved it completely,  

 

13709615_1175859575777779_1005862100_o.p

Edited by cnjnorton
Link to comment
Share on other sites

cnjnorton

after further testing  Just download from h**ps://ffmpeg.zeranoe.com/builds/ download ffmpeg 64bit shared, or the 32bit shared, then just copy all the files in the bin directory to the C:\Users\pcman\AppData\Roaming\Emby-Server\ffmpeg\20160410

and vola problems solved  FYI the ffmpeg is only 400k   :)  enjoy 

Edited by cnjnorton
Link to comment
Share on other sites

vaise

I tried this, but my Roku could not play anything ?  Am I supposed to restart emby server after replacing the ffmpeg and ffprobe from these downloads ?  Iv put it back to original and restarted and all is well again - Wife and kids off my back.....  I really want to try anything to get rid of the transcoding I have with some files.  My CPU is only an overclocked G3258.  two transcodes and sluggish, three and emby server crashes!  All cabled Roku 3's.

Edited by vaise
Link to comment
Share on other sites

chef

Guys, I'm not sure that swapping out ffmpeg is going to stop transcoding from happening like what you think.

 

Transcoding happens because the client can't play the file type directly (not nessessarily the container the media is in {ex. mkv}, but the actual audio and video inside it) or because the client can't access the file directly (the server then locates the file and may end up transcoding it).

 

If you are having issues with too many files transcoding to your client, make sure that the file is playable by direct streaming, and that the client has access to the file.

 

I maybe wrong, but the file size of ffmpeg shouldn't matter. It is commandline driven.

All emby does is figure out if the client can play the file directly, if not then it starts a ffmpeg process to convert it to something that the client can play, and then points the client to where that converted file is. It then tells the client to start playing that file whilst ffmpeg is converting it.

 

Ffmpeg is going to use all your processor power to try and convert the file as fast as possible.

If there are three versions of ffmpeg running at the same time, then that is going to drive your CPU really hard.

 

If it is something that happens in your household regularly, and you have setup UNC paths in the server, then perhaps I would suggest converting your media to something that is able to be directly played, as your best option.

Edited by chef
  • Like 1
Link to comment
Share on other sites

MSattler

I was curious about this recently and now I'm wondering when is it appropriate to use the max setting?

 

 

Sent from my iPad using Tapatalk

 

In my case, I am using Hardware transcoding, with no throttling in place.  I simply want the transcode to run as fast as possible.  With setting it to max it uses all cores for this, and ffmpeg will throttle itself accordingly with other processes running.  My results have been that the transcodings run faster, without any issues.

 

Now, in another thread someone mentioned Process Lasso, which allows you to limit the cores a process like ffmpeg can use.   I am using that as well, and letting it use 6 out of 8 cores, to ensure Emby and the OS always have 2 cores available.

Link to comment
Share on other sites

The OP is now suggesting builds from Zeranoe, that's where Emby Server for Windows ffmpeg comes from. He's done some nice investigation here but there's no need to replace your build unless you have your own reason to.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...