Jump to content

Tom1234
 Share

Recommended Posts

Tom1234

I have a file that displays Subtitles ONLY on the Emby Server/Player on my Windows 10 computer.  The Subtitles will NOT show up when playing the video on VLC, Quicktime, an Emby client app, or using my Mackbook Pro as a server. 

Why will the Subtitles only display on the Emby Server/Player, and NOT on anything else?

Link to comment
Share on other sites

pwhodges

I can't think of any type of subtitle that would do that; it will probably be necessary to look at the file to work it out.  

I can't think of single program which will list all possible subtitles and closed captions, except the players like VLC or MPV which you say are not!  Try MediaInfo as a strating point.

Paul

Link to comment
Share on other sites

Tom1234

pwhodges: I’m not a Subtitle expert!  If it’s more than an SRT, I’m lost; however with your comments, I found a “TG3X” subtitle track with Handbrake.  I selected it, “Burned In”, and changed the format of the video.  It worked!  Thank you!  (Oxford -- phenomenal!)

  • Like 1
Link to comment
Share on other sites

pwhodges

I'm pretty sure (from memory) that TG3X is a format I recently reported stopping working in the Roku client after a Roku firmware update.

Glad you fixed it!  I use subs a lot as well, but I prefer not to burn them in - in this case I would have converted to SRT by opening the subs in SubTitle Edit, and remuxing them in with MKVToolNix (though just having the file alongside the video works as well).

Paul

Edited by pwhodges
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...