Jump to content
mylous

Error no compatible streams available

Recommended Posts

mylous
Posted (edited)

Samsung model: UE43RU7100KXXU
Samsung software: T-MSLDEUC-1360.9
Emby client: 1.0.77
Emby Server: 4.4.3.0 (Official Docker Image, running reverse proxy to access remotely)

When trying to play any video on the samsung TV the error no compatible streams are available appears for all media. On a LG tv there is no problem.

Both are connecting remotely to the server but from the same place.

LG playback starts line 1058 in the log.

Samsung playback starts line 132, then 1467 after that every 200 or so lines after that in the log.

I can see in the dashboard when the samsung starts to play it says direct playing, so i assume this is a file compatability issue and for some reason the server is choosing not to transcode.

We have tried to alter the internet connection setting on the samsung tv both to the highest, lowest and on auto and still get the same result.

embyserverlog.txt

Edited by mylous
Attach file

Share this post


Link to post
Share on other sites
cayars

Can you provide metadata for one of the files that isn't playing on the Samsung?

Share this post


Link to post
Share on other sites
mylous

Sure, here's a few. Thanks.

mediainfo.PNG

mediainfo2.PNG

mediainfo3.PNG

mediainfo4.PNG

Share this post


Link to post
Share on other sites
cayars

What happens if you choose AAC audio on that first file?  Do you have the same problem?

Share this post


Link to post
Share on other sites
mylous

Yes, same problem.

Share this post


Link to post
Share on other sites
cayars

Have you tried this without the Proxy involved?

  • Like 1

Share this post


Link to post
Share on other sites
mylous

I haven't, I'll give that a go tomorrow. Thanks.

Share this post


Link to post
Share on other sites
mylous

I altered the server to not use the reverse proxy and connect directly using ssl and that fixed the issue, thanks!

  • Like 2

Share this post


Link to post
Share on other sites
Luke

If you are using nginx, then i would suggest comparing your configuration to that of @pir8radio

Share this post


Link to post
Share on other sites
Luke

@mylous has this helped?

Share this post


Link to post
Share on other sites
mylous

@Luke Sorry for the late reply. I tried it without the reverse proxy as suggested by @cayars. I set up the ssl in the network settings and then connected directly through the server ssl port rather than 443 when I was using the reverse proxy. That fixed the issue so I left the server in that configuration. It has been working great with no problems since so I removed the reverse proxy.

I can give you more info on how I had it set up if that would help in any way?

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback. I would suggest comparing your reverse proxy configuration to that of @pir8radio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...