Jump to content

[Solved] Problems with ExternalIdInfos in ItemLookupService


Recommended Posts

salty
Posted (edited)

Edit: I have found a way to get what I want. Thanks anyway :)

Greetings! Hope you are all doing well in these tough times. I am trying to use the Emby WEB API to lookup metadata on items in my library and came across ExternalIdInfos by browsing through the swagger page but when I call the endpoint as such:

curl -X GET "https://emby.domain.tld/emby/Items/8/ExternalIdInfos?api_key=<snip>" -H "accept: application/json"

I get the following output:

[{"Name":"IMDb","Key":"Imdb","UrlFormatString":"https://www.imdb.com/title/{0}"},{"Name":"TheMovieDb","Key":"Tmdb","UrlFormatString":"https://www.themoviedb.org/movie/{0}"},{"Name":"TheMovieDb Collection","Key":"TmdbCollection","UrlFormatString":"https://www.themoviedb.org/collection/{0}"}]% 

Which seems to suggest that the variables aren't getting sent out properly. Would love some help using this since it would help out with my current project and I assume that I'm not doing it wrong but if that is the case you may want to update the way swagger tells you to do it.

Hope you lads can help me out, thanks in advance :)

Edited by salty
Solved
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...