Jump to content

Cannot add folders to library: The path could not be found. Please ensure the path is valid and try again.


chriad
 Share

Recommended Posts

I have my media on NTFS partitions which I access via Ubuntu.

 

I use gnome-disks tool to set mount options on my partitions:

 

I tried the following mount options:

rw,x-gvfs-show,permissions,uid=emby,gid=emby

and the following path:

/media/chriad/additional-storage
drwxrwxrwx  1 emby   emby    28672 Mär 17 11:36 additional-storage

I changed all the rights recursively in all the files in this folder

sudo chmod -R ugo+rwX additional-storage/

Emby can still not find that folder.

 

What am I missing?

Thanks
 

 

Link to comment
Share on other sites

mastrmind11

can you su -u to emby and get to the folder from the cli?  if not, theres a permission issue.  also, set uid and gid to the emby id, i don't think it works with the name.  

Link to comment
Share on other sites

It was indeed a permission problem. I think the problem was similar to the one in the thread "Ubuntu Permission issue".

 

In the end what did the trick (I think) was:

setfacl -m g::rwx,d:g::rwx /media/chriad

but I think the mount options are fine.

 

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...