Jump to content
Sign in to follow this  
joncy92

Subtitle permissions

Recommended Posts

joncy92

Hi,

 

I'm having an issue with using external subtitles on my Kodi players. I am using embycon.

 

I have configured my libraries to download subtitles on import which is working fine.

The issue is emby sets the file permissions to 770 (rwxrwx---). For the Kodi players to see the SRT files I've had to manually set the permissions to 777.

Is there any way to make this happen when the files are created, or is there something else fundamentally wrong with my setup?

 

Thanks.

Share this post


Link to post
Share on other sites
Luke

@makarai

@MRobi

Can you think of any freebsd settings that might influence this?

This is just the way the mono runtime creates the files but I'm wondering if there's any OS settings that might impact this.

Share this post


Link to post
Share on other sites
joncy92

I've started using Bazarr to grab subs. It's also built on mono and allows you to set permissions if that helps at all 

Share this post


Link to post
Share on other sites
Luke

It might be using native methods to do that because the .net file APIs don't offer that kind of granularity. 

Share this post


Link to post
Share on other sites
MRobi
On 7/4/2020 at 7:55 PM, Luke said:

@makarai

@MRobi

Can you think of any freebsd settings that might influence this?

This is just the way the mono runtime creates the files but I'm wondering if there's any OS settings that might impact this.

None that I can think of. If the files are created as 770 there would need to be some process after the fact to change to 777 after processing.

Although I just checked a few of my subtitle files and they're all 777

Share this post


Link to post
Share on other sites
makarai
On 5/20/2020 at 1:19 AM, joncy92 said:

Hi,

 

I'm having an issue with using external subtitles on my Kodi players. I am using embycon.

 

I have configured my libraries to download subtitles on import which is working fine.

The issue is emby sets the file permissions to 770 (rwxrwx---). For the Kodi players to see the SRT files I've had to manually set the permissions to 777.

Is there any way to make this happen when the files are created, or is there something else fundamentally wrong with my setup?

 

Thanks.

So this sounds to me like a traditional file permission or user issue. What user and what group are you using for bazarr? When you have freshly created files and folders look at that first. Secondly you could play with the umask_set=XXX setting if you run bazarr on docker. 

 

Good choice to run bazarr especially the newest version with ffsubsync included which aligns the subs to the actual audio of the video automatically, this has become a fantastic addon and made me abandon all the sub additions in emby. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...