Jump to content
Sign in to follow this  
Malickfan86

Old with the new

Recommended Posts

Malickfan86
Posted (edited)

Hi everyone.

 

Long time user here, though not continuous.

 

With this quarantine, I decided to look back into my MediaBrowser 2.6.2 setup, which I last used in 2014.

 

Let me first say, I know that this version is outdated and not maintained. However, I set up my media collection to get it exactly right. I'm using the Diamond theme with Xzener's icons and a "Movies by Studio/Actor/Director/Year" set up once I enter. I've customized all the graphics to my liking. Though I was still around when the changes were taking place with MB3 and beyond, I decided not to upgrade because I was happy with the set up as it was. I spent a long time on it. Looking at it now, I still don't want to change anything.

 

post-892-0-18300100-1587505785_thumb.jpg

 

However, there are three things I would like to be able to do:

 

1) I added some new movies with new studios. I updated the IBN folder with the studio logos. For some reason, when I do a complete refresh of the MB service, the new studio logos don't appear even though they're configured exactly the same way.

 

Notice how, in the second image, the studio "Neon" doesn't have a logo but the other studio does.

 

post-892-0-24373400-1587505798_thumb.jpgpost-892-0-13210300-1587505816_thumb.jpg

 

2) It seems like the new movies I just added to my collection appear in "Unknown" under Movies by Director. I checked the metadata and they all have directors listed so I'm not sure why MB is not able to pick this up. I'm using Media Center Master for metadata.

 

post-892-0-15360900-1587505808_thumb.jpg

 

3) I realized that my LG TV has an Emby app. I downloaded it and I'm interested in pairing it with my MediaBrowser set up if possible. I know my set up may be strange to some of you, but I don't have a dedicated HTPC. I use my only personal computer, which is an HP laptop. Back in the day, I would plug my laptop into the TV with HDMI. I tried wireless solutions then with my Xbox 360 but the connection wasn't good. I'm sure if I had the ability to stream now, it would be much better based on my connection.

 

Appreciate any help. :)

Edited by Malickfan86

Share this post


Link to post
Share on other sites
Luke

Hi, let us know how you get on with the LG Emby app. Thanks !

Share this post


Link to post
Share on other sites
Malickfan86

Any idea why those issues are happening and how to fix them?

 

Can I use legacy MB with Emby Server for the LG app? I tried downloading Emby Server but I got an error.

Share this post


Link to post
Share on other sites
Luke

I'm not sure about the issues but you can use your old install side by side as long as you don't install emby for wmc.

Share this post


Link to post
Share on other sites
Luke

What error did you get when downloading?

Share this post


Link to post
Share on other sites
One2Go
Posted (edited)
With this quarantine, I decided to look back into my MediaBrowser 2.6.2 setup, which I last used in 2014.

 

Let me first say, I know that this version is outdated and not maintained. However, I set up my media collection to get it exactly right. I'm using the Diamond theme with Xzener's icons and a "Movies by Studio/Actor/Director/Year" set up once I enter. I've customized all the graphics to my liking. Though I was still around when the changes were taking place with MB3 and beyond, I decided not to upgrade because I was happy with the set up as it was. I spent a long time on it. Looking at it now, I still don't want to change anything.

 

1) I added some new movies with new studios. I updated the IBN folder with the studio logos. For some reason, when I do a complete refresh of the MB service, the new studio logos don't appear even though they're configured exactly the same way.

 

2) It seems like the new movies I just added to my collection appear in "Unknown" under Movies by Director. I checked the metadata and they all have directors listed so I'm not sure why MB is not able to pick this up. I'm using Media Center Master for metadata.

 

3) I realized that my LG TV has an Emby app. I downloaded it and I'm interested in pairing it with my MediaBrowser set up if possible. I know my set up may be strange to some of you, but I don't have a dedicated HTPC. I use my only personal computer, which is an HP laptop. Back in the day, I would plug my laptop into the TV with HDMI. I tried wireless solutions then with my Xbox 360 but the connection wasn't good. I'm sure if I had the ability to stream now, it would be much better based on my connection.

 

Appreciate any help. :)

 

We are in a similar situation because I was using MB 2.6 for the longest time but then decided to switch to the Emby server and client setup. At this time I still run MB 2.6 on a separate HTPC for the sole purpose of backup. Should my primary Emby setup ever have a hardware failure. My advise is to make the switch to the Emby 4.* server setup and you can get a similar look and feel as MB 2.6 but it comes with several conditions. Try to answer some of your questions.

 

1. The studio part will not work with Emby as due to lack of interest it has been discontinued. Since I run WMC with the EMC app plus the @@throgmorton themes, he added the feature to show the studios plus his themes are giving the look and feel of the Diamond theme plus I have used the Xzener icons to customize the menus. However EMC is a requirement and can't coexist with the MB 2.6 on the same PC. I run EMC and the Emby server on an intel NUC which is doing an excellent job. In addition even under MB 2.6 every now and then I had to futz around with the IBN studio entries try different refreshes and finally they appeared. It was at times a real hassle. So what you experience is part and parcel of MB 2.6 and I never have that problem in my present setup.

 

2. I also use MCM for the metadata which exists in XML files and Emby 4.* with the XML plugin will read the MCM generated metadata and no additional work is required. The Director's name actually can exist in two places in the XML file, under the Director's tag but also under the Person's tag with the designation of director rather then actor. You may want to try this.

 

3. If you want to use the Emby LG app then it requires the Emby server 4.* version and it might be in your situation the easiest as you don't have TBs of content plus it best for any playback of content that may create issues. You don't get the look and feel of MB 2.6 but you get many other features and advantages that more then make up for it.

 

It is basically a matter of how much money and time you want to spend to get a similar look and feel setup but judging from your content as well as your frequency of usage I would say Emby 4.* on your laptop and the LG app are your best bet.

 

Edited by One2Go

Share this post


Link to post
Share on other sites
Malickfan86

Hi Luke and One2Go,

 

Thanks for the responses. I've been busy lately so I didn't get a chance to work on this.

 

I understand there are customization options in the newer versions that can get it to look like it was before and there would also be performance improvements.

 

However, before I go changing everything without knowing how it will look in the end, I'd actually like to downgrade to the last version that had studios and directors, since that's how my setup is designed. If I find it's too buggy or slow, then I'll go ahead and upgrade. Would it be possible to get the installer for this version?

 

You can send it privately or by email, if it's more convenient.

 

Thanks again for the help!

Share this post


Link to post
Share on other sites
One2Go

Don't know if you want to go down this road of installing a server version 3.* as you will get very little support. In addition I don't know in what version the studio functionality was fully working as I never used it as a category only had it displayed in the theme. I quickly checked what I have and it is version embyserver-win-x64-3.5.3.0 but the Devs here may have a better answer. I do remember a discussion in a thread where the studio part was discussed and due to lack of interest and usage it was discontinued as it simplifies the code maintenance.

 

However if you decide to go the route of server and client setup do go for the version 4 as it adds live TV setup if you have a tuner like HDHomerun on the network. This was for me the reason to do the change. I have a HDHomerun box connected to an antenna in the attic get over 50 channels OTA programs. Emby Premier service will provide the TV guide data. During this quarantine I have found myself watching more TV then ever 11pm CBS news followed by Stephen Colbert.

 

Your preferred setup for viewing and navigating is very much out of the mainstream and you may be on your own there without support. The closest that I have found for getting the look and feel of MB 2.6,2 is Server 4.* with the latest EMC beta version and with the must have of the @@throgmorton themes. It does 95% of what I want to see and how I want to navigate. At times we may have to try a new way of doing things and then realize that actually the new idea is not that bad. It is on the same level as resisting changes in Operating Systems for the PC.

Share this post


Link to post
Share on other sites
Malickfan86

Okay, I'll take it into consideration. Live TV wouldn't be a big sell to me since I use my primary laptop and not a dedicated HTPC. I don't recall the discussion about studios. I definitely would have voiced my opposition to that move. However, like I said, once I set up everything, I didn't tinker with it too much because I was happy with it.

 

If the mods are able to provide me with the last version that has studio and director support, I would greatly appreciate it. Chances are you'll never hear from me again as I'll happily use this same setup for decades. If there is an issue with it, then I'll gladly upgrade as I'm sure the whole community has contributed some amazing features over the years. The only reason I'm not doing that right away is because I'm risking the setup that I currently have, which I think is beautiful.

 

Thanks again. :)

Share this post


Link to post
Share on other sites
Malickfan86

So does anyone know which version that is, with director and studio support?

Share this post


Link to post
Share on other sites
Malickfan86

I'm trying version 2.5.2 but I'm getting an error that there's a newer version installed. Is there a way I can back up all my configurator settings before I uninstall? I've made a backup to my IBN folder.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...