Jump to content


Photo

A little display bug when the Roku app first starts


  • Please log in to reply
4 replies to this topic

#1 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 976 posts
  • Local time: 09:08 AM
  • LocationTennessee

Posted 05 April 2020 - 07:28 PM

I am running Roku beta ver 3.0.218

Server ver 4.5.0.4 And ver 4.3.1.0

The problem appears on both servers.

 

I have my Roku start screen configured with "Next Up" at the top and I have the display description at the top turned on.

 

When I first start Emby on my Roku or when I switch servers (which is basically the same as an exit/restart sequence) The "Next up" appears at the top of the screen with the description overlayed on top of it. That is the next up row does not move down like it used to.

 

If I do anything that moves the focus the "Next Up" moves down like it should and remains that way until I switch servers or exit/reenter the app. To say in another way "Next up" starts at the top of the screen and relocates correctly, making room for the description, only after the focus moves once.

 

If after entering the app I do anything at all that changes the focus or the screen then everything reverts to normal and the only way I can get the bug to show again is ti exit the app or switch servers.

 

Note: I tested the release ver and this bug is not happening in the release.


Edited by Gilgamesh_48, 05 April 2020 - 07:33 PM.


#2 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 6085 posts
  • Local time: 06:08 AM

Posted 05 April 2020 - 10:08 PM

@Gilgamesh_48 you rock sir. :) Thank you for the issue report. Please keep the coming.

 

Reference:

Fix #836: [HomeRowList] fix homerowlist issues ( invalid reference + scroll issue )

 

Any others? Open as many new issue threads in the Roku section as you need. Thanks for the help. ^_~

 

 

We had an issue where some of the interface fields we are using in the application are not meant to be used as we are using them. Roku documentation doesn't list them as always reliable. This was our adjustment away from those incorrect fields. Apologies for the scroll issue as it was caused by this change. Now we should be back to how we were before. Same behavior, but correct implementation this time.

 

If "My Media" is not the first row of your Home screen this will now correctly scroll down when you first land on the home screen. The scroll down will happen automatically without a need to move focus first. Soon as these are verified by the team a release will be pushed to Beta.


Edited by speechles, 05 April 2020 - 10:14 PM.


#3 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 976 posts
  • Local time: 09:08 AM
  • LocationTennessee

Posted 05 April 2020 - 10:41 PM

@speechles I use Emby in what seems to be a somewhat unique way. I have it setup in a way that makes sense to me but may be at odds with how others or the developers use Emby or envision others using it. I use Emby only for Movies, TV and pictures I do not use remote access at all and I do not use Emby for audio and I do not use it for live TV. (I might use it for live TV if it supported TV anywhere like Channels DVR does but that seems quite unlikely. I get 0 signal from the nearby cities because of the local topology.)

 

Because of the way I use Emby I seem to unearth problems that others do not see but I also do not see issues that others do. I enjoy the testing part of this program but, because of my limited use, there are a number of issues that I will never see. With the current lockdown situation I do spend a lot of time in front of the TV lately and I thank Emby for making it a pleasant undertaking.

 

Walking Dead movies and outbreak movies are currently quite popular here. ;)

 

If I find (stumble upon) other bugs I will happily report them. I enjoy giving work to others. :P



#4 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 976 posts
  • Local time: 09:08 AM
  • LocationTennessee

Posted 07 April 2020 - 12:09 AM

Just to report I am now running Roku beta ver 3.0.219 and this problem is fixed.

Now off to find another bug......



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 51946 posts
  • Local time: 09:08 AM

Posted 07 April 2020 - 08:47 AM

Thanks for reporting back.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users