Jump to content
jdewoody71

Fast Forwarding Remotely

Recommended Posts

jdewoody71
Posted (edited)

Hello! Does anyone have any suggestions on how I could tweak my server settings to help with family fast forwarding remotely. The main complaint is that after the FF, the stream stutters a lot and may recover, it may not. I don't experience this locally. I have 1G/50Mb service and my server is dedicated to Emby with i7/16GB RAM/500GB SSD. 

 

Thanks for any ideas you might have!

Edited by jdewoody71

Share this post


Link to post
Share on other sites
Luke

Hi there, can we please look at an example? Thanks !

Share this post


Link to post
Share on other sites
jdewoody71

Hi there, can we please look at an example? Thanks !

Thank you for your response.

 

Sure, how would I provide you an example of this? Is it logged somewhere?

Share this post


Link to post
Share on other sites
jdewoody71
Posted (edited)

Here is the conversation:

 

 
It's pausing for a solid 10 to 15 seconds
9:17 PM
I also noticed after it does this then I'm immediately prompted for my password for Emby
9:17 PM
That is if I exit the application
9:18 PM
Seems to be fine once I enter my creds and get back in.

 

 

 

 

Attached are the logs from the time he reported it. Thanks!

ffmpeg-directstream-1a81ec3a-41c0-40c1-a26d-9d49732183cd_1.txt

embyserver.txt

ffmpeg-transcode-54fd817d-12df-4845-b7db-3bd253c62b2d_1.txt

ffmpeg-transcode-ac433e49-35e4-491c-a3d8-ab49f23ba951_1.txt

Edited by jdewoody71

Share this post


Link to post
Share on other sites
jdewoody71

Here is the conversation:

9:16 PM
It's pausing for a solid 10 to 15 seconds
9:17 PM
I also noticed after it does this then I'm immediately prompted for my password for Emby
9:17 PM
That is if I exit the application
9:18 PM
Seems to be fine once I enter my creds and get back in.

 

 

 

 

Attached are the logs from the time he reported it. Thanks!

Share this post


Link to post
Share on other sites
Luke

Hi, if the video is transcoding, then when you fast forward or rewind we may sometimes have to stop and restart the transcoder. That's why it might pause for several seconds. Does this answer your question?

Share this post


Link to post
Share on other sites
muzicman0

How far ahead does the transcoder ...ummm....transcode?  I have seen where if I skip through commercials, I can have issues as well.  At one point, I was looking for settings to either increase the buffer on the client side so I could buffer up to 7 or 8 minutes, but I was never able to find any settings.  Is this possible?  This would cover 95% or more of skipping through commercials at least.

Share this post


Link to post
Share on other sites
maegibbons
Posted (edited)

How far ahead does the transcoder ...ummm....transcode? I have seen where if I skip through commercials, I can have issues as well. At one point, I was looking for settings to either increase the buffer on the client side so I could buffer up to 7 or 8 minutes, but I was never able to find any settings. Is this possible? This would cover 95% or more of skipping through commercials at least.

Yes you can.

 

In the config directory under programdata there is a file called encoding .xml

 

Edit this file and find the ThrottleBuffer setting and change it from the default 120 (seconds) to what you require.

 

Save the file and restart server.

 

This is a server side transcode buffer not client side but it stops the transcoder restarting if you are skipping over adds in prerecorded content.

 

krs

 

Mark

 

Sent from my SM-N976B using Tapatalk

Edited by maegibbons
  • Like 1

Share this post


Link to post
Share on other sites
muzicman0

Hmmm...I did a search for encoding.xml in all of C:\Users\muzic\AppData\Roaming\Emby-Server\programdata and didn't find the file.  

 

I do have 'Enable Throttling' in the transcoding settings unchecked.

Share this post


Link to post
Share on other sites
maegibbons

Hmmm...I did a search for encoding.xml in all of C:\Users\muzic\AppData\Roaming\Emby-Server\programdata and didn't find the file.

 

I do have 'Enable Throttling' in the transcoding settings unchecked.

Well You could try checking it.

 

Its under Embyserver\programdata\config

 

Krs

 

Mark

 

Sent from my SM-N976B using Tapatalk

Share this post


Link to post
Share on other sites
muzicman0

once I re-enabled throttling, then the file appeared.

Share this post


Link to post
Share on other sites
maegibbons

Ok well i would adjust the setting to about 480 and see how that goes.

 

Krs

 

Mark

 

Sent from my SM-N976B using Tapatalk

Share this post


Link to post
Share on other sites
muzicman0

On it!  Thanks!

Share this post


Link to post
Share on other sites
muzicman0

That does seem to work, thanks!  I will have to do more testing to see how it works in real life scenarios, but I really appreciate the info!

  • Like 1

Share this post


Link to post
Share on other sites
maegibbons
Posted (edited)

Ok see how it goes.

 

Krs

 

Mark

 

 

 

A 'like' is always appreciated!

 

Sent from my SM-N976B using Tapatalk

Edited by maegibbons

Share this post


Link to post
Share on other sites
muzicman0

already done!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...