Jump to content

DNLA - No transcode (not applying user config) // Only direct play on mp4


Recommended Posts


Hi all,


My internet TV box ISP's has recently introduced a bug when playing mp4 format encoded by  "mp4creator 1.6.1d" (other encoders are fine).


Long story short, to fix this issue i want to transcode .mp4 files to another format. I tryed many templated, none of them worked. Always on direct play.

Played also with DirectPlayProfile, TranscodingProfile, ContainerProfile & Conditions, CodecProfile & Condition, etc.. and i never try to transcode when playing .mp4 files through DLNA.


DNLA is configured to match (successfully):

	FriendlyName:Freebox Player
	Manufacturer:Freebox SAS
	ModelDescription:Freebox UPnP Renderer

On web browser everything is fine and transcoded.


On the current FREEBOX.xml DLNA profile, you see that mp4 direct play profile is missing, so should trancode when playing one. But didn't.


I have only 1 user configured and have all access to transcode / recode rights.


emby version :

dlna version plugin :


See attached:

-media metada of mp4 file working file

-media metada of mp4 with issue

-embyserver logs with dlna when playing mp4 file (with issue)

-embyserver logs with web browser with no issue

-my user DLNA config file "FREEBOX"


I don't fully understand the use of "ProtocolInfo". Could you clarify what it is for and what needs to be added?


Could you help?


Thx & Greetings






Edited by Topper69
Link to comment
Share on other sites




I try both.
When i direct edit the file, then i restart emby (sudo service emby-server restart)





Link to comment
Share on other sites


I think it is because on the log we see that "Info Dlna: DLNA Session created for Freebox Player - Freebox" : it match and load it.

Link to comment
Share on other sites

Hi all,


@@Topper69,  reading your appeal, I think your knowledge is enough to help me solve the problem described in this appeal - https://emby.media/community/index.php?/topic/84694-dlna-device-profile-how-to-describe-it -correctly /

To be brief, there are two Samsung TVs on the local network:

-TV Samsung UE40H5303 - directly reproduces most popular formats, everything is OK with it;

-TV Samsung UE55RU8000 - does not directly reproduce, at least, sound in dts format. It requires a separate user DLNA profile with transcoding.

 EMBY Server has a pre-installed DLNA profile "Samsung Smart TV", which indicates only one identification parameter: 

    <ModelUrl> samsung.com </ModelUrl>

When creating a user profile for Samsung UE55RU8000 TV with more precise matching parameters, EMBY Server in each case selects the pre-installed DLNA profile "Samsung Smart TV" (probably, as the profile with the widest match)


All attempts to edit the pre-installed DLNA profile "Samsung Smart TV" lead to the creation of a new user profile, and the profile "Samsung Smart TV" remains unchanged.


DNLA is configured to match (unsuccessfully)

<Name>Samsung 8 Series</Name>
    <FriendlyName>Samsung 8 Series</FriendlyName>
    <SerialNumber />
    <ModelName>Samsung 8 Series (55)</ModelName>
    <DeviceDescription />
    <Manufacturer />
    <ManufacturerUrl />






2020-04-06 01:18:07.156 Debug Dlna: Dlna Device.Start
2020-04-06 01:18:07.161 Debug HttpServer: HTTP Response 200 to Time: 12ms.
2020-04-06 01:18:07.169 Debug Dlna: Found matching device profile: Samsung Smart TV
2020-04-06 01:18:07.186 Info Dlna: DLNA Session created for [TV] Samsung 8 Series (55) - UE55RU8000UXUA
2020-04-06 01:18:07.188 Debug Dlna: Attempting to create PlayToController from location



How can I “convince” EMBY Server to use its own DLNA profile for the Samsung UE55RU8000 TV?


Sorry to ask questions in your topic.

Could you help?


Link to comment
Share on other sites




@@level10 i think you could try this

1) remove the generic Samsung Smart TV from the template (save it in backup somewhere else). If you're in debian base distro, they are in "/var/lib/emby/config/dlna/system/Samsung Smart TV.xml"

2) create a specific template for each of your TV (fill all data as FriendlyName ModelNumber SerialNumber ModelName DeviceDescription ModelUrl Manufacturer ManufacturerUrl)


In this case, emby will select always the specific profile for each of your TV.

Link to comment
Share on other sites


Thanks for the quick response, @@Topper69

I already tried to do this - unsuccessfully.

I have Win, the path to the templates is 

c: \ Users \ AppData \ Roaming \ Emby-Server \ programdata \ config \ dlna \ system \

When I delete the DLNA profile “Samsung Smart TV” from this folder, after rebooting, the ”EMBY Server - profile“ Samsung Smart TV ”is back there.



I also tried to rename the Samsung Smart TV.xml file, after rebooting EMBY Server - two files appear in the folder: the renamed and the new Samsung Smart TV.xml file.

Edited by level10
Link to comment
Share on other sites


Ok then try :




open the "Samsung Smart TV.xml" and edit the inside with one of your TVs config. Then reboot emby. Open again with notepad to see if the file is overwritten or not.

Link to comment
Share on other sites

I already tried to do this - unsuccessfully.

After rebooting, the file is in its original form.

You wrote: "I have only 1 user configured and have all access to transcode / recode rights."

I have several users, but I make all attempts with the admin user.

Perhaps the problem is here somewhere?


Anyway, thanks for the tips.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...