Jump to content

Really stuck with gamebrowser III someone please help


Recommended Posts


OK so I am really stuck, I have been using media browser and gamebrowser for years now and love it. I finally thought it was time to upgrade to media browser 3 but now I can’t get gamebrowser working at all. I have been through the tutorial and I am pretty sure I have done everything right. I have also been though the forum and found no answer to my problems.

First I wanted to use media browser classic for went though the set up for that. I have got it to the point where i can see the all my games but I get an error when i try and run them. "An unknown error prevented this game from launching"


"An unknown error prevented this game from launching"

I’ve tried all of these steps

  1. stop server
  2. delete library.db
  3. delete servers GameBrowser.xml
  4. delete all .xml files contained anywhere in your game libraries
  5. delete MBC GameBrowser.xml
  6. start server
  7. re-add all game directories to the Gamebrowser server dashboard config
  8. wait for scan to complete
  9. launch MBC configurator and add emulators to the various platforms.
  10. Play game.


But I still get the same error. I am pretty sure my folder structure is ok.



So after trying many times to get it working, I thought I would try in media browser theatre but i have another issue there and that is when I try to set up the external player it won’t let me select a system when I press on the + or – is does nothing.


I could really use some help with if anyone has any ideas?


I have also attached some screenshots.







Link to comment
Share on other sites

  • 2 years later...

Hey. Even if this is an old thread. Could you solve your issue? As in my eyes it looks like you missed the settings in the plugin. After you have defined the emulators there you can choose in emby theater which game system you want for external player. Still with my setup it still does not work without any error message. have not yet look at the log file but I dont even have the play button.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...