Jump to content

emby + kodi on xbox one problems


Perun696
 Share

Recommended Posts

Hi

 

I've Kodi with emby plugin on xbox one installed. It works ok till I want to play something... It doesnt work... There is no error or message. It 'hangs' for 20-30s and then nothing...

What can be the problem? I use playing over the addon (no native paths)...

 

Greetz

Link to comment
Share on other sites

  • 3 weeks later...

I'm having this same issue, just trying to work out how to get the log off the xbox.

 

The initial sync works and loads the TV and Movies, however, if you click on any from the home screen, you just get a 20-30 second hanging and then it unlocks. If you go into a season and try to play an episode, you get the notification that the file cannot be found and may have been deleted. That is using the addon default paths.

 

If I change to native, it says the file paths are not correct, however they work perfectly on the PC and Mi Box, so I believe that is reporting incorrectly.

Link to comment
Share on other sites

  • 2 months later...
Exist2Resist

Having the same issue with Emby. Libraries get scanned into KODI and I can browse all movies, tv, and music but when I go to play any of them nothing happens except the system freezing for a minute then resuming after that. 

EmbyCon works fine and I can play the content. But I would like to use Emby plugin so I can have the libraries native in KODI. 

 

For the others here. To get KODI logs from your Xbox do the following;

In File manager Add source, browse and select home folder. 

It's in the root of the home folder. 

Plug in USB and copy file to usb.

 

I've attached the logs from both my server and kodi.

 

EDIT: Looks like similar issue to 

 

kodi.log embyserver_short.txt

Edited by Exist2Resist
logs
Link to comment
Share on other sites

  • 2 weeks later...

Hi,

I have the same problem, it is failing because it tries to connect to 127.0.0.1, but there is no emby server on the Xbox One 😃

CCurlFile::Open failed with code 0 for http://127.0.0.1:57578/emby/kodi/tvshows/7975/7984/file.strm?KodiId=456&Name=T

More log here :

http://paste.kodi.tv/eyizagimaz

We can see that it has managed to connect to server successfully though

Emby.emby.core.connection_manager -> calling onSuccessfulConnection with connection mode 2 with server

But it doesn't use the address of the server when trying to get files.

On the other hand, EmbyCon works as expected 

Link to comment
Share on other sites

2 hours ago, sdb said:

Hi,

I have the same problem, it is failing because it tries to connect to 127.0.0.1, but there is no emby server on the Xbox One 😃

CCurlFile::Open failed with code 0 for http://127.0.0.1:57578/emby/kodi/tvshows/7975/7984/file.strm?KodiId=456&Name=T

More log here :

http://paste.kodi.tv/eyizagimaz

We can see that it has managed to connect to server successfully though

Emby.emby.core.connection_manager -> calling onSuccessfulConnection with connection mode 2 with server

But it doesn't use the address of the server when trying to get files.

On the other hand, EmbyCon works as expected 

It is not trying to access the emby server, it is trying to access its own built in playback http services that it uses to process the plugin playback actions.

Unfortunately on some platforms this does not work and due to security restrictions on those platforms may never work.

 

Link to comment
Share on other sites

Thanks for the answer ! Could you specify that the plugin doesn't work on Xbox One in the wiki then ? It will avoid some headaches when trying to make it work ;)

And if you have more informations on these security restriction on Xbox One i'm curious too !

Link to comment
Share on other sites

2 hours ago, Perun said:

hmmm what sense does it make to release such a client if it cant work properly?

Greetz

All the Kodi add-ons (all three) are user community developed. You can see the current status of all 3 add-ons here:

https://emby.media/community/index.php?/topic/86968-current-status-of-kodi-add-ons/

There was mention of the Emby Team contributing to the Emby for Kodi add-on but I have not seen anything official yet. I do not know what their plans are in that regard apart from a few  comments posted in a few threads:

https://emby.media/community/index.php?/topic/87315-playback-problems-emby-for-kodi-kodi-187/page/2/&tab=comments#comment-896828

and this one

https://emby.media/community/index.php?/topic/86968-current-status-of-kodi-add-ons/&tab=comments#comment-895490

1 hour ago, sdb said:

Thanks for the answer ! Could you specify that the plugin doesn't work on Xbox One in the wiki then ? It will avoid some headaches when trying to make it work ;)

And if you have more informations on these security restriction on Xbox One i'm curious too !

I think you can request updates to the Wiki on the wiki, to be honest I dont know what wiki you are referring to as I dont use the Emby for Kodi add-on, I maintain the EmbyCon add-on but know how most of the add-ons work so help where I can.

The XBox One system is very locked down, my assumption is that the Xbox One environment will not let apps create listening services on any port, usually you can create listening ports on any number above 1024 on most systems but XBox One must be more locked down and does not allow it. I could be wrong, it might be something else but that is my guess.

Link to comment
Share on other sites

We are maintaining the Emby for Kodi add-on, and yes, looking into problems as they are reported.

Link to comment
Share on other sites

3 hours ago, Luke said:

We are maintaining the Emby for Kodi add-on, and yes, looking into problems as they are reported.

Should I update the addons status page with official support status for the Emby for Kodi addon?

Link to comment
Share on other sites

On 7/22/2020 at 5:55 PM, TeamB said:

Should I update the addons status page with official support status for the Emby for Kodi addon?

Yes sounds good, thanks.

Link to comment
Share on other sites

  • 5 months later...

Sorry for bumping an old thread; this is the first hit on Google.

Did anything come of this report? I am having the same issue on both Xbox One and Series X, with both the stable and the next-gen version of the add-on. EmbyCon appears to work without issue, but I'd really prefer to be using Emby for Kodi.

Link to comment
Share on other sites

12 hours ago, lusky3 said:

Sorry for bumping an old thread; this is the first hit on Google.

Did anything come of this report? I am having the same issue on both Xbox One and Series X, with both the stable and the next-gen version of the add-on. EmbyCon appears to work without issue, but I'd really prefer to be using Emby for Kodi.

Hi there, can you please describe the issue that you're having? Thanks.

Link to comment
Share on other sites

21 hours ago, lusky3 said:

Sorry for bumping an old thread; this is the first hit on Google.

Did anything come of this report? I am having the same issue on both Xbox One and Series X, with both the stable and the next-gen version of the add-on. EmbyCon appears to work without issue, but I'd really prefer to be using Emby for Kodi.

Can you please send me a kodi.log with emby-next-gen 5.1.7 installed.

thank you.

Link to comment
Share on other sites

17 hours ago, Luke said:

Hi there, can you please describe the issue that you're having? Thanks.

Exact same as posted above. Plugin installs, everything syncs, but selecting an item results in 20-30 seconds of thinking and then nothing happens.

8 hours ago, quickmic said:

Can you please send me a kodi.log with emby-next-gen 5.1.7 installed.

thank you.

Sent via PM.

Link to comment
Share on other sites

On 7/21/2020 at 11:50 AM, TeamB said:

The XBox One system is very locked down, my assumption is that the Xbox One environment will not let apps create listening services on any port, usually you can create listening ports on any number above 1024 on most systems but XBox One must be more locked down and does not allow it. I could be wrong, it might be something else but that is my guess.

 

I assume, TeamB is right here. Looks Xbox blocks local sockets. You could try native mode.

Can you configure the xbox network setup? Firewall etc in some way? If possible, open port 57578 for Kodi app or globally.

If you wanna take the risk, you can google "Xbox One Debug Mode" and try to enable the port 57578. But this is on you. I'm not familiar with Xbox!

 

Edited by quickmic
Link to comment
Share on other sites

21 hours ago, quickmic said:

 

I assume, TeamB is right here. Looks Xbox blocks local sockets. You could try native mode.

Can you configure the xbox network setup? Firewall etc in some way? If possible, open port 57578 for Kodi app or globally.

If you wanna take the risk, you can google "Xbox One Debug Mode" and try to enable the port 57578. But this is on you. I'm not familiar with Xbox!

 

I did some testing and have more-or-less determined that the last usable port on my Xbox is 57343. Binding to any port higher causing an error.

Is there any way to change the port that the add-on uses?

Link to comment
Share on other sites

Not yet, but I can add this option. But changing the port will require a full DB wipe.

Do you know, does it would work with other ports? Is there a whitelist?

Link to comment
Share on other sites

  • 11 months later...
On 1/25/2021 at 10:30 AM, lusky3 said:

I did some testing and have more-or-less determined that the last usable port on my Xbox is 57343. Binding to any port higher causing an error.

Is there any way to change the port that the add-on uses?

How do you bind ports on the xbox? I am having a similar issue except I cannot see the Emby server from the Kodi emby addon. It installs without error but when I go to configure and select connection it kicks me back to the original configure screen.

Link to comment
Share on other sites

56 minutes ago, Quek9 said:

How do you bind ports on the xbox? I am having a similar issue except I cannot see the Emby server from the Kodi emby addon. It installs without error but when I go to configure and select connection it kicks me back to the original configure screen.

Currenlty the ports are hardcoded, but I could change that. However, the server connection and sync should work anyway. The ports are used for artwork and addon-mode playback (and some internal communication). Anyway, the connection to the server should work.

If the connection screen doesn't offer any emby server, there is something blocking. Anyway, also this should be an issue. My Redhat Linux also blocks the server detection. In this case use "manual" server selection.

"http://myserverip" no port here

port cones in the next line

And please use beta version. The connections are improved in beta.

Let me know, if at least the sync works. If yes, then I can adjust the internal ports.

Link to comment
Share on other sites

18 minutes ago, quickmic said:

Currenlty the ports are hardcoded, but I could change that. However, the server connection and sync should work anyway. The ports are used for artwork and addon-mode playback (and some internal communication). Anyway, the connection to the server should work.

If the connection screen doesn't offer any emby server, there is something blocking. Anyway, also this should be an issue. My Redhat Linux also blocks the server detection. In this case use "manual" server selection.

"http://myserverip" no port here

port cones in the next line

And please use beta version. The connections are improved in beta.

Let me know, if at least the sync works. If yes, then I can adjust the internal ports.

Thanks for reply. The old version worked without any issues on the series X. The standalone is working but it is kind of slow. I am using the current beta version in Kodi. I have port forwarding on the following ports, 80, 443, 8096, & 8920. When I try to select the connection to log into the server it bounces me back. I have emby working on 4 phones, 5 computers, 3 tablets. I uninstalled and reinstalled it on Kodi xbox. Hell I even uninstalled and reinstalled Kodi. Still no joy. What could be blocking the server connection?

Link to comment
Share on other sites

Can you send me a kodi.log please.

What's the matter with port forwarding? Is your Emby server not in the LAN? Are we talking about a WAN connection?

You don't need port forwarding at all if xbox and emby server is in the same network. (unless xbox doesn't do some voodoo).

If both are in LAN don't use https for a test. This is an additional source of issues (certificate problems).

Edited by quickmic
Link to comment
Share on other sites

5 minutes ago, quickmic said:

Can you send me a kodi.log please.

What's the matter with port forwarding? Is your Emby server not in the LAN? Are we talking about a WAN connection?

You don't need port forwarding at all if xbox and emby server is in the same network. (unless xbox doesn't do some voodoo).

If both are in LAN don't use https for a test. This is an additional source of issues (certificate problems).

When I check Kodi logs on the xbox, the error doesn't show up. How can I pull log files off of the xbox? I was just mentioning the port forwarding just in case it was affecting something. Both the xbox and emby server are on the same LAN.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...