Jump to content


Photo

IPTV Stuttering


Best Answer mickle026 , 28 March 2020 - 01:55 PM

Now you found the reason why you are getting stuttering , ie cpu at 99%, you need to determine why its at 99%

 

1st to try is reboot Emby Server.  Sometimes on live tv a shared pipe sevice (you dont need to know what that is) can still run after channels have stopped playing.  This leaves ffmpeg open and transcoding to disk, this can be seen in the transcoding temp dir as it creates huge files the longer its been running.  Rebooting emby server cancels them and removes the temp files.  This is caused by a client exiting a selected channel as its starting but not quite playing yet.  These should terminate but very occasionly don't.  Rebooting the server (not the PC) sorts this out.  A running ffmpeg service hogs some of the cpu.

 

otherwise

 

Open task manager, click the performace tab.

 

You can see if HDDs are at 100% too or not and memory usage is high.  That'll show if something else is using them or if windows is probably using virtual memory.  If it is then that too is reading/writing to the disk.

 

If just the CPU is high then check running processes.  Some things like the indexing service can sometimes become corrupt .

 

If CPU + Memory + HDD is high then try unloading some processes, skype is a big *bleep* for making the disks access constantly.

 

There are 100's of things that can cause this, you need to narrow it down.

 

The Processes tab will show you what is using the most of everything.

 

Run Disk Check  - Scandisk /f

Go to the full post


  • Please log in to reply
42 replies to this topic

#41 leungalv OFFLINE  

leungalv

    Advanced Member

  • Members
  • 42 posts
  • Local time: 07:39 AM

Posted 29 March 2020 - 08:33 PM

That'll ease cpu resources.a lot.

 

The 2500k is compatible with a lot of motherboards.  Mine isn't even though it fits in the sockets, most motherboards wont turn on. My 9400F has to have a 350 chipset or above.  It doesnt work at all in the B250's which it fits in.

 

 

What i did notice when I upgraded mine was how fast the whole thing including the thumbnails on the galleries loaded.  They are pretty much instant now.

 

Ya, my system is actually the Shuttle SH67H3 - hope this will breath some new life into it.  Was about a $180 CDN upgrade, so if it'll give me a few more years of life, it would be totally worth it.



#42 densma OFFLINE  

densma

    Advanced Member

  • Members
  • 103 posts
  • Local time: 12:39 PM

Posted 30 March 2020 - 05:14 PM

and the server log?

 

thanks for the update. its all good now



#43 leungalv OFFLINE  

leungalv

    Advanced Member

  • Members
  • 42 posts
  • Local time: 07:39 AM

Posted 03 April 2020 - 03:39 AM

Installed video card and new CPU, things seem to be working now; however will test and advise in a few days. 

 

In the meantime, thank you to everyone for their suggestions and input. :)

 

UPDATE 04/04/20: Everything seems to be running smoothly now.  Thanks everyone.


Edited by leungalv, 04 April 2020 - 04:49 PM.

  • Luke likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users