Jump to content

How to trigger thumbnail creation of libraries


ariftwister
 Share

Recommended Posts

ariftwister

  5e5be6288423d_11.jpg5e5be6331902e_22.jpg

as seen in the above picture, these thumbnails for libraries which are auto generated are not perfect. How to trigger them to auto generate the thumbnail again.

Link to comment
Share on other sites

ariftwister

Hi, just run a library scan.

I tried both the individual library scan and all library scan, the results are the same. The auto generation of thumb only occurs once - when the library is created. 

Link to comment
Share on other sites

Happy2Play

I tried both the individual library scan and all library scan, the results are the same. The auto generation of thumb only occurs once - when the library is created. 

 

May need a server log, I have no issues deleting current image and doing a library scan to create a new image.  Are images displayed when you enter that library?

Link to comment
Share on other sites

ariftwister

May need a server log, I have no issues deleting current image and doing a library scan to create a new image.  Are images displayed when you enter that library?

Sent PM with logs attached.

 

I have to mention, the issue isn't new. For months, i learned to live with it. Now i decided to fix this once and for all

Link to comment
Share on other sites

eurotrash

Not sure if this is the correct way but I do this all the time and it works. First delete the library image, then go to "refresh metadata" for the library and tell it to just find missing metadata (I assume that's less intensive than replacing all metadata) and it rebuilds the image. Of course if you only have 2 shows in that library then you'll get the same image with duplicates.

Link to comment
Share on other sites

ariftwister

Not sure if this is the correct way but I do this all the time and it works. First delete the library image, then go to "refresh metadata" for the library and tell it to just find missing metadata (I assume that's less intensive than replacing all metadata) and it rebuilds the image. Of course if you only have 2 shows in that library then you'll get the same image with duplicates.

Just tried it, no effect.

Just to be clear, the example in the OP has repeat movie posters because when i was creating that library, i only had 2 movies. So it was generated like that. After that i added more movies, triggered library scan, search for missing metadata, its not changing. Only method is to delete the library entirely and create a new one. From then on, i only create a library with minimum 4 movies to avoid this problem.

Link to comment
Share on other sites

ariftwister

So you have movies with posters in your Tamil movies library?

Yes, plenty. 250 movies and all have posters.

Link to comment
Share on other sites

Happy2Play

Only thing I can think of is something flaky in your database for that library.

 

Have you tried adding a image, doing a library scan, then remove that image and do another library scan?

Link to comment
Share on other sites

ariftwister

Only thing I can think of is something flaky in your database for that library.

 

Have you tried adding a image, doing a library scan, then remove that image and do another library scan?

This i haven't tried. Will do. BTW, the issue is with all the libraries. Not just one. 

Link to comment
Share on other sites

miniliQuid

It even stays the same when you right click library and select refresh metadata and check the box "replace existing images" and hit refresh?
At that point I think all pictures in the library will be replaced, for me it always replaced the library picture as well (after it finished, so generally the next time I start emby on any device).

5e5ec05771617_refreshmetadata.jpg

Link to comment
Share on other sites

ariftwister

It even stays the same when you right click library and select refresh metadata and check the box "replace existing images" and hit refresh?

At that point I think all pictures in the library will be replaced, for me it always replaced the library picture as well (after it finished, so generally the next time I start emby on any device).

5e5ec05771617_refreshmetadata.jpg

Well i haven't tried it yet cause i have manually did some correction on so many movies it would be lost and thats the reason i have not deleted this library n created a new one.

 

However i can try this on a smaller library and see what happens

Link to comment
Share on other sites

ariftwister

Well i haven't tried it yet cause i have manually did some correction on so many movies it would be lost and thats the reason i have not deleted this library n created a new one.

 

However i can try this on a smaller library and see what happens

It did change on that smaller library. Hooray!!

 

But doing so in my larger library means i would lose so many changes i made. Is there any way to change just the library image?

Link to comment
Share on other sites

miniliQuid

You changed the pictures manually within the library?
If so do you have them saved within the folders in your library (with the movies/shows themselves)?

In that case you could copy/cut them away and replace the picture.
After that you simply place back all the folders/files.

If nothing else worked that is.

Cause usually deleting the picture and refreshing/scanning should work.
You could try making one yourself and replacing it manually, that should also work I guess?
In anyway, the method I described previously doesn't work for a single file as far as I know.

Link to comment
Share on other sites

ariftwister

You changed the pictures manually within the library?

If so do you have them saved within the folders in your library (with the movies/shows themselves)?

In that case you could copy/cut them away and replace the picture.

After that you simply place back all the folders/files.

 

If nothing else worked that is.

Cause usually deleting the picture and refreshing/scanning should work.

You could try making one yourself and replacing it manually, that should also work I guess?

In anyway, the method I described previously doesn't work for a single file as far as I know.

Not only is that library a big one, it contains folders from different directories/drives. So copy pasting again would certainly mess it up.

 

Is there any photoshop template for that ? I just want that library to look good with the rest of the other libraries as well. 

Link to comment
Share on other sites

miniliQuid

Not only is that library a big one, it contains folders from different directories/drives. So copy pasting again would certainly mess it up.

 

Is there any photoshop template for that ? I just want that library to look good with the rest of the other libraries as well. 

Not that I am familiar with, I simply adjusted 1 with paint once when it wasn't to my liking :(

Link to comment
Share on other sites

ariftwister

Not that I am familiar with, I simply adjusted 1 with paint once when it wasn't to my liking :(

Actually i remember seeing someone post a photoshop template with that design. Can't find it now  :(

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...