Jump to content


Photo

Chromecast problem away from home

chromecast

  • Please log in to reply
30 replies to this topic

#21 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157057 posts
  • Local time: 07:00 AM

Posted 29 February 2020 - 09:44 PM

Did you go through the things i asked you to try in this thread? 



#22 Kimballslice1890 OFFLINE  

Kimballslice1890

    Advanced Member

  • Members
  • 83 posts
  • Local time: 07:00 AM

Posted 03 March 2020 - 04:21 PM

I see you are hosting via HTTP and not HTTPS. Via your dashboard under network, secure connection mode, what is the listed option?

 

I had a similar issue with Chromecasts which required me purchasing a domain and acquiring a signed certificate (through Lets Encrypt, they're free) as chromecasts require a signed cert by a CA that is trusted by Google when streaming over HTTPS. Never tried streaming over HTTP outside of my LAN so I cannot say if the chromecast will even allow it or not.

 

Also this site may help you find your IPV4 address if you have one: https://whatismyipaddress.com/

 

Also, when you try to connect directly just to your IPV6 address instead of the dns, try typing it as: [2001:1284:f013:d1da:d82f:312f:abf2:6771]



#23 germanbuzz OFFLINE  

germanbuzz

    Member

  • Members
  • 15 posts

Posted 03 March 2020 - 07:06 PM

Did you go through the things i asked you to try in this thread? 

 

Hello. yes, it replaces the ddns of the external domain and now on the emby panel in remote access (WAN) is my IPv4 address.
 
I can get external access, but I can't play on the chromecast.
 
I installed the ddns program on the computer and it constantly updates both IPv4 and IPv6, I believe that is why I have access, as my operator does not release port on IPv4 (unless it is extremely necessary and after filling some things).


#24 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157057 posts
  • Local time: 07:00 AM

Posted 03 March 2020 - 07:10 PM

So you are connecting by external ip now? Or with the ddns address?



#25 germanbuzz OFFLINE  

germanbuzz

    Member

  • Members
  • 15 posts

Posted 03 March 2020 - 07:13 PM

in the emby app I put the ddns, but I don't know which IP it pulls, whether the 4 or 6, you know? because it automatically updates both.



#26 germanbuzz OFFLINE  

germanbuzz

    Member

  • Members
  • 15 posts

Posted 03 March 2020 - 07:16 PM

I see you are hosting via HTTP and not HTTPS. Via your dashboard under network, secure connection mode, what is the listed option?

 

I had a similar issue with Chromecasts which required me purchasing a domain and acquiring a signed certificate (through Lets Encrypt, they're free) as chromecasts require a signed cert by a CA that is trusted by Google when streaming over HTTPS. Never tried streaming over HTTP outside of my LAN so I cannot say if the chromecast will even allow it or not.

 

Also this site may help you find your IPV4 address if you have one: https://whatismyipaddress.com/

 

Also, when you try to connect directly just to your IPV6 address instead of the dns, try typing it as: [2001:1284:f013:d1da:d82f:312f:abf2:6771]

 

Hello. Thanks for responding.
So, I don't know much about networking, but I'll try to answer.
 
In connection mode on the panel it is: OFF
 
I don't know about the difference between HTTP and HTTPS.
To try the HTTPS connection, I just change the port on the app, right?
 
My operator does not release IPv4, so I think it has to be at 6.
 
I had already tried putting the IP in place of ddns and it didn't work.


#27 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157057 posts
  • Local time: 07:00 AM

Posted 04 March 2020 - 02:14 AM

in the emby app I put the ddns, but I don't know which IP it pulls, whether the 4 or 6, you know? because it automatically updates both.

 

@germanbuzz, the emby app doesn't "pull" anything. It relies on device support to resolve this DNS, which it sounds like it is a problem for Chromecast. So i would try first using ip address only connections.



#28 Kimballslice1890 OFFLINE  

Kimballslice1890

    Advanced Member

  • Members
  • 83 posts
  • Local time: 07:00 AM

Posted 04 March 2020 - 01:12 PM

 

Hello. Thanks for responding.
So, I don't know much about networking, but I'll try to answer.
 
In connection mode on the panel it is: OFF
 
I don't know about the difference between HTTP and HTTPS.
To try the HTTPS connection, I just change the port on the app, right?
 
My operator does not release IPv4, so I think it has to be at 6.
 
I had already tried putting the IP in place of ddns and it didn't work.

 

 

Okay, don't worry about the HTTPS thing for now as you have it OFF (wanted to see if it was reverting to https without you knowing).

 

I'd go with Luke's recommendation and try just using the IP and hold off on the ddns for now.

 

Also have you tried reverting the http port back to 8096 instead of using your custom 8065? 



#29 germanbuzz OFFLINE  

germanbuzz

    Member

  • Members
  • 15 posts

Posted 04 March 2020 - 01:24 PM

@germanbuzz, the emby app doesn't "pull" anything. It relies on device support to resolve this DNS, which it sounds like it is a problem for Chromecast. So i would try first using ip address only connections.

 

Maybe I expressed it badly, but I didn't mean that the emby "pulls" the ip, but the program I use for that purpose.
already tried with the IP address, but still have the same problems.


#30 germanbuzz OFFLINE  

germanbuzz

    Member

  • Members
  • 15 posts

Posted 04 March 2020 - 01:25 PM

Okay, don't worry about the HTTPS thing for now as you have it OFF (wanted to see if it was reverting to https without you knowing).

 

I'd go with Luke's recommendation and try just using the IP and hold off on the ddns for now.

 

Also have you tried reverting the http port back to 8096 instead of using your custom 8065? 

 

I understand. so, i already tried with IP address but it still doesn't work. He can access and by cell phone, smartv, tvbox I can watch the movies, but I can't transmit via chromecast.
over the door I didn't try to reverse. I will do that and warn you next. thanks


#31 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 157057 posts
  • Local time: 07:00 AM

Posted 04 March 2020 - 01:25 PM

How did you try that?





Also tagged with one or more of these keywords: chromecast

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users