Jump to content

Kodi mit Emby-Addon Fehler 403 bei Proxy in Kodi - Nur Windows Problem


vk_digi

Recommended Posts

vk_digi

Guten Tag,

 

ich habe mehrere Installation in der Kombination Kodi (18.5) mit Emby-Addon am laufen. Ich hab zusätzlich noch jeweils das Zattoo-PVR Addon installiert. Damit ich hier aus DE vollen Zugriff habe, hab ich im Kodi einen http Proxy auf einen Server in der Schweiz aktiviert. 

 

Das klappt auf allen Kisten sei es Fire TV Stick oder Pi3. Nur unter Windows gibt es ein Problem beim Zugriff auf die Stream im Emby-Server (der steht in Ger Data-Center).

 

Die Daten und Bilder werden alle korrekt angezeigt. Jedoch kann ich keinen Stream starten. Ich sehe im Logfile einen Fehler 403 - was wohl bedeutet, dass der Zugriff verweigert wurde. Im Logfile vom Emby-Server ist kein Zugriff zu sehen.

 

Als muss also bei Zugriff auf den Proxy mit IP 127.0.0.1 (lokal) abgewiesen werden. 

 

Wenn ich den Proxy im Kodi deaktiviere klappt alles wie es soll. Ich muss jedoch  eine Umleitung auf Schweiz machen wegen Zattoo und den bekannten Gründen.

 

Was kann ich da tun? 

 

Muss ich echt zwei Kodi-Installation auf der Win-Kiste (HTPC) haben einen mit Proxy für Zattoo und einen ohne für Emby? Das wäre nicht was mich wirklich begeistern würde.

 

Gruss 

MeinerEiner

Link to post
Share on other sites
Luke

Hi there, sounds like you need to configure the reverse proxy. What reverse proxy are you using? If you are using nginx then I would suggest comparing your nginx configuration to that of @@pir8radio.

Link to post
Share on other sites
vk_digi

Hallo,

 

nein das ist nicht so. Also nochmals kurz der Weg. 

 

Stick Fire TV:

Kodi,Emby-Addon,Proxy innerhalb von KODI, Router,Proxy in der Schweiz, Emby-Server Data-Center. Das klappt ohne jedes Problem

 

Windows:

Wie oben. Klappt nicht. Da in den Logs vom Emby-Server nichts zu finden ist und im Log vom Proxy in der Schweiz auch nicht, kommt der Fehler 403 aus meiner Sicht vom Proxy im KODI bzw beim Zugriff vom Kodi-Emby-Addon auf den Proxy innerhalb vom Kodi.

 

Sobald ich den Proxy-Zugriff im Kodi ausmache klappt auch der Zugriff in Windows Problem los.

 

Es liegt also an der Kombination Zugriff Emby-Add-On über Kodi-Proxy auf die IP 127.0.0.1....Der Proxy von Kodi bring 403. Warum auch immer.

Link to post
Share on other sites
Luke

Ok, I don't fully understand this situation so I'm not sure what the answer is yet. Did you figure this out?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...