Jump to content

Path could not be found


DutchEllie
 Share

Go to solution Solved by DutchEllie,

Recommended Posts

DutchEllie

Hi all,

 

I just installed emby server on my linux vps. I want to have my emby libraries on a different server however, specifically a onedrive server. Don't worry, I have that all sorted out, using rclone and a cache. It works like a charm. However, the folder currently is in the root directory, under the name of /onedrive owned by a user and group called qbtuser (from qbittorrent) so it can write nicely to it. Now I need to assign the emby libraries to somewhere like /onedrive/movies and /onedrive/series. However when I try to add a library in emby server and specify the folder, /onedrive is not found.

 

/onedrive is owned by user and group qbtuser, and the directories and files inside are given the permissions of 775. The folder /onedrive itself also has permissions 775. Now, not only does that mean that everyone should be able to read and see what is in every folder, but the first problem arose when the root user tried to read from the /onedrive folder, and they are not allowed to.. Now also emby is not allowed to read or anything. 

 

There is a group qbtuser as mentioned before and I have added emby to that, and even rebooted the server, but it still does not work.

I am out of ideas. Anyone else got any ideas?

 

Link to comment
Share on other sites

  • Solution
DutchEllie

 

Those did not help, but as always when I post something on a forum I figured it out myself.

The reason it did not work was because the permissions for the mounted onedrive folder work quite differently from regular folder permissions, in the sense that you cannot just sudo chown or sudo chmod them. You have to specify the permissions beforehand when mounting the drive. I figured out after some searching that there is a flag called --allow-other in the rclone mount command, as well as an --allow-root. So what happened was when I mounted the drive to the folder I did it using the qbtuser, therefor the ownership was in the hands of the qbtuser. This worked great for qbittorrent, but not for anything else. I unmounted it using qbtuser and mounted it again using the root user (sudo su) and added the flag --allow-other. Worked absolutely perfectly... Thanks anyway

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...