Jump to content


Photo

Android Auto testing


  • Please log in to reply
164 replies to this topic

#1 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156956 posts
  • Local time: 01:38 PM

Posted 07 February 2020 - 02:21 PM

Is anyone here equipped to help us test that with the mobile app?

 

Here is a test build supporting Android Auto:

-- Install the beta from the play store

 

To Do

This doesn't support downloaded content yet, but it's coming


  • Sammy, skidmarks, SikSlayer and 2 others like this

#2 groovejumper OFFLINE  

groovejumper

    Member

  • Members
  • 21 posts
  • Local time: 12:38 PM

Posted 07 February 2020 - 02:32 PM

Yes!!  I use Android Auto (almost) daily, and Emby (definitely) daily.  Fully set up for remote access.  

 

While my music is currently on Airsonic I can easily add it to Emby as well, would much prefer a solution like that.

 

Let me know how I can help.


  • Sammy likes this

#3 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 07 February 2020 - 02:33 PM

Yes. I have Android Auto in my car and a Galaxy S9 just updated to Android Q.

Sent from my SM-G960U1 using Tapatalk

#4 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 07 February 2020 - 03:26 PM

Can't wait to check this out in my car on my drive home tonight.

 

 

53c7e79a3e70fe1b79261d78b59d30a2.jpg         31fef86927bf07a3e25749d6df2d48e6.jpg

Sent from my SM-G960U1 using Tapatalk


Edited by Sammy, 07 February 2020 - 03:39 PM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156956 posts
  • Local time: 01:38 PM

Posted 07 February 2020 - 03:28 PM

Well you shouldn't have to go into the Emby app. You should be able to just use the android UI to browse the content.


  • Sammy likes this

#6 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 07 February 2020 - 03:36 PM

This is Android Auto UI on my phone. Tonight I'll tether my phone to my Android Auto headset and give it a spin..

Sent from my SM-G960U1 using Tapatalk

#7 groovejumper OFFLINE  

groovejumper

    Member

  • Members
  • 21 posts
  • Local time: 12:38 PM

Posted 07 February 2020 - 06:25 PM

It was very exciting to see Emby come up on my car's head unit...  First notes: probably only need to see libraries with the Music category, it was neat to browse through tv shows/etc but obviously they won't play...

 

Bigger problem though is that no tracks would actually play - it would appear on-screen and the time counter running, but no audio.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156956 posts
  • Local time: 01:38 PM

Posted 07 February 2020 - 06:39 PM

It was very exciting to see Emby come up on my car's head unit...  First notes: probably only need to see libraries with the Music category, it was neat to browse through tv shows/etc but obviously they won't play...

 

Bigger problem though is that no tracks would actually play - it would appear on-screen and the time counter running, but no audio.

server log?



#9 groovejumper OFFLINE  

groovejumper

    Member

  • Members
  • 21 posts
  • Local time: 12:38 PM

Posted 07 February 2020 - 06:50 PM

PM sent.



#10 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 07 February 2020 - 08:38 PM

It is working for me here. . Can't select to play an entire album. I think maybe that's an issue with the Emby music player?

Sent from my SM-G960U1 using Tapatalk

#11 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 07 February 2020 - 09:44 PM

I can kick off playing an album from the Emby app on my phone and then it shows up in Android Auto on my head unit.

This may be an Android Auto thing but it only shows about six to eight titles and then says search by voice. It would be nice to be able to scroll through the entire Library.

Sent from my SM-G960U1 using Tapatalk

#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156956 posts
  • Local time: 01:38 PM

Posted 07 February 2020 - 10:10 PM

It is working for me here. . Can't select to play an entire album. I think maybe that's an issue with the Emby music player?

Sent from my SM-G960U1 using Tapatalk

 

What happens when you try to play an album?



#13 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 07 February 2020 - 10:27 PM

It goes to the tracklist where it only lets you select one track.

Sent from my SM-G960U1 using Tapatalk

#14 adamstewiegreen OFFLINE  

adamstewiegreen

    Advanced Member

  • Members
  • 333 posts
  • Local time: 03:38 AM
  • LocationMuswellbrook, NSW

Posted 08 February 2020 - 12:41 AM

Samsung galaxy S7
Latest Emby android mobile beta
Latest Emby server beta (mac) (4.4.0.12?)


Couldnt get android auto to play. Showed it was going but nothing coming through the car speakers. Switched to yatse (same album/song) and it played fine.

I'll send server logs when I can.

#15 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3536 posts
  • Local time: 10:38 AM

Posted 08 February 2020 - 10:49 AM

I've tried to get some pics of my headunit display but Android Auto won't let me. I'll need to find another way? I do have an actual camera.. I'll probably have to use that.



#16 mmmbusby OFFLINE  

mmmbusby

    Newbie

  • Members
  • 7 posts
  • Local time: 11:38 AM

Posted 08 February 2020 - 11:35 PM

OK, so I tried it out today on my Samsung Galaxy S10+. I tried it on two different head units. On both of them, I had the same issues. It is not showing all of the artists. On the ones that were showing, not all of the songs were listed under each album. When you do select a song, it only plays that song. It does not continue to the next song. Also, hitting the next track or previous track button does nothing.

 

A couple of other things to note. Maybe I am missing something, but I could not find any way to sort things (Albums/Album Artists/Artists/Playlists...) Also, nothing regarding shuffle.

 

It is awesome that this is starting to move forward. I am more than willing to continue testing things as it progresses.

 

Keep up the good work, 

 

Mike



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156956 posts
  • Local time: 01:38 PM

Posted 09 February 2020 - 12:03 AM

 

 

It is not showing all of the artists. 

Right now all we've done is straight folder browsing, so it should match the contents of the Folders tab of the web app, right?



#18 mmmbusby OFFLINE  

mmmbusby

    Newbie

  • Members
  • 7 posts
  • Local time: 11:38 AM

Posted 09 February 2020 - 09:55 AM

Right now all we've done is straight folder browsing, so it should match the contents of the Folders tab of the web app, right?

The app on the phone does show everything correctly.

 

Android Auto on my head unit does not. What I did notice is that the folders are not in alphabetical order like the web app and android app does. If I search for them, then they appear. Of course, it only shows a few on the list before the "Voice search while driving" thing comes up. Also, If I do select an artist, not all of the albums are appearing.

 

Let me know if you need me to test anything else...I'm here to help.

 

Mike



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156956 posts
  • Local time: 01:38 PM

Posted 10 February 2020 - 01:42 PM

The build in the first post is updated based on current reports. Thanks guys.



#20 mmmbusby OFFLINE  

mmmbusby

    Newbie

  • Members
  • 7 posts
  • Local time: 11:38 AM

Posted 11 February 2020 - 04:32 AM

The build in the first post is updated based on current reports. Thanks guys.

 

I tried out the updated version, but I don't see any difference. The artists are still not showing up in order, and it still only plays one song and then stops.

 

I do have another question. What do you need to say to Google to get it to play something in Emby? Right now, I can say "Play Disciple in Poweramp", and it will open Poweramp and start playing Disciple's music. I can't seem to get this to work with Emby.

 

Looking forward to the next update!!

 

Mike






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users