Jump to content


Photo

Movies # - Z (Home Buttom to get out)



  • Please log in to reply
20 replies to this topic

#1 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 02:19 AM

Been like this for a week or so, but decide to just ride it out until now.  Got something going on with the quick picker in my movies library.  Go to Movies then select a random letter.  Last attempt was selecting R.  Will get the spiny wheel.  Unfortunately after a minute and a half or so i hit the back button.  Get clunk sound when doing so.  But the only way out is with the roku home button.  Haven't been keeping up with the roku releases recently, so don't know if this is roku or server.  Read a thread about deleting dll files?  Don't know if this issue pertains to that one or not.

 

On the server side and theater selecting R will return instant results (movies jump to the first R)

 

Notice some port mapping issues in this log? 

 

Will PM log.  I created a new one and believe this issue should be found in it.

 

Thanks in Advance...

 

(Kind of checked for any strange new movie titles in the past week, but didn't see any rouge characters)

 

 



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 09:26 AM

What version of the app do you have?  This has been happening for a week?



#3 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 823 posts
  • Local time: 02:05 AM
  • LocationTennessee

Posted 06 February 2020 - 10:27 AM

I have noticed that as well but I generally just wait out the spinning wheel until it finally gets everything loaded and displays what I want. So far the maximum wait time when first entering "Movies" and choosing say "W" has been about three minutes for my about 3000 movie library.

 

After that first load, if it is deep in the library say at least "S", subsequent letter choices are almost instant. 

 

I do not remember ever trying to exit the spinning wheel for sure but I think I get the same effect. That is I cannot exit with back and I have to use home and exit the app. Again that is what my memory says happened but it is so rare that I just do not wait for the operation to complete that I just do not remember for sure.

 

While I was posting this I decided to do a quick test and I can verify that the behavior reported, that you cannot exit the spinning wheel with the back button, is exactly what happens.

 

To add: I also have verified that once you successfully select a letter late in the alphabet subsequent selections are nearly instant.



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 10:34 AM

In order to make the picker work the way it does in this interface, we do have to retrieve your library up to the letter you select but nothing should have changed recently in how this works.

 

Can you select one of the lower letters and wait out the spinner and then immediately go back to the app home and send the log from the app?

 

Thanks.



#5 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 10:50 AM

In order to make the picker work the way it does in this interface, we do have to retrieve your library up to the letter you select but nothing should have changed recently in how this works.

 

Can you select one of the lower letters and wait out the spinner and then immediately go back to the app home and send the log from the app?

 

Thanks.

Will do so now ebr...

 

Yes this has been an issue for at least a week, possibly longer.  Tried the Android TV late last night and it went to R within 4 seconds.

 

Going up to send log now,

Thanks!



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:06 AM

Also, if you use the release version of the app, does it perform better?

 

It looks to me like something has slowed way down in our processing of results in this app but I don't know when that happened.



#7 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 823 posts
  • Local time: 02:05 AM
  • LocationTennessee

Posted 06 February 2020 - 11:10 AM

In order to make the picker work the way it does in this interface, we do have to retrieve your library up to the letter you select but nothing should have changed recently in how this works.

 

...

 

I do not know enough about the Roku system to know if it is possible but could you not begin a pre-fetch and run it in the background when the library is loaded. The fact that selections work almost instantly after a late letter is chosen makes me think that pre-loading is possible and "might" be a good idea but it also might be a lot too slow so that is why I mentioned running it in the background and that is what I do not know if it is possible.

 

I do not remember if that fast selection is still true after a video has been selected and played

 

Edit: I tested and the release version of the app does behave the same way.


Edited by Gilgamesh_48, 06 February 2020 - 11:14 AM.


#8 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:11 AM

Spent about 6 minutes trying to get to R (backed out with the home button) then another 5 trying to get to N (used the home button again).  Got to G within a minute +/-

 

Log sent


Edited by skidmarks, 06 February 2020 - 11:19 AM.


#9 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:14 AM

Also, if you use the release version of the app, does it perform better?

 

Knowing that will help to identify when this change occurred.  Thanks.



#10 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:21 AM

Knowing that will help to identify when this change occurred.  Thanks.

Will go put on the stable release. 



#11 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 823 posts
  • Local time: 02:05 AM
  • LocationTennessee

Posted 06 February 2020 - 11:22 AM

On my system getting to "W" took only about 1.5 minutes. My library that I tested on has 2550 entries in it. While not ideal that seems acceptable. 
My server is Version 4.4.0.11 beta and my Roku ultra's app is 3.0.208



#12 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:32 AM

Knowing that will help to identify when this change occurred.  Thanks.

The stable has the exact same issue...  seems to be about the same amount of time to get G loaded.  Gave up on lower letters.

 

So obviously something else needs to be the root cause of this new problem.  Maybe i should start by removing cover art and turn off background images?

 

 

 

On my system getting to "W" took only about 1.5 minutes. My library that I tested on has 2550 entries in it. While not ideal that seems acceptable. 
My server is Version 4.4.0.11 beta and my Roku ultra's app is 3.0.208

I have a few more in my library.  Movie quick jump was never a issue in my recent memory.  I could get anywhere in an acceptable amount of time.  Definitely in less than a minute or two.  


Edited by skidmarks, 06 February 2020 - 11:37 AM.


#13 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:39 AM

So obviously something else needs to be the root cause of this new problem.  Maybe i should start by removing cover art and turn off background images?

 

I don't think so.  I just think maybe you haven't noticed it until now.

 

I can reproduce slower processing than we used to have here but it has been a while since I've tested this.  Whatever the change was, I think is just also in the release.



#14 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 823 posts
  • Local time: 02:05 AM
  • LocationTennessee

Posted 06 February 2020 - 11:46 AM

...

I have a few more in my library.  Movie quick jump was never a issue in my recent memory.  I could get anywhere in an acceptable amount of time.  Definitely in less than a minute or two.  

 

I decided some time ago due to performance issues that I would keep individual libraries at less than 3000 entries for movies. I do not know if that is still needed but it was in the past and I developed the habit of keeping my libraries less than 3000. I kind of guess that the issues  that caused that choice may no longer exist but it developed into a habit that is still ongoing and does not seem to hurt anything.



#15 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 11:50 AM

I don't think so.  I just think maybe you haven't noticed it until now.

 

I can reproduce slower processing than we used to have here but it has been a while since I've tested this.  Whatever the change was, I think is just also in the release.

Admittedly i do not focus my attention to movies, music and TV are the norm.  But this movie jump list would have gotten my attention pretty quickly.  I usually give it a week, became head shy, to see if fixes occur before i report issues.  This has to be within the last month i would say.



#16 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 12:10 PM

I think I've found the culprit.   Now I just need to figure out how to fix it...


  • skidmarks likes this

#17 Gilgamesh_48 OFFLINE  

Gilgamesh_48

    Advanced Member

  • Members
  • 823 posts
  • Local time: 02:05 AM
  • LocationTennessee

Posted 06 February 2020 - 12:13 PM

I think I've found the culprit.   Now I just need to figure out how to fix it...

 

Just take it to a good vet to have it "fixed."



#18 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 04:37 PM   Best Answer

Try .209...


  • skidmarks likes this

#19 skidmarks OFFLINE  

skidmarks

    Advanced Member

  • Members
  • 506 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 04:52 PM

Try .209...

6 - 7 seconds to jump to R!!! 

 

As always, you the man!

 

Thanks!


Edited by skidmarks, 06 February 2020 - 04:54 PM.


#20 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50059 posts
  • Local time: 02:05 AM

Posted 06 February 2020 - 05:05 PM

On my system getting to "W" took only about 1.5 minutes. My library that I tested on has 2550 entries in it. While not ideal that seems acceptable. 
My server is Version 4.4.0.11 beta and my Roku ultra's app is 3.0.208

 

That is not acceptable in my book.

 

Please try 209.  I would expect 15 seconds or less for that same jump...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users