Jump to content


Photo

Synology Freigaben verbinden


  • Please log in to reply
13 replies to this topic

#1 mws OFFLINE  

mws

    Newbie

  • Members
  • 8 posts
  • Local time: 11:38 AM

Posted 24 January 2020 - 10:16 AM

Hallo,

 

ich habe gerade unter Debian 9 Emby installiert und versuche nun (bisher erfolglos) meine Multimedia- Ordner in Emby einzubinden, welche sich auf meinem Synology NAS befinden.

 

Könnt Ihr mir sagen, wie ich dabei vorgehen muss um die Freigaben zu verbinden?

 

Bisher erhalte ich immer die Fehlermeldung: "The path could not be found. Please ensure the path is valid and try again."

Mir ist außerdem aufgefallen, dass ich nirgends eine Möglichkeit habe um Zugangsdaten für die Serververbindung einzutragen.

 

Liebe Grüße

Manuel

 

 



#2 MarcelF1 OFFLINE  

MarcelF1

    Newbie

  • Members
  • 3 posts
  • Local time: 11:38 AM

Posted 24 January 2020 - 03:45 PM

Hallo,

 

ich habe gerade unter Debian 9 Emby installiert und versuche nun (bisher erfolglos) meine Multimedia- Ordner in Emby einzubinden, welche sich auf meinem Synology NAS befinden.

 

Könnt Ihr mir sagen, wie ich dabei vorgehen muss um die Freigaben zu verbinden?

 

Bisher erhalte ich immer die Fehlermeldung: "The path could not be found. Please ensure the path is valid and try again."

Mir ist außerdem aufgefallen, dass ich nirgends eine Möglichkeit habe um Zugangsdaten für die Serververbindung einzutragen.

 

Liebe Grüße

Manuel

 

Hi bin zwar auch relativ neu hier aber ich habe auch meine Ordner auf ner Synology

 

hast du den optionalen Pfad mit smb://Diskstation  und dann deinen Ordner angegeben


Edited by MarcelF1, 24 January 2020 - 03:48 PM.


#3 mws OFFLINE  

mws

    Newbie

  • Members
  • 8 posts
  • Local time: 11:38 AM

Posted 24 January 2020 - 05:33 PM

Hi,

 

ja, das habe ich auch schon versucht, allerdings kann ich die Ordner einfach nicht hinzufügen.

 

Attached File  Bildschirmfoto 2020-01-24 um 22.31.47.png   70.32KB   2 downloads

 

lg

Manuel



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148965 posts
  • Local time: 05:38 AM

Posted 25 January 2020 - 01:23 AM

HI, try instead mounting the network share to a local share using the tools in the OS. Then add the local share path to Emby Server. Please let us know if this helps. Thanks.



#5 MarcelF1 OFFLINE  

MarcelF1

    Newbie

  • Members
  • 3 posts
  • Local time: 11:38 AM

Posted 25 January 2020 - 03:00 AM

bei mir sieht das etwas anders aus

Attached Files


Edited by MarcelF1, 25 January 2020 - 03:01 AM.


#6 mws OFFLINE  

mws

    Newbie

  • Members
  • 8 posts
  • Local time: 11:38 AM

Posted 26 January 2020 - 09:44 AM

HI, try instead mounting the network share to a local share using the tools in the OS. Then add the local share path to Emby Server. Please let us know if this helps. Thanks.

 

Hi,

 

i have now mounted the network share on Debian directly like:

mount -t nfs 10.1.1.5:/volume1/folder1 /mnt/folder1

After the mount i can access the share directly on debian an see all files and folders but when i want to add the mount directory /mnt/folder1 in emby it doesn't work.

When i browse in folder selection to /mnt/ i see the mount folder called folder1 but when I click on it the complete folder selection disappears.

5e2d97a9bb745_emby.gif



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148965 posts
  • Local time: 05:38 AM

Posted 26 January 2020 - 02:55 PM

@mws this likely means the server doesn't have permissions to read the contents of the folder. Have you checked on this?



#8 Dibbes OFFLINE  

Dibbes

    Advanced Member

  • Members
  • 1001 posts
  • Local time: 11:38 AM
  • LocationMadrid, Spain

Posted 26 January 2020 - 02:56 PM

sieht aus wie ein Berechtigungsproblem... kannst du mal direkt im Directory auf dem Server schauen?


Edited by Dibbes, 26 January 2020 - 02:58 PM.


#9 mws OFFLINE  

mws

    Newbie

  • Members
  • 8 posts
  • Local time: 11:38 AM

Posted 26 January 2020 - 04:27 PM

@mws this likely means the server doesn't have permissions to read the contents of the folder. Have you checked on this?

I think so too but i don't know why. Because on the debian terminal i can access the share without problems. It could just be that the emby user has no rights to do so, but I don't know how to change the rights for it.

5e2df5c54b7a1_emby3.gif

 

sieht aus wie ein Berechtigungsproblem... kannst du mal direkt im Directory auf dem Server schauen?

Wie bereits darüber auf Englisch geschrieben gehe ich auch davon aus. Ich weiß leider nur nicht wie ich die Berechtigung anpassen muss bzw. kann. Direkt über das Terminal funktionier der Ordner- Zugriff ja problemlos, aber da bin ich auch als Root- Benutzer angemeldet.



#10 Dibbes OFFLINE  

Dibbes

    Advanced Member

  • Members
  • 1001 posts
  • Local time: 11:38 AM
  • LocationMadrid, Spain

Posted 26 January 2020 - 06:04 PM

Wie bereits darüber auf Englisch geschrieben gehe ich auch davon aus. Ich weiß leider nur nicht wie ich die Berechtigung anpassen muss bzw. kann. Direkt über das Terminal funktionier der Ordner- Zugriff ja problemlos, aber da bin ich auch als Root- Benutzer angemeldet.

Ich hatte das gleiche Problem mit Ubuntu. Ich habe das mit CIFS erledigt. Da dein English super scheint, werde ich diese URL nicht uebersetzen: https://help.ubuntu....aresPermanently



#11 Sebmuh83 OFFLINE  

Sebmuh83

    Newbie

  • Members
  • 4 posts

Posted 05 February 2020 - 06:12 AM

@Dibbes

Zwar schon ein paar Tage älter, aber das geht recht simpel über die Weboberfläche der Synology.

Systemsteuerung - Gemeinsame Ordner (dann den Ordner den du freigegeben hast) - bearbeiten - Berechtigungen

Dort solltest du für den emby Nutzer den Lese/Schreibzugriff auf den Ordner freigeben.

Bei mir läuft der emby Server direkt auf der Synology und unter Berechtigungen habe ich dann unter lokale Benutzer den emby Server für den ich den jeweiligen Ordner freigeben musste.

Vorher hatte ich das gleiche Problem


  • Dibbes likes this

#12 Dibbes OFFLINE  

Dibbes

    Advanced Member

  • Members
  • 1001 posts
  • Local time: 11:38 AM
  • LocationMadrid, Spain

Posted 09 February 2020 - 10:34 AM

@Sebmuh83 das Problem hier war mit einem Server die niet direkt auf der SYnology laeuft, sondern auf Ubuntu mit external storage... Du hast ja recht wenn Emby direkt auf der Synology laeuft...



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148965 posts
  • Local time: 05:38 AM

Posted 10 February 2020 - 02:13 PM

@Dibbes is there still an issue?



#14 Dibbes OFFLINE  

Dibbes

    Advanced Member

  • Members
  • 1001 posts
  • Local time: 11:38 AM
  • LocationMadrid, Spain

Posted 10 February 2020 - 08:27 PM

Nope... All seems to work now


  • Luke likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users