Jump to content


Photo

[Solved?] Error 500 & Huh .. Looks like I have no content to show you in this view I'm afraid

error orsay tizen

  • Please log in to reply
7 replies to this topic

#1 ogry OFFLINE  

ogry

    Newbie

  • Members
  • 9 posts
  • Local time: 12:41 AM

Posted 23 January 2020 - 12:11 PM

With the appearance of version 4, some problems began to appear in the behavior of the application that I installed on my Samsung TV of the UH6900 series (of a somewhat special type, halfway between Orsay and Tizen)

While the movie library was navigating properly, the series began to give problems. The first thing we noticed was that the announcement of new episodes of the series that we followed stopped appearing on the main screen.

Then we realized that if we tried to go to TV -> Latest and navigate the series from there, the system responded with an error message 500 (server error)


The solution seemed to be to start playback from the web application on the computer, leave it halfway and then play it from the TV.

Then we also saw with astonishment that for any series, new or old, when selected from the catalog, the system responded with a funny message:

 
 
Huh .. Looks like I have no content to show you in this view I'm afraid

 

 

 
And it brought you back to the home screen.
 
At this point, I started to investigate online to see if anyone had the same problems, and so I reached the thread that opened @Leyst last March. There I left a workaround that served to at least watch some episodes.
 
But, of course, that is not enough.
 
As an old developer, I would have liked to find the source code of the server. Surely I would have advanced faster and solved the problems better.
 
I took advantage of that just @SamES announced a last revised release of the client application for Samsung to install and configure the Samsung TV SDK (V 5.1), with the Oracle emulator and the appropriate extensions, and thus test that promising version 2.2.6a
 
To my discontent, none of the problems I experienced were solved, at least with the current version of the server, 4.3.1.0
 
Willing to keep it that way, I started to get my hands on the code, struggling my old brain, trying to fix them.
 
There is a problem with the way the server responds to the GETs that the application launches. The API now behaves in a different way. For example, in previous versions the list of episodes of a series did not depend on the season, and the client could skip the query and later regroup the episodes. Now it is obligatory to indicate in the query the season to which the requested episodes belong. If you don't, the result is not an error, but an unexpected empty list. Hence one of the mistakes.
 
The other comes from the query that should return the new episodes of a series. Instead, it gives an error 500 (server error)
 
Well, if there is someone who has the same problem and wants to save a couple of weeks of research, here I leave version 2.2.7 that I think solves at least those two problems (I have noticed that there are more, among others the screen resolution, which is not published correctly)
 
To install it, if the television does not have Tizen (USB installer), it is best to follow the guidelines in this link (it is a mess for the neophytes)
 
 
Finally, I can try to do some other corrective maintenance operation on the Samsung client code, but I can only be there until the end of February of this year. I will respond in this thread and to the private ones.

 

Attached Files



#2 ogry OFFLINE  

ogry

    Newbie

  • Members
  • 9 posts
  • Local time: 12:41 AM

Posted 23 January 2020 - 12:18 PM

Sorry, this is the widgetlist.xml you need to put in webroot to install the package

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<rsp stat="ok">
<list>
<widget id="Emby">
<title>Emby</title>
<compression size="966012" type="zip"/>
<description>SoluciĆ³n a un par de problemas</description>
<download>http://192.168.56.1/Widget/Emby_2.2.7_Europe_20200123.zip</download>
</widget>
</list>
</rsp>



#3 ogry OFFLINE  

ogry

    Newbie

  • Members
  • 9 posts
  • Local time: 12:41 AM

Posted 23 January 2020 - 12:19 PM

Damn, and this is the correct zip file

Attached Files


  • FrostByte likes this

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152667 posts
  • Local time: 07:41 PM

Posted 23 January 2020 - 12:36 PM

Hi that's great, thanks for doing this !

#5 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1217 posts
  • Local time: 10:41 AM

Posted 24 January 2020 - 07:37 AM

Thanks, let me know when you can confirm the changes are all good and I'll merge them in



#6 ogry OFFLINE  

ogry

    Newbie

  • Members
  • 9 posts
  • Local time: 12:41 AM

Posted 24 January 2020 - 10:03 AM

Hello @SamES,

 

I would also like to have a second (and even a third) confirmation. I can only say that ... it works for me.


#7 SamES OFFLINE  

SamES

    Advanced Member

  • Members
  • 1217 posts
  • Local time: 10:41 AM

Posted 24 January 2020 - 04:37 PM

 

Hello @SamES,

 

I would also like to have a second (and even a third) confirmation. I can only say that ... it works for me.

 

 

Sure.  If you can give me the steps to reproduce the original problem, I will try it here as well.  Is it just latest episodes for a series that is a problem?



#8 ogry OFFLINE  

ogry

    Newbie

  • Members
  • 9 posts
  • Local time: 12:41 AM

Posted 24 January 2020 - 05:06 PM

 

Then we realized that if we tried to go to TV -> Latest and navigate the series from there, the system responded with an error message 500 (server error)

 

 

 

This ocurred for the new series.

 

 

Then we also saw with astonishment that for any series, new or old, when selected from the catalog, the system responded with a funny message:
 
 

Quote

Huh .. Looks like I have no content to show you in this view I'm afraid

 

 

 

 

 

 

This is since upgrading to 4.2 or 4.3, may be coincident with a full scan of librarys...







Also tagged with one or more of these keywords: error, orsay, tizen

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users