Jump to content


Photo

Rendering Home Page in Web App Causes Live TV to Pause


  • Please log in to reply
15 replies to this topic

#1 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 20 January 2020 - 06:30 AM

Had this forever but havent bothered to report it before:

 

Live TV comes from an m3u. Its created by xteve v1 so no redirection through xteve. not that this is relevant anyway because i had it before i used xteve too. before xteve it come partly from a local install of dvbviewer and partly from an iptv m3u.

 

Typically i'm watching live tv on android tv and if, in a web browser, i open emby so the home page renders, or i do a search in emby the live tv stream pauses for a second or two while those actions complete. after they complete it carries on from the same point so its not skipping that brief period. doesnt happen every time, but maybe 50%. should be easy enough to catch in a log if that will show it. but will it? video?

 

but its annoying me now. what can i provide to show this? no idea if it happens with other clients as i don't really use them.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153473 posts
  • Local time: 06:06 PM

Posted 20 January 2020 - 10:20 PM

How many cores is your server cpu? If you play from the web app on the same machine, and then do the same thing in another browser tab, does it happen then?

#3 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 21 January 2020 - 05:54 AM

How many cores is your server cpu? If you play from the web app on the same machine, and then do the same thing in another browser tab, does it happen then?

its an i7 4790K so 4 cores, 8 threads. Also 32Gb of RAM. so i doubt its system resources.

 

As to your second question, its difficult to confirm. it doesnt happen all the time and when i tried to make it happen this morning i couldnt. I will continue to investigate and try to work out if there is something else going on in the system at the same time that could be the cause.

 

For now i wanted to put it out there and see if anyone else had similar experiences. I've checked with the group of users i regularly converse with and no-one there has seen it



#4 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 22 January 2020 - 04:12 PM

How many cores is your server cpu? If you play from the web app on the same machine, and then do the same thing in another browser tab, does it happen then?

happened at 19.37. Opened web app in firefox on my laptop and tv on shield paused as the home screen rendered

 

i'll try and catch in on the same machine

 

Attached File  embyserver.zip   3.32MB   2 downloads



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153473 posts
  • Local time: 06:06 PM

Posted 27 January 2020 - 12:32 AM

Ok, thanks. Let's see if the next beta helps with it.



#6 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 27 January 2020 - 03:59 AM

Ok, thanks. Let's see if the next beta helps with it.

i don’t use the beta server so I’ll wait for it to come out in stable.

#7 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 02 February 2020 - 06:27 PM

Ok, thanks. Let's see if the next beta helps with it.

Also interesting to note that this also happens with live tv through punktchen's virtual tv plugin. so there is something going on with emby's live tv function.

 

obviously havent been able to test any updates yet though...



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153473 posts
  • Local time: 06:06 PM

Posted 02 February 2020 - 06:30 PM

Thanks for the info.

#9 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 14 February 2020 - 03:59 PM

Thanks for the info.

changed to beta. its no better i'm afraid



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153473 posts
  • Local time: 06:06 PM

Posted 14 February 2020 - 05:27 PM

Once this happens, after the home page is open i assume it eventually calms down and stabilizes right? Once it does, if you refresh the home page in the browser, does it pause again?



#11 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 15 February 2020 - 06:19 AM

Once this happens, after the home page is open i assume it eventually calms down and stabilizes right? Once it does, if you refresh the home page in the browser, does it pause again?

correct, once it’s happened refreshing the same page has no effect. It’s generally caused by the home page rendering ( which to be fair I do have quite a lot if stuff on) or search.

Just a bit curious that no one else sees this

#12 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 15 February 2020 - 08:10 AM

disabled cover art and i will see if this has any effect



#13 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 22 February 2020 - 07:29 AM

removing cover art has had no effect



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153473 posts
  • Local time: 06:06 PM

Posted 22 February 2020 - 02:57 PM

I assume you've updated the server again?

#15 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4581 posts
  • Local time: 11:06 PM

Posted 22 February 2020 - 08:21 PM

I assume you've updated the server again?

on 4.4.0.15. Update just came through

#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153473 posts
  • Local time: 06:06 PM

Posted 22 February 2020 - 09:53 PM

Ok thanks for the info.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users