Jump to content


Photo

Choppy playback on 4K UHD

4K UHD HDR

  • Please log in to reply
3 replies to this topic

#1 DaSilva OFFLINE  

DaSilva

    Advanced Member

  • Members
  • 87 posts
  • Local time: 02:46 AM

Posted 15 January 2020 - 01:49 PM

I think this is mainly @Doofus but anyone who can may help offcourse.

I'm running latest stable build with following mpv.conf

gpu-api=auto
icc-profile=C:\Windows\System32\spool\drivers\color\Adobe RGB (1998) D65 WP 2.2 Gamma.icc
icc-contrast=inf
hdr-compute-peak=auto
tone-mapping=reinhard
hwdec-codecs=all

This is my complete mpv.conf btw, nothing more in it.

Hardware Acceleration Mode is set to "UNSET", no DEINTERLACING and everything else in Theater video unchecked.

 

When I watch my normal Blu-Ray's in a mkv container everything is fine and I have a nice image but when I watch my UHD Blu-Ray's (also in mkv container) I get choppy playback and stuttering.

What can I change in the config to keep the nice quality for 1080p but also get smooth playback for 4k?

Theater is running on latest Win10 with a GTX 1060 videocard.

This is mainly for the wife and kids because they use the native mpv for stability and useability.

I'm still using mpc-be with madvr as an external player (for auto HDR and framerate switching) and no problems there.

Thank you very much in advance!

 


#2 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13710 posts
  • Local time: 06:46 PM

Posted 15 January 2020 - 02:03 PM

Try using the latest test build, with no conf. But you don't have hardware acceleration, enabled. Add hwdec=auto to the conf.

Edited by Doofus, 15 January 2020 - 02:16 PM.


#3 DaSilva OFFLINE  

DaSilva

    Advanced Member

  • Members
  • 87 posts
  • Local time: 02:46 AM

Posted 15 January 2020 - 02:40 PM

Thanks I will add hwdec=auto to my conf!
Should I remove gpu-api=auto then or is this something different?

#4 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13710 posts
  • Local time: 06:46 PM

Posted 15 January 2020 - 03:12 PM

No, that's fine. But if you use the test build, don't use that conf. Just enable auto in the settings and enable HDR for Windows, and hit play.





Also tagged with one or more of these keywords: 4K, UHD, HDR

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users