Jump to content


Photo

Can't direct play 4k to Chromecast Ultra

chromecast direct play transcoding

Best Answer Luke , 11 January 2020 - 02:54 PM

No, it's only when it's aac more than 2 channels, or a secondary audio track (non-default).

Go to the full post


  • Please log in to reply
27 replies to this topic

#1 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 08 January 2020 - 06:39 PM

Hi, I would like to direct play a movie to my Chromecast Ultra but i can't....

I can't understand why because here https://github.com/M...wiki/Chromecast, it says that MKV is supported by Chromecast, but when I try to play it it says 

"The media is compatible with the device regarding resolution and media type (H.264, AC3, etc.), but is in an incompatible file container (.mkv, .avi, .wmv, etc.). The video will be re-packaged on the fly before streaming it to the device."...

 

Do you know why ?

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 09 January 2020 - 02:22 PM

Hi, this video has AAC 5.1. With AAC audio Chromecast only supports up to 2 channels. They dropped 5.1 support a couple years ago. Does this answer your question?



#3 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 08:26 AM

I didn't know because they say here https://developers.g...cast/docs/media that ac2 is supported...

But in this case why in Netflix Surround works and why demo movie from Dolby Atmos steram by Emby site works too ?

 

I should buy a Nvidia Shield i guess...


Edited by squelix, 10 January 2020 - 08:37 AM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 10 January 2020 - 11:56 AM

As I mentioned aac is supported, but only 2 channels. Your audio track is 5.1 or 7.1.

#5 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 01:58 PM

Yes my audio track is 5.1 :/

And i want 5.1 or 7.1, i have a Dolby Atmos Sound Bar.

 

5e18bb1e76986_unnamed.png



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 149391 posts
  • Local time: 02:03 AM

Posted 10 January 2020 - 01:59 PM

That one should direct play if you select the first subtitle track

#7 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:03 PM

I think you mean "the first audi track", but i would like 5.1 :/



#8 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 02:06 PM

Shouldn't it support AC3 5.1? Oh, but maybe not 640Kb/s?

#9 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:09 PM

Shouldn't it support AC3 5.1? Oh, but maybe not 640Kb/s?

 

That's what I thought :/



#10 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 02:11 PM

Can you find a movie with an AC3 audio track that has a bitrate of 384Kb/s and try it?

#11 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:16 PM

Can you find a movie with an AC3 audio track that has a bitrate of 384Kb/s and try it?

 

I have AC3 audio track that has a bitrate of 448Kb/s, I can try



#12 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 02:18 PM

Try that. And how is your audio equipment set up?

#13 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:26 PM

Try that. And how is your audio equipment set up?

 

Still not working.

 

I have my Chromacast Ultra directly on my Sound Bar and it sends all (video and sound) to my TV.

 

Sound Bar: https://www.lg.com/f...0Y-barre-de-son

TV: https://www.acer.com...el/UM.SE0EE.001



#14 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 02:32 PM

What does actually work?

#15 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 02:35 PM

I'm wondering if your issue is the same as mine

https://emby.media/c...ll/#entry829782

#16 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:37 PM

What does actually work?

 

This one is Direct Playing, but none of files with AC3, whatever the bitrate, is Direct Playing, only Direct Streaming.

 

5e18c4287b045_Capturedecran20200110a1936



#17 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:39 PM

I'm wondering if your issue is the same as mine

https://emby.media/c...ll/#entry829782

 

It looks like very similar.



#18 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 02:45 PM

I need to investigate that a bit further.

#19 squelix OFFLINE  

squelix

    Member

  • Members
  • 15 posts
  • Local time: 08:03 AM
  • LocationFrance, Grenoble

Posted 10 January 2020 - 02:47 PM

I need to investigate that a bit further.

 

I can't figure out if the problem is from Emby or from the Chromecast.



#20 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13580 posts
  • Local time: 11:03 PM

Posted 10 January 2020 - 03:01 PM

I had the same question.





Also tagged with one or more of these keywords: chromecast, direct play, transcoding

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users