Jump to content

Transcoding causes video looping on Roku


mahuti
 Share

Recommended Posts

Problem: transcoding a movie with 6-channel audio on a 2-channel (stereo) it TV causes the playback to loop, play a bit, then loop, then play a bit, then loop. This only starts to happen after an hour or so of the movie's playtime. If I fast forward a movie to an hour and ten minutes, the looping will happen. If I fast forward to the ten minute mark, or play ten minutes from the start, the looping will not happen. It only happens when I'm far into the movie.  i've seen it happen with multiple movies after the hour (or so) mark.

 

Server Platform: Raspberry PI 4

 

Server Version: Emby 4.3, and 4.4 beta. (I never saw this happen on 4.1... not sure about 4.2)

 

Affected Apps: Emby on TCL TV with Roku Software, Roku Stick, old Roku box.

 

Unaffected: Emby app on Samsung Galaxy, Emby played through a browser on a few laptops I've tried. I'm guessing transcoding is not happening so those are unaffected.

 

I did not notice this happening until recently after I upgraded emby to 4.3 (from 4.1 or 4.2... sorry I don't recall the version I was using) and upgraded the hardware to a Raspberry PI 4 from a 3. I tried upgrading from 4.3 to the 4.4 beta, but the problem persists.

 

I've tried adjusting transcoding settings, a variety of ways, including turning on and off hardware transcoding. Nothing seems to make any difference. The frequency of the looping happens roughly every few seconds at the max, and a high volume of ffmpeg-remux logfiles get generated.

 

I've uploaded the server logfile, and several of the ffmpeg-remux log files (there are around 20 per minute generated sometimes)

 

embyserver.txt

ffmpeg-remux-1227e031-e60a-498d-bb6a-2a0dd5c5c08b_1.txt

ffmpeg-remux-bf700119-a27c-4a9c-9a75-0bb32017e6cd_1.txt

ffmpeg-remux-c82537e4-2b42-45fc-b58a-dc9439cac80b_1.txt

hardware_detection-63713319499.txt

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Yes. Additional detail: At some point after my post I updated to the latest beta and the issue remained. It has affected so much of my content I haven't really been able to use Emby for watching movies since my post. It works fine for movies on mobile and computers, but not on any of my Roku devices.

 

Sorry for the late reply. Didnt catch the notification in my inbox.

Link to comment
Share on other sites

If you lower the in-app quality setting so that it does a full transcode, I assume that resolves it, right?

Link to comment
Share on other sites

homebrew79

I have been experiencing this exact issue as well, with the same setup. Raspberry Pi 4 server running Raspbian with Emby running under docker using the linuxserver/emby image. Roku Premier+ as the client. Around 1hr 10 minutes or so, the video will jump back a few seconds, play, jump back a few seconds... It is really frustrating. I have started pre-transcoding all of my movies to mp4's with AC3 audio, just so that I can direct play.

 

I know a "me too" post isn't really helpful, but I am happy to contribute any logs or additional information that will help.

 

Thanks!

Link to comment
Share on other sites

I set the video quality to 144p-192kbps. It didn't loop that I noticed during a section that was previously looping and unwatchable.

 

Previous setting was to "auto"

Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...