Jump to content


Photo

Transcoding causes video looping on Roku

transcoding roku looping remux ffmpeg raspberry pi

  • Please log in to reply
8 replies to this topic

#1 mahuti OFFLINE  

mahuti

    Member

  • Members
  • 16 posts
  • Local time: 08:10 PM

Posted 30 December 2019 - 07:03 PM

Problem: transcoding a movie with 6-channel audio on a 2-channel (stereo) it TV causes the playback to loop, play a bit, then loop, then play a bit, then loop. This only starts to happen after an hour or so of the movie's playtime. If I fast forward a movie to an hour and ten minutes, the looping will happen. If I fast forward to the ten minute mark, or play ten minutes from the start, the looping will not happen. It only happens when I'm far into the movie.  i've seen it happen with multiple movies after the hour (or so) mark.

 

Server Platform: Raspberry PI 4

 

Server Version: Emby 4.3, and 4.4 beta. (I never saw this happen on 4.1... not sure about 4.2)

 

Affected Apps: Emby on TCL TV with Roku Software, Roku Stick, old Roku box.

 

Unaffected: Emby app on Samsung Galaxy, Emby played through a browser on a few laptops I've tried. I'm guessing transcoding is not happening so those are unaffected.

 

I did not notice this happening until recently after I upgraded emby to 4.3 (from 4.1 or 4.2... sorry I don't recall the version I was using) and upgraded the hardware to a Raspberry PI 4 from a 3. I tried upgrading from 4.3 to the 4.4 beta, but the problem persists.

 

I've tried adjusting transcoding settings, a variety of ways, including turning on and off hardware transcoding. Nothing seems to make any difference. The frequency of the looping happens roughly every few seconds at the max, and a high volume of ffmpeg-remux logfiles get generated.

 

I've uploaded the server logfile, and several of the ffmpeg-remux log files (there are around 20 per minute generated sometimes)

 

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152442 posts
  • Local time: 09:10 PM

Posted 02 January 2020 - 11:54 AM

Hi there, thanks for reporting. Well take a look at this.

#3 mahuti OFFLINE  

mahuti

    Member

  • Members
  • 16 posts
  • Local time: 08:10 PM

Posted 03 January 2020 - 05:52 PM

Great thanks. Good luck.

 

Please let me know if I can provide any further information.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152442 posts
  • Local time: 09:10 PM

Posted 17 January 2020 - 01:02 AM

@mahuti are you still running into this?



#5 mahuti OFFLINE  

mahuti

    Member

  • Members
  • 16 posts
  • Local time: 08:10 PM

Posted 01 February 2020 - 01:17 AM

Yes. Additional detail: At some point after my post I updated to the latest beta and the issue remained. It has affected so much of my content I haven't really been able to use Emby for watching movies since my post. It works fine for movies on mobile and computers, but not on any of my Roku devices.

Sorry for the late reply. Didnt catch the notification in my inbox.

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152442 posts
  • Local time: 09:10 PM

Posted 01 February 2020 - 06:33 PM

If you lower the in-app quality setting so that it does a full transcode, I assume that resolves it, right?



#7 homebrew79 OFFLINE  

homebrew79

    Newbie

  • Members
  • 1 posts
  • Local time: 07:10 PM

Posted 01 February 2020 - 09:58 PM

I have been experiencing this exact issue as well, with the same setup. Raspberry Pi 4 server running Raspbian with Emby running under docker using the linuxserver/emby image. Roku Premier+ as the client. Around 1hr 10 minutes or so, the video will jump back a few seconds, play, jump back a few seconds... It is really frustrating. I have started pre-transcoding all of my movies to mp4's with AC3 audio, just so that I can direct play.

 

I know a "me too" post isn't really helpful, but I am happy to contribute any logs or additional information that will help.

 

Thanks!



#8 mahuti OFFLINE  

mahuti

    Member

  • Members
  • 16 posts
  • Local time: 08:10 PM

Posted 01 February 2020 - 10:57 PM

I set the video quality to 144p-192kbps. It didn't loop that I noticed during a section that was previously looping and unwatchable.

Previous setting was to "auto"

#9 mahuti OFFLINE  

mahuti

    Member

  • Members
  • 16 posts
  • Local time: 08:10 PM

Posted 01 February 2020 - 11:01 PM

I set the setting back to auto and it immediately had the same old problem. The full transcode resolves it though.





Also tagged with one or more of these keywords: transcoding, roku, looping, remux, ffmpeg, raspberry pi

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users