Jump to content

VirtualTV plugin


pünktchen

Recommended Posts

30 minutes ago, pünktchen said:

I saw it in the server log, that's why i requested the ffmpeg log after this. But that looks okay to me.

I'm not sure about the ending of the transcoding process.

Normally, Emby sends a 'q' to quit and then we see the word "EXIT" printed in the log which allows to determine whether the shutdown was graceful. But maybe you do it in a different way..?

But I still think that the key is the server error regarding segments.

Link to comment
Share on other sites

pünktchen
37 minutes ago, softworkz said:

I'm not sure about the ending of the transcoding process.

Normally, Emby sends a 'q' to quit and then we see the word "EXIT" printed in the log which allows to determine whether the shutdown was graceful. But maybe you do it in a different way..?

But I still think that the key is the server error regarding segments.

When the user starts playing a channel a 60 seconds ts file is placed in the transcoding folder and is used as path for the live tv request. If then the app sends a playback start event to Emby, my plugin sends a remote play command to the app with the actual video from the library. But the remote play command isn't executed anymore in the app, because an error is thrown for the 60 seconds ts file (timing problem?). My suspicion is that the auto cleanup of the transcoding folder is too aggressive. The small ts file gets deleted while the app hasn't yet started the remote playback command.

Link to comment
Share on other sites

Jdturos
7 hours ago, Spaceboy said:

a new plugin was required for server versions 4.7+. have you manually installed that?

No I didn’t can you send it to me 

Link to comment
Share on other sites

Spaceboy
32 minutes ago, Jdturos said:

No I didn’t can you send it to me 

It’s in the 1st post

Link to comment
Share on other sites

Mookdog
Posted (edited)
4 hours ago, pünktchen said:

@Mookdog can you try this version please: 

VirtualTV-Test.zip 1.58 MB · 1 download

Hey @pünktchen

For the browser it worked fine. But as far as the shield tv on Emby app for Android TV it still shows a blank screen still

Update : It seems like it worked remotely (I tested on phone with cellular network) and it played. But locally its not on both ATV version and regular android version

Update Update : I just had a friend test it remotely from another state and his is working fine. Locally it doesnt play

 

 

Mook

Edited by Mookdog
Update
Link to comment
Share on other sites

pünktchen

If you have the regular Android app installed at the same time as the AndroidTV app on the Shield, please uninstall the regular app and try again.

Link to comment
Share on other sites

Mookdog
Posted (edited)
9 minutes ago, pünktchen said:

If you have the regular Android app installed at the same time as the AndroidTV app on the Shield, please uninstall the regular app and try again.

Ok uninstalled rebooted shield and tried the ATV version and still the same blank screen also rebooted server

 

https://streamable.com/m6b1bh

update : Seems to be the shield causing the problem. I just tried on my Formuler GTV and it worked perfect

Mook

Edited by Mookdog
update
Link to comment
Share on other sites

pünktchen

I'm out of ideas. I also own a Shield and it's working for me. Although i'm still on Shield Experience 8, but i can't image that makes a difference or others would have reported it here. Maybe you should make a new thread in the AndroidTV section and send an in app log to ebr.

Link to comment
Share on other sites

Mookdog
14 minutes ago, pünktchen said:

I'm out of ideas. I also own a Shield and it's working for me. Although i'm still on Shield Experience 8, but i can't image that makes a difference or others would have reported it here. Maybe you should make a new thread in the AndroidTV section and send an in app log to ebr.

I had to factory reset shield. All is fine now working as it should. Thank u for working on this with me I appreciate it. All working fine now

 

Mook

  • Like 1
Link to comment
Share on other sites

rattlerviper

So I got this set up and working today and it is great! One question though, what file type and parameters are allowed for the TV logo? I seem to be unable to get one set. 

Link to comment
Share on other sites

Mookdog
1 hour ago, Jdturos said:

What is SHIELD

NvIdia Shield Pro is an android streaming box that allows u to stream movies and shows/play games etc etc. My personal opinion is its the best android device on the market since 2015

 

Mook

Link to comment
Share on other sites

Mookdog

Hey @pünktchen

Plugin is working great I do have 1 question

What can I do to prevent my epg from running out of program data ? I want it to continue the whole week until the guide refreshes after a week ? I have it setup to play episodes in order but it doesnt repeat after the show is done

 

Mook

Link to comment
Share on other sites

pünktchen

Server -> Live TV -> Advanced -> Number of days of guide data to download: Anything but Auto

Link to comment
Share on other sites

Mookdog
1 hour ago, pünktchen said:

Server -> Live TV -> Advanced -> Number of days of guide data to download: Anything but Auto

Thanks bro I completely forgot about that part

 

Mook

Link to comment
Share on other sites

dsync89
Posted (edited)

Was searching on Google for native pseudotv plugin for Emby and stumbled across this one. Hats off for this native plugin built directly into emby :D Before I start does it support direct play or HLS direct without transcoding?

I've previously tried pseudotv, dizquetv and ersatztv on my Kodi Emby setup to simulate tv browsing experience, and would like to compare them with this one too.

Edited by dsync89
Link to comment
Share on other sites

pünktchen
14 minutes ago, dsync89 said:

Before I start does it support direct play or HLS direct without transcoding?

Yes.

Link to comment
Share on other sites

thisismytrial

I would like to switch to playlist mode, but there is one issue that keeps coming up. Basically, it seems like there is no way to use playlist mode without the log showing that my active account is watching or just watched a show that aired. 

Obviously, I created a user just to be the Channel User. I have Clear Resume Point, Remove Shows From Continue Watching and Add the "Channel User" to playback sessions all checked. However, if I tune into a show while logged into my normal account, it still shows up on the log and thus Continue Watching however briefly. Continuous Playback mode doesn't have this problem and it only logs that my account tuned to that channel. 

Is there anyway to use VirtualTV in Playlist Mode without leaving any trace on my normal account and it only effecting the Channel User? 

Thanks for all you do, @pünktchen!

Link to comment
Share on other sites

pünktchen
21 hours ago, thisismytrial said:

Is there anyway to use VirtualTV in Playlist Mode without leaving any trace on my normal account and it only effecting the Channel User?

No, not possible because effectively the logged in user is playing the videos from the library. Beside the Activity messages in the dashboard, does it make any problem to Continue Watching or similar or why do you want to use the channel user?

Link to comment
Share on other sites

vtjapes

I have a lot of movies that I put into collections since it's easier to bulk move something into a collection instead of adding a tag to each file.  I recently discovered this plugin and I made a bunch of channels for my son.  I was wondering if there was a way to make a channel out of a few collections.  For instance I made a collection of modern Kaiju movies and a second collection of old ones.  If I want to create a Kaiju channel currently I'd have to tag each movie individually and then use the "tags" flag to grab movies for the channel.  So curious if Collections could be added in addition to Tags, Genres, Actors, Directors, and Studios that are already available.

Thanks again for creating this.  My son and I are having a blast creating channels. 

Link to comment
Share on other sites

thisismytrial
On 6/2/2022 at 5:24 PM, pünktchen said:

No, not possible because effectively the logged in user is playing the videos from the library. Beside the Activity messages in the dashboard, does it make any problem to Continue Watching or similar or why do you want to use the channel user?

I never use the channel user. But I find the watch data doesn't stick exclusively to that user. My main user account tends to have the episodes show up on Continue Watching. Most of the time very briefly, but it happens often enough that it doesn't feel like a clean experience like the Continuous Playback channels do. 

Link to comment
Share on other sites

I'm in a similar situation. I have a lot of channels dedicated to classic sitcoms.

I don't want continue watching and trakt thinking I'm watching all of the Beverly Hillbillies just because I had some guests over and we watched a couple of random show episodes.

I currently log in as a special purpose Emby user for watching Virtual TV channels.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...