Jump to content

VirtualTV plugin


pünktchen

Recommended Posts

pünktchen

@@pünktchen Any chance of expanding the amount of channels to 20? I would try series, but I have too much genres in movies that reserve all of the 10 current ones :D :D :D

You will get this tonight.

 

@@pünktchen And did you get any feedback by Luke for a better integration with ffmpeg/Emby stream options?

We've already discussed what's the best solution, but if or when this will be integrated he didn't mentioned.
  • Like 4
Link to comment
Share on other sites

pünktchen

New version 0.6.2 in the starting post:

Increased channels to twenty. Unfortunately this breaks your existing plugin configuration and you'll have to start from scratch. I'm really sorry for this!

Fixed some serious time calculation mistakes for the "AutoMarkWatched" function and made it configurable by percent.

Hopefully fixed the exception at playback start that some of you reported. (@@CBers @@WilhelmStroker @@hstamas)

  • Like 4
Link to comment
Share on other sites

CBers

New version 0.6.2 in the starting post:

Increased channels to twenty. Unfortunately this breaks your existing plugin configuration and you'll have to start from scratch. I'm really sorry for this!

Fixed some serious time calculation mistakes for the "AutoMarkWatched" function and made it configurable by percent.

Hopefully fixed the exception at playback start that some of you reported. (@@CBers @@WilhelmStroker @@hstamas)

Still getting my 2 channels transcoding, even though the same items Direct Play outside of VirtualTV.

 

Has there been any feedback from @@Luke or @@ebr as why this is happening?

 

Surely Emby can work out that the source is local, direct from disk and not external.

Link to comment
Share on other sites

pünktchen

Still getting my 2 channels transcoding, even though the same items Direct Play outside of VirtualTV.

 

Has there been any feedback from @@Luke or @@ebr as why this is happening?

 

Surely Emby can work out that the source is local, direct from disk and not external.

In "single playback" mode? Are you sure it's transcoding or is it a remux? Can you post the media info for one item where this happens?

 

From Emby side of things the live tv engine doesn't know there's actually a local file behind the channel stream. I have to use a direct stream with video and audio copy by ffmpeg because currently it's the only way to seek to the start position.

Link to comment
Share on other sites

CBers

In "single playback" mode? Are you sure it's transcoding or is it a remux? Can you post the media info for one item where this happens?

 

From Emby side of things the live tv engine doesn't know there's actually a local file behind the channel stream. I have to use a direct stream with video and audio copy by ffmpeg because currently it's the only way to seek to the start position.

Yes, single playback mode.

 

The Android TV (ATV) app says Trans/I.

 

The same video Direct Plays in normal Emby, so it's something that either the plugin, or Emby's Live TV routines is mis-playing.

 

If you're using ffmpeg to get to the correct start position, then that's probably it.

 

Not telling you how to code, as I have no idea, but can't you use the resume function code, as that must be doing the same thing?

Link to comment
Share on other sites

pünktchen

Not telling you how to code, as I have no idea, but can't you use the resume function code, as that must be doing the same thing?

No this is just not possible. For resume the player has to send multiple http range requests to the server to get the media type, codecs, runtime and finally the start position. Even i would do this in my plugin, it will be lost when the result is hand over to the live tv engine. Only a real media player can interpret the results of the range request.

 

Btw. it's always direct playing with Emby Theater.

Link to comment
Share on other sites

pünktchen

Okay @@CBers it seems the Android apps only allow .ts as a container for live tv streams. How silly is that [emoji2955] You can also see this in your log folder: The direct stream log is generated by the plugin. Then follows a remux log because the app requests a container swap. Finally you get a transcoding log because the app can't play the remuxed stream.

Interestingly it works without transcoding when the plugin already initiates the container swap [emoji54]

I will make an option for this.

  • Like 3
Link to comment
Share on other sites

pünktchen

Okay @@CBers the new option won't help you with the Android TV app. As i've found out it only helps with the Mobile app. The big problem seems to be the audio track codec. Somehow the Android TV app/Exoplayer doesn't like codecs other than AC3 for the live tv stream.

I have a Shield and an audio system that can play everything up to True-HD Atmos and DTS-X. With movies from my library there's never a problem, but with live tv stream from my plugin that has a DTS audio track it's like this in the Android TV app:

The player starts with direct playback for the video track and local downmix for the audio track (i can see this for one second in the stats for nerds). This doesn't work, so the app requests a direct stream where only the audio is transcoded (remux log). This still doesn't work, so the app requests a full transcode. Then playback is successfull.

 

I will give you the option for a ts stream, but it's up to you and the other guys to solve the audio problem with ebr.

  • Like 2
Link to comment
Share on other sites

CBers

I will give you the option for a ts stream, but it's up to you and the other guys to solve the audio problem with ebr.

Thanks.

 

Is @@ebr aware of this issue do you know?

 

Perhaps he can code something to cater for it.

Link to comment
Share on other sites

shorty1483

So much people over at Plex and other Media solutions are screaming for a PseudoTV like solution. And here it is, @@pünktchen created a unique selling point that totally separates Emby from other solutions. Everyone now can enjoy TV, even you have no cable card.

 

To be honest, this is exactly a plugin I would have expected by the Emby Team as an optional core part of Emby.

Edited by shorty1483
  • Like 3
Link to comment
Share on other sites

Spaceboy

0.6.2 seems to work ok for me but actually crashes embyserver.exe at the end of every completed show. this is on latest stable just using one channel made up of one show picked by tag

  • Like 1
Link to comment
Share on other sites

pünktchen

0.6.2 seems to work ok for me but actually crashes embyserver.exe at the end of every completed show. this is on latest stable just using one channel made up of one show picked by tag

Continious playback on or off?
Link to comment
Share on other sites

Spaceboy

Continious playback on or off?

off

 

Out now but I’ll get you some logs later. I did take a look and there seemed to be no indication of any issue.

Edited by Spaceboy
Link to comment
Share on other sites

WilhelmStroker

Similar issue here. Continuous playback turned off and it doesn't look like the process crashes but my server becomes unresponsive and I need to restart it after an episode finishes. Will do some more testing and check the logs later.

Edited by WilhelmStroker
Link to comment
Share on other sites

pünktchen

New version 0.6.4 in the starting post:

Fixed "Watched Only" condition for tv shows. @@hstamas

Fixed http response header for the export web api. (necessary for Kodi Simple PVR addon)

Fixed Emby crash by "AutoMarkWatched". @@Spaceboy @@shorty1483 @@WilhelmStroker

Added option to force ts container in single playback mode. @@CBers

Edited by pünktchen
  • Like 2
Link to comment
Share on other sites

hstamas

New version 0.6.4 in the starting post:

Fixed "Watched Only" condition for tv shows. @@hstamas

 

 

Confirmed that the issue with programs from different media locations not populating the guide if "watched only" was selected is fixed. Thanks punktchen!

Link to comment
Share on other sites

CBers

New version 0.6.4 in the starting post:

Added option to force ts container in single playback mode. @@CBers

Does this option have to be on for all platforms ?

 

I ask, as I am having issue just playing the content remotely in Chrome.

 

I will try with my Shield/ATV app later when I get home from work.

Link to comment
Share on other sites

pünktchen

Does this option have to be on for all platforms ?

 

I ask, as I am having issue just playing the content remotely in Chrome.

 

I will try with my Shield/ATV app later when I get home from work.

You are asking questions. How should i know? I don't have all platform devices. I do not even use any of the official apps for watching live tv. I can say it has to be on for the Android Mobile app. For Android TV it depends somehow on the app setting "Direct stream live tv" if you get sound or not.
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...