Jump to content

VirtualTV plugin


pünktchen

Recommended Posts

pünktchen

I'm having the same issue as above, I get the channel to show but no program information or movies show up for it. I didn't convert from 3.5

But you've only tried Emby stable?

Or does it also work for you with beta, but not stable?

 

Anything in the logs? @@Spaceboy

Link to post
Share on other sites
pünktchen

Sorry mate,was busy updating ,all my APCs :D

 

I checked with stream.mp4? and stream.mkv? and both are working on latest VLC.

Are you sure you've tried it with the url from inside your ffmpeg error log above and not any working ffmpeg log?
Link to post
Share on other sites
shorty1483

Are you sure you've tried it with the url from inside your ffmpeg error log above and not any working ffmpeg log?

 

Yes sir. I searched exactly this error log.

Link to post
Share on other sites

Hmmm... on beta server 4.4.0.4 the channels don't even show up. I get a timeline on the web client, but that's the only thing...

 

EDIT2: After running the Scheduled tasks "Refresh Guide" manually twice, the "Export VirtualTV Channels & Program" completed successfully and the web-client started showing what needed to be shown  :)

 

EDIT: I just need to say that I absolutely love this idea and once it incorporates series (and maybe later on even music...???  ;) ) this will most likely be my most used feature of Emby! Let me know how to buy you a beer or coffee or something...

Edited by Dibbes
  • Like 1
Link to post
Share on other sites
pünktchen

@@jachin99 @@Spaceboy @@Dibbes and all others that will follow,

please pm me some logs and either screenshots of your channel configuration or the VirtualTV.xml file that is inside ...\plugins\configurations

When you just say "it doesn't work" i cannot help you, because it works for @@shorty1483 and me with stable and beta.

  • Like 1
Link to post
Share on other sites

@@jachin99 @@Spaceboy @@Dibbes and all others that will follow,

please pm me some logs and either screenshots of your channel configuration or the VirtualTV.xml file that is inside ...\plugins\configurations

When you just say "it doesn't work" i cannot help you, because it works for @@shorty1483 and me with stable and beta.

 

Done... let me know if you need anything else

Edited by Dibbes
Link to post
Share on other sites

Any errors in the logs?

If not enable debug logging in Emby, do a guide refresh and pm the log.

good morning,
 
I uninstalled your addon to install the new version, but now I don't see it in the list of extensions anymore. 
Link to post
Share on other sites
pünktchen

good morning,

 
I uninstalled your addon to install the new version, but now I don't see it in the list of extensions anymore. 

 

Have you copied over the new plugin version to your plugins folder and then restarted Emby?

You will not find the plugin in the catalog yet.

Link to post
Share on other sites

Have you copied over the new plugin version to your plugins folder and then restarted Emby?

You will not find the plugin in the catalog yet.

yes I took the new version I copied it into the folder as you can see on the picture.
 
the addon should appear between themes song and trailers like yesterday but I don't see it

post-475712-0-06550600-1577732550_thumb.png

post-475712-0-45365800-1577732566_thumb.png

Link to post
Share on other sites

I'm getting this error when I run the scheduled task

2019-12-30 13:06:15.219 Error TaskManager: Error
	*** Error Report ***
	Version: 4.4.0.3
	Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3
	Operating system: Unix 4.19.56.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///system/System.Private.CoreLib.dll
	Processor count: 12
	Program data path: /config
	Application directory: /system
	System.Net.WebException: System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
	   at System.Net.HttpWebRequest.GetResponse()
	   at System.Net.WebClient.GetWebResponse(WebRequest request)
	   at System.Net.WebClient.DownloadBits(WebRequest request, Stream writeStream)
	   at System.Net.WebClient.DownloadFile(Uri address, String fileName)
	   at System.Net.WebClient.DownloadFile(String address, String fileName)
	   at VirtualTV.Services.ExportVirtualTVTask.Execute(CancellationToken cancellationToken, IProgress`1 progress)
	   at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)
	Source: System.Net.Requests
	TargetSite: System.Net.WebResponse GetResponse()
Link to post
Share on other sites
pünktchen

I'm getting this error when I run the scheduled task

 

There should be one or two web request before the error in your log:

Info HttpServer: HTTP GET http://127.0.0.1:8096/emby/VirtualTV/Channels?Pass=. UserAgent:

Info HttpServer: HTTP GET http://127.0.0.1:8096/emby/VirtualTV/Guide?Pass=. UserAgent:

Which one is failing for you?

Link to post
Share on other sites

There should be one or two web request before the error in your log:

Info HttpServer: HTTP GET http://127.0.0.1:8096/emby/VirtualTV/Channels?Pass=. UserAgent:

Info HttpServer: HTTP GET http://127.0.0.1:8096/emby/VirtualTV/Guide?Pass=. UserAgent:

Which one is failing for you?

2019-12-30 14:14:54.540 Info HttpServer: HTTP GET http://127.0.0.1:8096/emby/VirtualTV/Channels?Pass=. UserAgent: 
2019-12-30 14:14:54.619 Info HttpServer: SocketException: http://127.0.0.1:8096/emby/VirtualTV/Channels?Pass=
2019-12-30 14:14:54.620 Info HttpServer: HTTP Response 500 to 127.0.0.1. Time: 80ms. http://127.0.0.1:8096/emby/VirtualTV/Channels?Pass=
2019-12-30 14:14:54.623 Error TaskManager: Error
	*** Error Report ***
	Version: 4.4.0.3
	Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3
	Operating system: Unix 4.19.56.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///system/System.Private.CoreLib.dll
	Processor count: 12
	Program data path: /config
	Application directory: /system
	System.Net.WebException: System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
	   at System.Net.HttpWebRequest.GetResponse()
	   at System.Net.WebClient.GetWebResponse(WebRequest request)
	   at System.Net.WebClient.DownloadBits(WebRequest request, Stream writeStream)
	   at System.Net.WebClient.DownloadFile(Uri address, String fileName)
	   at System.Net.WebClient.DownloadFile(String address, String fileName)
	   at VirtualTV.Services.ExportVirtualTVTask.Execute(CancellationToken cancellationToken, IProgress`1 progress)
	   at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)
	Source: System.Net.Requests
	TargetSite: System.Net.WebResponse GetResponse()
Link to post
Share on other sites
pünktchen

I don't know how to use the newspaper, but here it is. 

 

The dll isn't even loaded by Emby. Maybe it is blocked by Windows?

Right click the ddl file and select properties, a unblock checkbox or button shoul be availiable which allows to resolve the problem.

Link to post
Share on other sites

The dll isn't even loaded by Emby. Maybe it is blocked by Windows?

Right click the ddl file and select properties, a unblock checkbox or button shoul be availiable which allows to resolve the problem.

I don't see what her options are talking to you, can you give me a capture.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...