Jump to content

Can't connect to local server via SSL


hispeed
 Share

Recommended Posts

Hi folks,

 

I can't connect to my local emby server via the Emby for Kodi addon. I have set up and running Kodi on a rasperry 4. I have installed the addon: emby for Kodi, this worked fine.

I have running since more than a year an emby server on centos 7. In front of that I usualle a NGINX reverse proxy.

 

Why is the emby for kodi addon using: http instead of https? The Emby server is not in the same subnet is this a problem?

2019-12-22 18:19:32.510 T:2606998384  NOTICE: Emby.emby.core.connection_manager -> Begin connectToServers, with 0 servers
2019-12-22 18:19:34.302 T:3011987936 WARNING: CGUIWindowManager - HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2019-12-22 18:19:34.307 T:2606998384 WARNING: Previous line repeats 1 times.
2019-12-22 18:19:34.307 T:2606998384  NOTICE: EMBY.connect -> ERROR:: No server selected
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/connect.py", line 162, in register_client
                                                self.select_servers(state)
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/connect.py", line 236, in select_servers
                                                return self.select_servers()
                                              File "/storage/.kodi/addons/plugin.video.emby/resources/lib/connect.py", line 234, in select_servers
                                                raise RuntimeError("No server selected")
                                            RuntimeError: No server selected
2019-12-22 18:19:34.389 T:2606998384  NOTICE: EMBY.entrypoint.service -> ERROR:: User sign in interrupted
2019-12-22 18:19:37.928 T:2882610032  NOTICE: Emby -> ---[ START EMBYCLIENT ]---
2019-12-22 18:19:37.928 T:2882610032  NOTICE: Emby.emby.client -> state cannot be empty
2019-12-22 18:19:37.980 T:2882610032  NOTICE: EMBY.entrypoint.default -> path: ?mode=updateserver params: {
                                                "mode": "updateserver"
                                            }
2019-12-22 18:19:37.980 T:2882610032  NOTICE: EMBY.default -> ---<[ default ]
2019-12-22 18:19:38.061 T:2648961904  NOTICE: EMBY.entrypoint.service -> [ onNotification/plugin.video.emby/UpdateServer ]
2019-12-22 18:19:39.435 T:3011987936 WARNING: CGUIWindowManager - HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2019-12-22 18:19:49.212 T:2648961904  NOTICE: EMBY.objects.monitor -> [ xbmc/Input.OnInputRequested ]
2019-12-22 18:19:53.635 T:3011987936 WARNING: CGUIWindowManager - HandleAction - ignoring action 107, because topmost modal dialog closing animation is running
2019-12-22 18:19:54.019 T:2648961904 WARNING: Previous line repeats 23 times.
2019-12-22 18:19:54.019 T:2648961904  NOTICE: EMBY.objects.monitor -> [ xbmc/Input.OnInputFinished ]
2019-12-22 18:19:54.940 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://XXX.XXX.XX.XX:443/emby/system/info/public
2019-12-22 18:19:54.955 T:2648961904  NOTICE: Emby.emby.core.http -> ERROR:: HTTPConnectionPool(host='XXX.XXX.XX.XX', port=443): Max retries exceeded with url: /emby/system/info/public (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0xac1b6670>: Failed to establish a new connection: [Errno 113] No route to host',))
2019-12-22 18:19:54.956 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR::
2019-12-22 18:19:54.957 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR:: connectToAddress http://XXX.XXX.XX.XX:443 failed
2019-12-22 18:19:55.838 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://XXX.XXX.XX.XX:443/emby/system/info/public
2019-12-22 18:19:55.850 T:2648961904  NOTICE: Emby.emby.core.http -> ERROR:: HTTPConnectionPool(host='XXX.XXX.XX.XX', port=443): Max retries exceeded with url: /emby/system/info/public (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0xac1b61b0>: Failed to establish a new connection: [Errno 113] No route to host',))
2019-12-22 18:19:55.851 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR::
2019-12-22 18:19:55.851 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR:: connectToAddress http://XXX.XXX.XX.XX:443 failed
2019-12-22 18:19:56.538 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://XXX.XXX.XX.XX:443/emby/system/info/public
2019-12-22 18:19:56.550 T:2648961904  NOTICE: Emby.emby.core.http -> ERROR:: HTTPConnectionPool(host='XXX.XXX.XX.XX', port=443): Max retries exceeded with url: /emby/system/info/public (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0xac1b6e50>: Failed to establish a new connection: [Errno 113] No route to host',))
2019-12-22 18:19:56.551 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR::
2019-12-22 18:19:56.551 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR:: connectToAddress http://XXX.XXX.XX.XX:443 failed
2019-12-22 18:19:57.171 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://XXX.XXX.XX.XX:443 /emby/system/info/public
2019-12-22 18:19:57.184 T:2648961904  NOTICE: Emby.emby.core.http -> ERROR:: HTTPConnectionPool(host='XXX.XXX.XX.XX', port=443): Max retries exceeded with url: /emby/system/info/public (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0xac109970>: Failed to establish a new connection: [Errno 113] No route to host',))
2019-12-22 18:19:57.184 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR::
2019-12-22 18:19:57.185 T:2648961904  NOTICE: Emby.emby.core.connection_manager -> ERROR:: connectToAddress http://XXX.XXX.XX.XX:443 failed
2019-12-22 18:20:57.835 T:3011987936  NOTICE: Log level changed to "LOG_LEVEL_DEBUG_FREEMEM"
2019-12-22 18:20:57.835 T:3011987936  NOTICE: Enabled debug logging due to GUI setting. Level 2.
2019-12-22 18:20:57.837 T:3011987936   DEBUG: ------ Window Init () ------
2019-12-22 18:20:57.839 T:3002069872   DEBUG: libinput: event1  - debounce state: DEBOUNCE_STATE_RELEASED → DEBOUNCE_EVENT_TIMEOUT → DEBOUNCE_STATE_IS_UP
2019-12-22 18:20:58.150 T:3002069872   DEBUG: CLibInputPointer::ProcessMotion - event.type: 3, event.motion.x: 1853, event.motion.y: 241
2019-12-22 18:20:58.166 T:3002069872   DEBUG: CLibInputPointer::ProcessMotion - event.type: 3, event.motion.x: 1852, event.motion.y: 241
2019-12-22 18:20:58.182 T:3002069872   DEBUG: CLibInputPointer::ProcessMotion - event.type: 3, event.motion.x: 1848, event.motion.y: 243
2019-12-22 18:20:58.198 T:3002069872   DEBUG: CLibInputPointer::ProcessMotion - event.type: 3, event.motion.x: 1845, event.motion.y: 244

Thanks for any ideas.

Link to comment
Share on other sites

Wait a sec, your server is running locally, why do you even want to connect thru the reverse proxy? 

 

I'm running a reverse proxy too but locally I have a direct connecting. Otherwise everything is routed over the internet.

Link to comment
Share on other sites

Hi,

 

I have enabled and disabled verify connection but both doesn't help.

 

I use the reverse proxy internal as well because I have a pfsense and there i have my dns set up and so I go directly back to the reverse proxy which is also internal.

Link to comment
Share on other sites

Ok now it works. I have to use port: 6024 but I don't know why because I also have to use the dns name which is forwarded to the reverse proxy. So far fine but then there is still a small bug, because:

 

We have there settings in the addon where you can define the server and there i set it to: https://emby.mydomain.com

 

This doesnt work. You have to do it like that:

 

1. Add server manually -> type in your domain with https and use port 6024

2. Restart emby for kodi

3. Select the server in the popup dialog (if it doesn't open go on favourite movies)

4. Login with your Emby User

 

I don't know but a little bit strange behaviour here :D

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...