Jump to content

Migration from Windows 10 to Arch Linux


Archangél
 Share

Go to solution Solved by Happy2Play,

Recommended Posts

Archangél

hey all,
I am a bit confused... As far as I know I should be able to just run the backup tool in Windows and then run it in the arch installation and then it should "magically" work, right?

this have not been the case with my installation, I can literally not see the libraries even tho the paths are correct. I need to know how to get emby working again. Right now i cannot see media files in any of the libraries when looking through them, not even the metadata tool shows anything.
I have tried several browser (opera and firefox, tried both in private mode as well) so it got nothing to do with cache/cookies.
example picture from opera: 5dfacb122c40f_embynothing.png

 

I am on the latest build of emby available for my distro which is 4.3.0.30.

 

I ran

sudo pacman -Ssy emby

Result I got from that:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
community/emby-server 4.3.0.30-1 [installed]
    Bring together your videos, music, photos, and live television

I am attaching embyserver.txt if you require any other log from emby server I shall conjure it into existence for you helping folks.

 

I tried to create new libraries, and it works, it is just that the already existing ones does not work, and I really would like try to avoid to recreate them, thank you

 

It is 2am when typing this, I am sorry for any spelling mistakes, if you need any clarification, ask away!

 

Thank you for taking your time reading through this and trying to help me with my trouble.

have a nice day! :)

 

embyserver.txt

 

Edit: Added embyserver.txt logfile

Edited by Archangél
Link to comment
Share on other sites

  • Solution
Happy2Play

Why do you feel paths are correct?

2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/D:\Music because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/E:\Anime\Normal because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/E:\Series because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/F:\Anime\Normal because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/F:\Multimedia\Series because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/F:\Music because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/H:\Anime\Normal because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/H:\Movies because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/H:\Series because the path does not exist

Trying to restore on a different OS will have issues with anything that has a path configured.  Ideally you only restore Users and Userdata.

Edited by Happy2Play
  • Like 1
Link to comment
Share on other sites

Archangél

Why do you feel paths are correct?

2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/D:\Music because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/E:\Anime\Normal because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/E:\Series because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/F:\Anime\Normal because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/F:\Multimedia\Series because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/F:\Music because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/H:\Anime\Normal because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/H:\Movies because the path does not exist
2019-12-19 01:35:16.963 Info LibraryMonitor: Skipping realtime monitor for /usr/lib/emby-server/H:\Series because the path does not exist

Trying to restore on a different OS will have issues with anything that has a path configured.  Ideally you only restore Users and Userdata.

 

Thank you for your response!

Well, I checked manually, in the webinterface for the libraries, and there they pointed towards the correct path, that was why.

 

Now that I check again, today, I see that there is a double of every library, which were not there yesterday when I wrote this post (more then an hour after the restoring process).

 

 

Thank you very much for taking your time and explaining best practices in restoring backups between different OSes! :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...