Jump to content

Emby for Kodi sync crashes on first sync


Benji99
 Share

Recommended Posts

Hi guys, having an issue getting kodi to sync with emby for first time in a new setup.

 

Sync will crash a few seconds after starting with error message: "Something went wrong during the sync"

 

Here are the logs:.http://paste.kodi.tv/awoworumox

 

It seems to crash after syncing a few shows...

 

Emby server is 4.3.0.30 (server recently re-built from scratch, emby apps running fine)

Emby Plugin is 4.1.16 (but also tried 4.1.17)

Kodi is 18.5 (Kodi able to access nfs shares that Emby is pointing to no problem)

Running on Nvidia Shield

 

Any help greatly appreciated!

 

Link to comment
Share on other sites

Angelblue05

You are the second person to report this. You have actors without names and thats unexpected. The other user fixed it by removing the problematic content and readding it I believe. I’ll add a fix for it for the next update.

Edited by Angelblue05
Link to comment
Share on other sites

Thanks for the response!

 

Now obviously the data is coming from and generated by emby so wouldn't the issue need to be fixed there?
Now looking at the crash location, I was assuming the error would be in the Mandalorian but looking at the data in the emby library, it all looks good. In fact, there's actually not a lot of content on this server and I went through every tv series and according the Metadata manager, all looks good...

 

Any tips on finding the offending data in Emby so that I can correct it?

  • Like 1
Link to comment
Share on other sites

Angelblue05

@@Luke

 

When a person is added to the Emby database (actor, etc) do they always have a name value? Two users have reported issues and both times it was caused by the person (People) list having no Name key defined.

 

I'm going to patch this on my side to ignore people without a Name key but this is a new bug?

Edited by Angelblue05
Link to comment
Share on other sites

Hi Luke, the sync crashes while tryin to sync TV shows. I checked all TV shoes in the Emby web and saw nothing weird in the cast of every single TV show in the database. (This is a fresh set up so there isn't much in there yet)

 

Is there some kind of extract from the Emby database that I could send you?

 

Sent from my Pixel 3 XL using Tapatalk

Link to comment
Share on other sites

You're saying a person has a blank name, I'm just asking what that person looks like in the web app.

Link to comment
Share on other sites

That was Angelblue05's analysis based on the logs. I'm not sure how to isolate the specific entry at fault to compare in Emby itself. That's why I checked all the shows and couldn't find anything strange or unusual.

 

Sent from my Pixel 3 XL using Tapatalk

Link to comment
Share on other sites

Angelblue05

I'm not sure which person it is Luke. It just crashes because the Name key is not defined for the person it's processing. Meaning one person entry has no Name key being returned and the add-on doesn't modify or builds that list. It is taken directly from the api response.

 

Let me push extra logging and the fix. Give me a few minutes. I'll let you know once the change is available.

Edited by Angelblue05
Link to comment
Share on other sites

Angelblue05

@@Benji99

 

Restart Kodi, it should pick up on the patch and allow to process the problematic content. However can you provide a new log if possible, just so we can see what's happening? Thank you!

Link to comment
Share on other sites

Beautiful, it'll have to wait until the weekend but it'll definitely report back. Thanks!

 

Sent from my Pixel 3 XL using Tapatalk

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...