Jump to content


Photo

Bizarre Playlist Issues/Bugs

Playlists Bugs

  • Please log in to reply
3 replies to this topic

#1 piecesofme OFFLINE  

piecesofme

    Advanced Member

  • Members
  • 39 posts
  • Local time: 07:53 PM

Posted 27 November 2019 - 03:07 AM

Hello,

 

I’ve noticed some weird issues with Playlists happening with Emby that I’ve not had happen before and it’s making playlist use very difficult and unpredictable. I’ve really tried to work to figure out some pattern to the issues and I’ve included that below. I’m sorry it’s a little difficult to explain and I’ve tried to be as clear as I can. I hope it’s OK.
 
I primarily use the Roku app right now and cannot say if it affects other platforms.
 
The first is related to a bug that I reported sometime back. When you click the play button on the Roku remote when you’re in the full list of items in one’s playlist, instead of playing the playlist from that point, it throws you out of the Emby app altogether and to the Roku Home Screen.
 
Because you cannot click the play button within the playlist, you have to click on the playlist item (center of the d-pad on the remote), which takes you to the episode/media info page. If you click on the play button from here, the playlist does not play through as it should (continuing to play through each item on the playlist till it gets to the end). It will mostly just stop at the end of the season (despite the fact that there are all the seasons added to the playlist). And if you choose the “play repeat” option, it will only repeat from where you start playing in the season to the end and back to the one that you started with. For instance, if you start on Episode 9 of an season with 10 episodes in it, the playlist will play episode 9 then go on to episode 10 then stop. If you choose the repeat play option, it will repeat episode 9 and 10 over and over and over. Previously, the play-repeat button just allowed the playlist to play completely through everything on the playlist then start over. So, there is an odd thing right now where playlists aren’t looking at what’s on the playlist itself, but what’s in a specific season.
 
Additionally, I’ve learned how to add items to a playlist one season at a time so that it adds everything in airdate order -at least if you have it setup to show “specials” in the season in which it played. So, one show in particular has one special at the end of every season and it’s setup in the playlist just that way so you see everything how it should be in the storyline. I noticed that on this playlist, it will do exactly what I said above - if you start on episode 10, it will play episode 10 then go onto the special. If you have the play-repeat option selected, it will replay episode 10 and the special over and over. However, this is where it gets weirder. If you start on the special in the playlist (between episode 10 and episode 1 of the next season), instead of playing on to episode 1 of the next season as it is in the playlist - it’s skipping ahead and playing the next special in the specials season. This means that Emby is somehow not looking at the playlist order at all but it’s somehow reading from the season (specials or season 00) that the special was originally in. It did this for at least 5 specials in a row - skipping over all the episodes between them in the playlist and just going from special to special. Again, this is only happening when you start on the specials. But the playlist is stopping at the end of whatever season you start in (including playing the special at the end by airdate) if you start earlier in the season. It appears that even though the items are in playlists, Emby is still reading them as though they were in seasons only and it’s not reading the order of the playlists themselves. And it’s doing that differently, depending on what episode you begin playing from. As you can imagine, it means that using playlists are virtually not usable at the moment. I should also mention that all of the above is happening in the current stable Roku app version. 
 
In addition, there’s another glitch/bug in the Playlist section of the Emby app (this time, in the beta 3.0.198 and newer) that I noticed the other day and another poster mentioned in the post thread re: the first bug mentioned. Now, when you’re in a playlist and click down to show all of your other episodes/media in the playlist, you get nothing. You cannot see any of your playlist items in the Roku app at all.  The only thing you can do is to play all from the beginning - nothing more. I’m only mentioning it because it’s related to the Playlists not functioning properly and I thought it might be helpful to have the info together.
 
I switched over the Emby because the Playlist features and options are light years ahead of Plex, where I came from. In addition, the Dev team here with Emby actually gives a care and listens to what Emby users are asking for. That makes all the difference. I know that bugs happen, which is why I’m trying to help as I run across them. I’m really hoping that these playlist glitches will be able to fixed. We use the playlists literally daily and I’m really missing being able to play through a playlist. We want to be able to start playing the playlist later in the series and then use the play-repeat function to have it start back over at the very beginning. That way, you don’t have to start with the same early episodes each time and still have it continue playing. I wish I could actually do more to help fix it, but I’ll continue to test as much as I’m able.

 


Edited by piecesofme, 27 November 2019 - 03:08 AM.


#2 speechles ONLINE  

speechles

    Advanced Member

  • App Developer
  • 5868 posts
  • Local time: 04:53 PM

Posted 27 November 2019 - 10:07 AM

What type of playlists are these?

 

This should not produce a crash but I can see a scenario where with certain media types mixed in a playlist can cause this problem. 

 

Are these video? Is it mixed types? Maybe series and episodes? Or is this just episodes? Knowing how the playlist is constructed will help us replicate the issue. Once we recreate the problem we can fix it. We just need to know how the playlist is constructed. Thanks. :)



#3 SpaceballOne OFFLINE  

SpaceballOne

    Newbie

  • Members
  • 2 posts
  • Local time: 05:53 PM

Posted 27 November 2019 - 11:56 AM

I am experiencing this issue with movie playlists that were created using the add to playlist option when selecting the title in the library with the web browser interface. I am specifically speaking to the not being able to see a title list when pushing the down button on the controller and only being able to play all or shuffle. I am on 3.0.199 beta.

Edited by SpaceballOne, 27 November 2019 - 12:01 PM.


#4 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 49140 posts
  • Local time: 07:53 PM

Posted 27 November 2019 - 01:24 PM

Hi.  You are on the beta version now, correct?

 

If so, I just want to move this over to the testing area so we can follow it there.  Your initial problem was fixed in beta, correct?

 

I also understand there are new issues with video playlists in the current beta.

 

Most of this is due to the fact that I think very few people use video playlists in Emby so it hasn't gotten as much testing as audio.

 

Thanks.







Also tagged with one or more of these keywords: Playlists, Bugs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users